No permission to change User Avatar?

Trying to change my User Avatar from System Settings. I am able to go the whole way through picking one of the presets or from a file, but Apply is greyed out, and if I hit OK I get a red banner at the top of the window saying: Could not get permission to save user ******(<---me)

What have I done to try to fix this?

  • 3 giant mugs of coffee
  • 2 hours of changing my search terms to see if I'm just not wording it properly
  • preparing to face palm when given a simple solution that I hadn't thought of

Any help would be appreciated. This isn't a matter of life and death for my install of Garuda, I'd just rather see something other than a big ol' S when I login....

1 Like

Post the image, I should be able to change it for you.

Welcome to Garuda.

sorry, to be clearer, on my desktop, NOT the forum.

Where is the graphics file located?

Try placing it in ~/Pictures.

Trying that now. Though it gives the same results with the preset options

What format is the image?

Yeah.... no dice

i've tried jpg and png

Perhaps it is too large.

the file i wanted to use is 2.2m, just for sh!ts and giggles i tried one that was 750kb, and i've cropped the image 6 ways from sunday. this really does appear to be a permissions issue

Can you change to any preexisting system image?

nope, i've tried all the different preset images

Don't know what to say, it's working for me. :man_shrugging:

:man_facepalming: :man_facepalming: :man_facepalming: :man_facepalming: :man_facepalming: :man_facepalming:

Reset ownership to your own user on your home directory:

sudo chown $USER:$USER ~ -R

trying that now. thanks for sticking with it and helping me troubleshoot

1 Like


╰─λ sudo chown $sturg:$sturg ~ -R
[sudo] password for sturg:
chown: missing operand after ‘/home/sturg’
Try 'chown --help' for more information.

sudo chown sturg:sturg ~ -R comes another facepalm moment

no change

i'm also out of daily replies for a new user. i'll try to search more, and come at this tomorrow after work..

1 Like

Maybe try
sudo chown -R $USER: $HOME

1 Like