No login screen on wake from sleep after recent updates

Sorry, you're on Gnome, I don't think the compositor can be shut down with Gnome.

1 Like

Apparently it cannot.

1 Like

I just stumbled upon the open source video driver which was already installed with Garuda

extra/xf86-video-nouveau 1.0.17-2 (90.8 KiB 222.9 KiB) [xorg-drivers] (Installed)

so my question is if I were to uninstall the nvidia driver completely (for troubleshooting this issue) then would the system automagically resue nouveau driver or will I have to handhold it ? If handholding is needed then what are the steps ?

The nvidia driver blacklists nouveau in order to be loaded and take control of the card.
When nvidia related packages are removed (including the blacklisting file, which belongs to them), then nouveau will control nvidia card, whether nouveau package is installed, or not, since it is included in the linux kernels (modesetting).


@petsam thanks for your quick reply.

So I can plan things ahead, say if the GUI does not render for some reason, can I boot into plain text mode ?? and reinstall Nvidia if I have to in case nouveau doesn't work. If that's possible then how do I boot into text mode

  • Edit grub menu entry (press E while at grub menu).
  • Go to the line that starts with linux . Delete splash and quiet and add (number) 3 at the end of the line.
  • Press F10 to boot.

Update: I uninstalled Nvidia drivers but the suspend issue still is not resolved. I even tried shutting off WiFi (I have no RJ45 connection) and BlueTooth completely before attempting Sleep ... but machine never wakes up.

I don't have snapshots from 3-4 days ago to restore to since I have update the system one too many times since and only so many snapshots are stored and older ones are deleted.

Please help.

If using nvidia, there is a fair chance there is some helping kernel parameter, but noone can know for sure.

Read your Mobo user manual for anything about Sleep modes (S3, S2 or similar) and alter them, if any. It's one possible solution to try.

Another thing is, after all this weird behavior and after your troubleshooting, it could be a HW issue. It happens several times that BIOS/firmware either reset, or clog. This is often solved clearing buffers, or updating firmware, or resetting BIOS.
You might want to try to remove power from your desktop for several minutes (hours?), or/and resetting BIOS battery.

Get whatever available info from the vendor's support and manuals.

Good luck!


Latest update: I switched to Garuda Dragonize kde on X11 and even though I am not getting consistent boot to GUI I was able to partially wake from sleep. The reason I say partially is the keyboard and mouse didn't work only the monitor showed the desktop background. Pleaee note at this time auto login is disabled.

Could someone pleaee nudge to further alleviate this problem?

Thanks in advance for your help

Check Archwiki on DPMS / suspend troubleshooting and test few of the service files examples. With KDE, you usually restart kwin or plasma.
No one solution fits all issues.


latest update: Just for the heck of it and to rule out any hardware issues. I installed latest Garuda KDE edition on a separate disk and the sleep wake works perfectly. So obviously it was some update that caused the issue.

I guess this is the bane of using rolling releases, you just don't know when you will get burned badly.

This is not the only possibility, I guess.
Other changes might have happened on the system by any package, application, utility or manually by the admin to break this feature.
Not that it is not by an updated package, but I added for clarity.

If you really want to pinpoint the issue, you may install Garuda (on a new spare drive?) on the same computer, check that sleep is working OOTB, reboot and upgrade your system.
After next reboot, you should have your answer... :person_shrugging:

I still suggest trying Arcwiki for solutions.


That's one reason why Snapshots are very very useful (as well as backups on another drive).
Please setup your snapshots management so next time this can be avoided and you can either test your changes within a snapshot prior to apply them on your main subvolumes or use a snapshot to rollback the changes.

Now the damage was done, but for next time....


Thanks for the wonderful tip. I knew snapshots were being created automatically on each update but I didn't know that they could experimented with like the way you describe.

Would you please share some documentation on that manual management of snapshot specifically the part of applying to subvolume before applying to main volume?

FYI I only have one ssd and separate backups of home folder not system folders.

Well I would go off topic if I start on Snapshots. lol However I believe you need a bit of guidance to avoid repeating a non-restore situation and I want to help.

I will respond to your question, but for any further information the answers will be found elsewhere in a few days or weeks.

That being said, you would have had less problems if you had enough snapshots to restore from, so it's a bit related.

It's not the 1st time I would like to refer someone to some sort of tutorial/explanation on snapshots and how to use them to prevent system breakage and rollback.
I will search the Forum and see if this exists already, if not I am very tempted to create one myself and use it for future references. Snapshots can save your system so they are important.

In the meantime, my suggestion is you at least increase the number of snapshots Snapper automatically takes. Hourly, Daily, Weekly, Monthly, use how you feel comfortable but make sure the number of PACMAN snapshots should be sufficient for your usage (default is 10 now, when activated). I would recommend to use 10 if you have disk space for it.
Then if something breaks, you restore a previous snapshot of root (@) and you are back on a clean system, giving you time to discuss here with people and search the web about your problem, rather than try to fix it in a hurry and make things worse.

As for applying the changes within a Snapshot before you apply on your main subvolumes, I have to understand better how Garuda uses Snapper by default, my test bench on a fresh Garuda install does not return good results at the moment (weird). This would be part of my potential tutorial if I can't find one. I don't use Snapper myself so I have to learn.

Again, plz increase your number of Snapshots, especially Pacman (assuming you have enough disk space to handle) and try to have at least 1 Snapshot taken per day, if you use your machine every day. This way when you need to restore you can chose any day and you don't need to think much about "what am I going to lose if I restore an old backup from 2 weeks ago?". :slight_smile:

Don't worry, I learned the hard way many times too! Snapshots and external SSD backups helped me learn a lot and also saved my life countless number of times (much less now cuz I better master my system after learning the hard way lol).

Now back on TOPIC, have you fixed your issue?
You installed on a 2nd SSD and it's fine. Do you consider this topic solved, then?


Hey tnx for that SGS!
Should be good reading for you @onkara . This short tutorial will explain how to restore if you broke the system.
As mentioned, make sure the number of snapshots will be sufficient in the future. :slight_smile:


I did temporarily fix the issue by reinstalling Garuda, sleep/wake worked fine. But as soon as I did a system update, sleep/wake stopped working.

I have spent quite significant time on this and unfortunately I can't continue to work like this and need to move on to a more predictable and stable distro.

Or post which files are *updated, or just use snapshot until the bug is fixed by a developer.

But developer needs your *information.


I recently started to experience the same issue. My system actually hangs and i need to physically reset it after sleep. this behavior started very recently, so i tried to restore to days back and it didn't fix the issue. for now I'm trying to roll forward as there are some updates available. I'm wondering if this is going to change things. if not i will try to restore to a week ago state.

[🔍] × garuda-inxi
Kernel: 5.17.5-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cfa490e8-fc51-4b99-b39e-9e21021d7ed1 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: ROG CROSSHAIR VIII FORMULA v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 0702
date: 07/04/2019
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3667 high: 4208 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3598 2: 3591
3: 3585 4: 3707 5: 3443 6: 3482 7: 3538 8: 4174 9: 3591 10: 3589 11: 3622
12: 3593 13: 3592 14: 3783 15: 3594 16: 3592 17: 3837 18: 4074 19: 3753
20: 3577 21: 3618 22: 3903 23: 3544 24: 3587 25: 4017 26: 3590 27: 3581
28: 3596 29: 3509 30: 4208 31: 3503 32: 3385 bogomips: 223583
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Micro-Star MSI driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,DP-3 empty: DP-1,HDMI-A-1 bus-ID: 0e:00.0
chip-ID: 1002:731f class-ID: 0300
Device-2: Afatech NarviCapture U3 HD60 4K Device type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1:2 chip-ID: 1b80:e104
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x2880 s-dpi: 96 s-size: 1354x762mm (53.31x30.00")
s-diag: 1554mm (61.17")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,bottom-l
model: Samsung C49RG9x serial: <filter> built: 2018 res: 5120x1440 hz: 120
dpi: 109 gamma: 1.2 size: 1190x340mm (46.85x13.39") diag: 1239mm (48.8")
modes: max: 5120x1440 min: 720x400
Monitor-2: DP-3 mapped: DisplayPort-2 pos: top-right
model: LG (GoldStar) ULTRAWIDE serial: <filter> built: 2015 res: 3440x1440
hz: 60 dpi: 109 gamma: 1.2 size: 800x335mm (31.5x13.19")
diag: 867mm (34.1") modes: max: 3440x1440 min: 640x480
OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 13.0.1 DRM 3.44
v: 4.6 Mesa 22.0.3 direct render: Yes
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0e:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 10:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Afatech NarviCapture U3 HD60 4K Device type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1:2 chip-ID: 1b80:e104
class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.17.5-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.51 running: yes
Device-1: Aquantia AQC111 NBase-T/IEEE 802.3bz Ethernet [AQtion]
vendor: ASUSTeK driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 1 link-max: lanes: 4 port: N/A bus-ID: 06:00.0 chip-ID: 1d6a:11b1
class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-6:4 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 4.55 TiB used: 1.7 TiB (37.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7
temp: 48.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 4TB
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
ID-1: / raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 69.36 GiB (71.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 500.7 MiB size: 499.7 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /home raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 69.36 GiB (71.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 69.36 GiB (71.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 69.36 GiB (71.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.78 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 56.0 C mobo: 39.0 C gpu: amdgpu temp: 64.0 C
mem: 66.0 C
Fan Speeds (RPM): cpu: 990 gpu: amdgpu fan: 0
Processes: 640 Uptime: 23m wakeups: 0 Memory: 62.78 GiB
used: 7.23 GiB (11.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1641 lib: 405 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.3-2):
System install date:     2022-03-17
Last full system update: 2022-05-19 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:```