No input when making a new shortcut

I wanted to set Flameshot as my default screenshot tool and when I go to settings and then custom shortcuts; I cant set the ¨Prt sc¨ button as the trigger shortcut. In fact, I can't set any button as my trigger shortcut. This doesn´t affect the normal shortcuts. Just the Custom Shortcuts.

This is my system specs

System: Kernel: 5.10.2-104-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=4d2c60da-02b9-4ea9-9435-7f92c5aaa813 rw [email protected] quiet 
           cryptdevice=UUID=36904169-cbae-411a-98c5-d54857620d41:luks-36904169-cbae-411a-98c5-d54857620d41 
           root=/dev/mapper/luks-36904169-cbae-411a-98c5-d54857620d41 splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC v: 0896100000304100000620100 
           serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 2163 v: 29.42 serial: <filter> UEFI: Insyde v: F.72 date: 03/09/2018 
Battery:   ID-1: BAT0 charge: 23.2 Wh condition: 23.2/23.2 Wh (100%) volts: 16.9/14.8 model: Hewlett-Packard Primary 
           type: Li-ion serial: N/A status: Full 
CPU:       Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 45 (69) 
           stepping: 1 microcode: 26 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13583 
           Speed: 1572 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1572 2: 1596 3: 1574 4: 1596 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a16 
           Device-2: Suyin HP Truevision HD type: USB driver: uvcvideo bus ID: 2-3:3 chip ID: 064e:e264 serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0a0c 
           Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:9c20 
           Sound Server: ALSA v: k5.10.2-104-tkg-bmq 
Network:   Device-1: Realtek RTL8188EE Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8188ee v: kernel port: 4000 
           bus ID: 08:00.0 chip ID: 10ec:8179 
           IF: wlo1 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 
           bus ID: 09:00.0 chip ID: 10ec:8136 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 698.64 GiB used: 31.07 GiB (4.4%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD7500BPVX-60JC3T0 size: 698.64 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A01 
Partition: ID-1: / raw size: 187.73 GiB size: 187.73 GiB (100.00%) used: 31.04 GiB (16.5%) fs: btrfs dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-36904169-cbae-411a-98c5-d54857620d41 
           ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) used: 28.4 MiB (29.6%) fs: vfat dev: /dev/sda2 maj-min: 8:2 
           ID-3: /home raw size: 187.73 GiB size: 187.73 GiB (100.00%) used: 31.04 GiB (16.5%) fs: btrfs dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-36904169-cbae-411a-98c5-d54857620d41 
           ID-4: /var/log raw size: 187.73 GiB size: 187.73 GiB (100.00%) used: 31.04 GiB (16.5%) fs: btrfs dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-36904169-cbae-411a-98c5-d54857620d41 
           ID-5: /var/tmp raw size: 187.73 GiB size: 187.73 GiB (100.00%) used: 31.04 GiB (16.5%) fs: btrfs dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-36904169-cbae-411a-98c5-d54857620d41 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 221 Uptime: 6h 17m wakeups: 1 Memory: 15.56 GiB used: 3.63 GiB (23.3%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.0.0 Packages: pacman: 1223 lib: 345 Shell: fish v: 3.1.2 running in: konsole inxi: 3.2.00

Sorry for the bother.

Check if the khotkeys package is installed.

1 Like

just installed/reinstalled it just in case and it didn't really do the trick. maybe somehow it´s not running.

im gonna try removing the official one and getting the Aur one

Reinstalling didn't help and the Aur one doesn't wanna install. I mean I still have the normal way of using Flameshot but would be nice if in can be able to to use it natively.

Is there anything else i can try? I can set it somehow with the normal shortcuts even tho I tried that

One of the reasons that Flameshot isn't installed by default is because of its recent buginess.

It's not about flameshot.
I also have this bug with custom shortcuts for some time. This confirms it's a bug.
It has to be reported upstream kde bugs, if not already done.

2 Likes

I have just found a workaround, if not the new Plasma way for Custom Shortcuts :grinning_face_with_smiling_eyes:.

  1. Create a new group in Custom Shortcuts (maybe optional)
  2. Create a new custom shortcut, set the activation command and save
  3. Make sure the group is enabled
  4. Go to System shortcuts and select Custom shortcuts service
  5. This group should contain your new custom shortcut (use a unique name to make it easy recognizable)
  6. Assign a key combination as usual

The above worked for me successfully. I tested with success!!!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.