No Date & Time in i3 menu bar

System:
  Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=0167ca6b-15b5-45fb-837d-ba98603369a0 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: i3 4.20.1 info: i3bar dm: LightDM 1.30.0 Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 3593 v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 04N9HV v: A00 serial: <filter> UEFI: Dell v: 1.19.0
    date: 12/10/2021
Battery:
  ID-1: BAT0 charge: 30.1 Wh (100.0%) condition: 30.1/42.0 Wh (71.6%)
    volts: 12.8 min: 11.4 model: SMP DELL VM73297 type: Li-poly
    serial: <filter> status: Full
CPU:
  Info: model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xA8
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1135 high: 1914 min/max: 400/3600 base/boost: 1400/1200
    scaling: driver: intel_pstate governor: powersave volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 1914 2: 1102 3: 1018 4: 1048 5: 1001 6: 1000
    7: 1001 8: 1001 bogomips: 19046
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:4 chip-ID: 0bda:5520 class-ID: 0e02 serial: <filter>
  Display: server: X.Org 1.21.1.3 driver: loaded: intel
    unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143
    size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel bus-ID: 02:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:5
    chip-ID: 0cf3:e009 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
Drives:
  Local Storage: total: 1.16 TiB used: 201.46 GiB (17.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1002
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 model: AAR256GM061320030 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 7A0 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Generic model: Flash Disk
    size: 14.65 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 8.07 scheme: MBR
Partition:
  ID-1: / raw-size: 116.5 GiB size: 116.5 GiB (100.00%)
    used: 25.34 GiB (21.8%) fs: btrfs block-size: 4096 B dev: /dev/sdb4
    maj-min: 8:20
  ID-2: /boot/efi raw-size: 700 MiB size: 698.6 MiB (99.80%)
    used: 596 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sdb3
    maj-min: 8:19
  ID-3: /home raw-size: 116.5 GiB size: 116.5 GiB (100.00%)
    used: 25.34 GiB (21.8%) fs: btrfs block-size: 4096 B dev: /dev/sdb4
    maj-min: 8:20
  ID-4: /var/log raw-size: 116.5 GiB size: 116.5 GiB (100.00%)
    used: 25.34 GiB (21.8%) fs: btrfs block-size: 4096 B dev: /dev/sdb4
    maj-min: 8:20
  ID-5: /var/tmp raw-size: 116.5 GiB size: 116.5 GiB (100.00%)
    used: 25.34 GiB (21.8%) fs: btrfs block-size: 4096 B dev: /dev/sdb4
    maj-min: 8:20
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.54 GiB used: 2 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3121
Info:
  Processes: 282 Uptime: 38m wakeups: 1 Memory: 7.54 GiB
  used: 3.6 GiB (47.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: apt: 0 pacman: 1264 lib: 349
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: alacritty
  inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-01-18
  Last full system update: 2022-02-05
  Is partially upgraded:   No
  Relevant software:       tlp NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service

My I3 menubar does not show date and time.THough I have the following in my ~/.config/i3status/config

tztime local {
format = "%Y-%m-%d %H:%M:%S"
hide_if_equals_localtime = true

locale = "en_IN.UTF-8"
}

My locale output

LANG=en_IN
LC_CTYPE="en_IN"
LC_NUMERIC=en_IN
LC_TIME=en_IN
LC_COLLATE="en_IN"
LC_MONETARY=en_IN
LC_MESSAGES="en_IN"
LC_PAPER=en_IN
LC_NAME=en_IN
LC_ADDRESS=en_IN
LC_TELEPHONE=en_IN
LC_MEASUREMENT=en_IN
LC_IDENTIFICATION=en_IN
LC_ALL=
2 Likes

Even after putting this

tztime local {
format = "%Y-%m-%d %H:%M:%S"
hide_if_equals_localtime = true
}

tztime berlin {
format = "%Y-%m-%d %H:%M:%S %Z"
timezone = "Europe/Berlin"
}

still cant see date and time in i3 menu bar

Reboot or super + shift + r

2 Likes

still no date and time :frowning:

Do you live in Germany?

1 Like

NO,i live in India

Maybe?

You see it work for me, did you see something or nothing about time and date?

or try

tztime local {
# format = "%Y-%m-%d %H:%M:%S    %Z  "
# format = "<span color='#ffffff'>%time</span>"
format = " ◔ %H:%M:%S | %a. %d.%m.%Y "
locale = "de_DE.UTF-8"
}

locale to India.

2 Likes

image

Thanks a Lot

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.