No Controller Detection

Hello Garuda users.

New to Garuda, just did my first install and i'm already hooked. However one thing that's not aligning is my controller support, tried USB connection to a generic Xbox One controller and my preferred Razer Wolverine. No detection despite lighting up. I have the drivers it comes with and I've also tries getting udev, and other randoms from the AUR. Is it something I forgot to do upon setup?

Have you tried any of the packages in Garuda Welcome -> Garuda Gamer? Way down below within the Garuda Gamer selection there should be 2 different Xbox One controller packages: xpadneo-dkms and xone-dkms . Try them one at a time and see what works best for you (most likely going to need a restart after you install one, since they are kernel modules).

6 Likes

Thanks :joy: I feel dumb now, I thought i'd be set with the one that just said xbox-generic-controller.
New to Linux in general I feel i should add lol

Welcome! I think you'll like the Linux gaming experience here. Proton/Wine has made a lot of games playable over the years that is for sure.

2 Likes

Thanks, so far I certainly do. Had Ubuntu several years ago, and messed with EndeavourOS a few times before jumping over here, definitely seems to be coming along nicely.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.