No audio output through bluetooth headphones (OnePlus Buds Z)

I was using Garuda Linux about 2 months ago when I had a problem with my bluetooth earphones autoconnecting and disconnecting immediately. It wasn't resolved, so I decided to try out other Linux distros, and I experienced the same problem in Ubuntu and every other distro I tried.

I recently started using Garuda Linux again, but this time, I noticed a different problem. When I pair my earphones, they no longer have the autoconnect problems, and as an added bonus, the HSP/HFP profile also works now, which is absolutely amazing. But the problem is that there is absolutely no audio output when I select the profile as A2DP. Can someone help me with this? I'm using pipewire.

Output of inxi -Fxxxza is below.

System:    Kernel: 5.10.43-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=5e2e53f2-6c23-46cc-afcb-8563ce9b8a27 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=ae1ee1b4-f1ae-4d2c-90f9-74598416514d loglevel=3 
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 5567 v: N/A serial: <filter> Chassis: type: 10 
serial: <filter> 
Mobo: Dell model: 02YHJP v: A00 serial: <filter> UEFI: Dell v: 1.2.8 date: 05/22/2019 
Battery:   ID-1: BAT0 charge: 12.4 Wh (100.0%) condition: 12.4/42.0 Wh (29.6%) volts: 12.6 min: 11.4 
model: Samsung SDI DELL C4HCW6B type: Li-ion serial: <filter> status: Full 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
note: check family: 6 model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
Speed: 3100 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3100 2: 3100 3: 3100 4: 3100 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
chip-ID: 8086:5916 class-ID: 0300 
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 
chip-ID: 0c45:6a06 class-ID: 0e02 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati,intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.2 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
Sound Server-1: ALSA v: k5.10.43-1-lts running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: no 
Sound Server-4: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus-ID: 02:00.0 
chip-ID: 8086:3165 class-ID: 0280 
IF: wlp2s0 state: up mac: <filter> 
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel 
port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:7 
chip-ID: 8087:0a2a class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter> 
Drives:    Local Storage: total: 447.13 GiB used: 34.99 GiB (7.8%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: R022
scheme: GPT
Partition: ID-1: / raw-size: 438.08 GiB size: 438.08 GiB (100.00%) used: 34.99 GiB (8.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 438.08 GiB size: 438.08 GiB (100.00%) used: 34.99 GiB (8.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 438.08 GiB size: 438.08 GiB (100.00%) used: 34.99 GiB (8.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 438.08 GiB size: 438.08 GiB (100.00%) used: 34.99 GiB (8.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
maj-min: 8:3
ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 48.0 C mobo: 45.0 C sodimm: SODIMM C gpu: amdgpu temp: 48.0 C
Fan Speeds (RPM): cpu: 4441
Info:      Processes: 213 Uptime: 6h 10m wakeups: 1 Memory: 7.67 GiB used: 3.78 GiB (49.3%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1873 lib: 344
Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.04

I tried the linux-lts kernel, the linux kernel and the default linux-zen kernel, but none of them seemed to fix the issue. The audio output in the HSP/HFP profile works really well, but the quality isn't really that good, which is what is expected. I need the A2DP profile audio, as its much higher quality, and makes music enjoyable. HSP/HFP straight up ruins the quality, but I'm pleasantly surprised to see it work. Can someone help me fix the audio output on the A2DP profile please? I will not be active right now, its 11 pm at the time of posting, so I'll be gone for a while before I can reply to any solutions. Any help is appreciated. (I am using the blackarch version of Garuda Linux, the Dr46onized edition)


I think we move to unsupported software. Why you post in Qtile?

Seems your hardware is not in the kernel?

1 Like

Check this troubleshooting article.

Also, you may try with pavucontrol (install it if it's not already).

2 Likes

I tried switching with Pavucontrol too, but even that didn't work.

I couldn't get it working after creating the udev rule as per the script mentioned in the article you linked. Although I did find something interesting. Is this related?

This is the output of pactl list sinks

Sink #42
State: RUNNING
Name: alsa_output.pci-0000_00_1f.3.analog-stereo
Description: Built-in Audio Analog Stereo
Driver: PipeWire
Sample Specification: s32le 2ch 48000Hz
Channel Map: front-left,front-right
Owner Module: 4294967295
Mute: no
Volume: front-left: 57016 /  87% / -3.63 dB,   front-right: 57016 /  87% / -3.63 dB
balance 0.00
Base Volume: 65536 / 100% / 0.00 dB
Monitor Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
Latency: 0 usec, configured 0 usec
Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
Properties:
object.path = "alsa:pcm:0:front:0:playback"
api.alsa.path = "front:0"
api.alsa.pcm.card = "0"
api.alsa.pcm.stream = "playback"
audio.channels = "2"
audio.position = "FL,FR"
device.routes = "2"
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "ALC3246 Analog"
alsa.id = "ALC3246 Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xdf328000 irq 130"
alsa.driver_name = "snd_hda_intel"
device.profile.name = "analog-stereo"
device.profile.description = "Analog Stereo"
card.profile.device = "8"
device.id = "39"
factory.name = "api.alsa.pcm.sink"
priority.driver = "1009"
priority.session = "1009"
media.class = "Audio/Sink"
node.nick = "HDA Intel PCH"
node.name = "alsa_output.pci-0000_00_1f.3.analog-stereo"
device.description = "Built-in Audio Analog Stereo"
device.icon_name = "audio-card-analog"
node.pause-on-idle = "false"
factory.id = "18"
client.id = "31"
node.driver = "true"
factory.mode = "merge"
audio.adapt.follower = ""
library.name = "audioconvert/libspa-audioconvert"
object.id = "42"
node.max-latency = "8192/48000"
Ports:
analog-output-speaker: Speakers (type: Speaker, priority: 10000, availability group: Legacy 3, availability unknown)
analog-output-headphones: Headphones (type: Headphones, priority: 9900, availability group: Legacy 2, not available)
Active Port: analog-output-speaker
Formats:
pcm

Sink #78
State: SUSPENDED
Name: bluez_output.E4_41_22_37_FF_C1.a2dp-sink
Description: OnePlus Buds Z
Driver: PipeWire
Sample Specification: s16le 2ch 48000Hz
Channel Map: front-left,front-right
Owner Module: 4294967295
Mute: no
Volume: front-left: 42598 /  65% / -11.23 dB,   front-right: 42598 /  65% / -11.23 dB
balance 0.00
Base Volume: 65536 / 100% / 0.00 dB
Monitor Source: bluez_output.E4_41_22_37_FF_C1.a2dp-sink.monitor
Latency: 0 usec, configured 0 usec
Flags: HARDWARE HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY
Properties:
api.bluez5.transport = ""
api.bluez5.profile = "a2dp-sink"
api.bluez5.codec = "aac"
api.bluez5.address = "E4:41:22:37:FF:C1"
device.routes = "1"
card.profile.device = "1"
device.form_factor = "headset"
device.bus = "bluetooth"
device.id = "68"
device.description = "OnePlus Buds Z"
node.name = "bluez_output.E4_41_22_37_FF_C1.a2dp-sink"
factory.name = "api.bluez5.a2dp.sink"
priority.driver = "1010"
priority.session = "1010"
device.icon_name = "audio-headset-bluetooth"
node.pause-on-idle = "false"
factory.id = "8"
device.api = "bluez5"
media.class = "Audio/Sink"
node.driver = "true"
node.latency = "512/48000"
factory.mode = "merge"
audio.adapt.follower = ""
library.name = "audioconvert/libspa-audioconvert"
object.id = "78"
client.id = "30"
Ports:
headset-output: Headset (type: Headset, priority: 0, available)
Active Port: headset-output
Formats:
pcm

It says that Sink #78 State is SUSPENDED. Does that have something to do with this?

Also, thank you for quick reply

Oh GOD. I thought I had posted in Network Assistance. Terribly sorry.

Greetings Brother, If Your Problem Continues, You Should Install Alsamixer On Your Computer And Your Problem Will Be Solved With The Help Of Alsamixer By Introducing The Hardware :slight_smile: :+1:

1 Like

L├╝tfen, yaln─▒zca dil alan─▒n─▒n d─▒┼č─▒nda ─░ngilizce kullan─▒n.
Please, use only English outside the language area.

3 Likes

Ummmm, I'm sorry, but can you please elaborate?