New Plasma Theme Unstable

I'd think that removing Latte-Dock would make Garuda a lot more stable. However, it's been 3 times that the Plasma theme crashes. It is still not quite stable. On Zen kernel right now (alternating between Zen and Xanmod)

I'm also noting a round-shaped overlay from the old theme that sometimes appears on the new bottom Plasma bar, that feels off.


Kernel: 6.1.12-zen1-1.1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=58203bda-e2e2-4c32-a006-c91d933cad4e rw [email protected]
loglevel=3 quiet intel_iommu=on iommu=pt ibt=off
Desktop: KDE Plasma v: 5.27.1 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Predator PH315-53 v: V1.01
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V1.01 serial: <superuser required>
UEFI: Insyde v: 1.01 date: 04/27/2020
ID-1: BAT1 charge: 41.6 Wh (99.5%) condition: 41.8/58.8 Wh (71.2%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: not charging
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF4
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2571 high: 3201 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 1092 2: 3200 3: 3201
4: 3200 5: 3200 6: 1300 7: 3197 8: 3200 9: 2004 10: 1744 11: 3201 12: 2317
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 515.76
alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2023-02) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-2
empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 mapped: eDP-1-1 note: disabled model: AU Optronics 0x82ed
built: 2018 res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6.0 NVIDIA 515.76 renderer: NVIDIA GeForce RTX
2060/PCIe/SSE2 direct-render: Yes
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 1-1.3:6 chip-ID: 08bb:29b0
alternate: snd_soc_skl,snd_sof_pci_intel_cnl class-ID: 0300
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.12-zen1-1.1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.66 running: yes
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.0
chip-ID: 10ec:2600 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
IF-ID-2: virbr1 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:5 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 1.63 TiB used: 1.31 TiB (80.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 11101100 temp: 24.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: A3J0 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT275MX300SSD4
size: 256.17 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: R060 scheme: GPT
ID-1: / raw-size: 468.84 GiB size: 468.84 GiB (100.00%)
used: 440.93 GiB (94.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:3
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 51.2 MiB (53.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 468.84 GiB size: 468.84 GiB (100.00%)
used: 440.93 GiB (94.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:3
ID-4: /var/log raw-size: 468.84 GiB size: 468.84 GiB (100.00%)
used: 440.93 GiB (94.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:3
ID-5: /var/tmp raw-size: 468.84 GiB size: 468.84 GiB (100.00%)
used: 440.93 GiB (94.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.46 GiB used: 3.76 GiB (24.3%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 61.0 C pch: 77.0 C mobo: N/A gpu: nvidia
temp: 61 C
Fan Speeds (RPM): N/A
Processes: 407 Uptime: 2d 2h 40m wakeups: 1 Memory: 15.46 GiB
used: 7.64 GiB (49.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 alt: 11 clang: 15.0.7 Packages:
pm: pacman pkgs: 2092 libs: 552 tools: octopi,pamac,paru pm: appimage
pkgs: 0 Shell: fish v: 3.6.0 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2021-11-24
Last full system update: 2023-02-25
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            systemd-sysctl.service

Please post as text the output from

systemctl status systemd-sysctl.service

Got no clue what that means.

× systemd-sysctl.service - Apply Kernel Variables
Loaded: loaded (/usr/lib/systemd/system/systemd-sysctl.service; static)
Active: failed (Result: exit-code) since Sat 2023-02-25 20:50:28 EST; 2 days ago
Docs: man:systemd-sysctl.service(8)
Process: 620 ExecStart=/usr/lib/systemd/systemd-sysctl (code=exited, status=1/FAILURE)
Main PID: 620 (code=exited, status=1/FAILURE)
CPU: 5ms

Feb 25 20:50:28 Hanuman-PC systemd[1]: Starting Apply Kernel Variables...
Feb 25 20:50:28 Hanuman-PC systemd-sysctl[620]: Couldn't write 'nr_hugepages' to 'vm/nr_hugepages': Invalid a>
Feb 25 20:50:28 Hanuman-PC systemd[1]: systemd-sysctl.service: Main process exited, code=exited, status=1/FAI>
Feb 25 20:50:28 Hanuman-PC systemd[1]: systemd-sysctl.service: Failed with result 'exit-code'.
Feb 25 20:50:28 Hanuman-PC systemd[1]: Failed to start Apply Kernel Variables.

and here's a screenshot of the bogus round shape appearing at the bottom sometimes, kind of flickery

When you removed latte, did you complete the migration? Was the removal prompted after garuda-update? Migration info to confirm it's done correctly:


First off, I also have instabilities with 5.27. kwin_wayland crashes when I click on certain close buttons or click on full screen button on a youtube. About once a day this happens. This is not the new theming.

Secondly, the round thing you mention, is it this darker bar?


That is part of Plasma Themes, it's called the Glow Bar and identifies that portion of the screen so you can use Screen Edges features from Plasma. It is easily removeable from the theme, but if we do that, those using screen edges will have no highlight on the edge of the screen. I have thought about this for months! But could not find a way to automatically remove it for those not using screen edges.


You don't know what nr_hugepages is?
Me too, but it breaks systemd-sysctl.service
Typically this is a very scarce resource on processor.
Operating systems try to make best use of limited number of TLB resources.
This optimization is more critical now as bigger and bigger physical memories
(several GBs) are more readily available.

Maybe this make your theme unstable.


Sadly, I have to agree about the recent stability problems.
I have many 'locale' errors after Garuda offered to install missing Language Packs.
Only this morning, an update broke my Howdy facial recognition which I'm working to fix.

Where can i find the very latest Drag460nized .iso?
I can feel a re-install coming on :slight_smile:

It is still at 221019 if you are refering to official ISO builds.

Thanks, I'll see if there is a fix for the Howdy issues before i dive in to a re-install


I know what hugepages is, it's an optimization useful for VM. I don't know what systemd-sysctl.service is though.

Looks like there's an issue with hugepages that will need to be investigated.

Could it also be a bad "defective" widget? You might want to try a clean new panel and slowly add in widgets one at a time.

I know in the past the 'Event Calendar' widget had caused major issues with my desktop until updated.


It must look like this

systemctl status systemd-sysctl.service
● systemd-sysctl.service - Apply Kernel Variables
     Loaded: loaded (/usr/lib/systemd/system/systemd-sysctl.service; static)
     Active: active (exited) since Tue 2023-02-28 20:12:44 CET; 37min ago
       Docs: man:systemd-sysctl.service(8)
   Main PID: 349 (code=exited, status=0/SUCCESS)
        CPU: 3ms


Now I get

● systemd-sysctl.service - Apply Kernel Variables
Loaded: loaded (/usr/lib/systemd/system/systemd-sysctl.service; static)
Active: active (exited) since Thu 2023-03-02 02:28:37 EST; 4min 57s ago
Docs: man:systemd-sysctl.service(8)
Process: 376 ExecStart=/usr/lib/systemd/systemd-sysctl (code=exited, status=0/SUCCESS)
Main PID: 376 (code=exited, status=0/SUCCESS)
CPU: 470ms

Mar 02 02:28:37 Hanuman-PC systemd[1]: Finished Apply Kernel Variables.
Notice: journal has been rotated since unit was started, output may be incomplete.

And Plasma layout just crashed/restarted again.

Is 19/10/22 the date of the ISO? The reason I ask is I've heard from a lot of people that a rolling release should be updated at least every month to help prevent issues, and Arch uses this time period for its releases Arch Linux - Releases. 19/10/22 is a lot longer than a month ago.

If I'm wrong about the ISO date please accept my apologies for making this point.

Sadly yes.

Just to add a bit of context to my previous moan.

The problems with Howdy Facial Recognition are caused by updates to VTK, Python-opencv and opencv.
Editing pacman.conf to ignore updates to these three programs is a temporary fix whilst someone clever comes up with a permanent fix.
Update (Someone clever did come along, the pacman updates are fixed, the ignore package is removed and all is OK with Howdy again).

My 'Locale' errors were actually caused by Bleachbit (I know!!) Last time I use that PoS. It seems Bleachbit deleted my Locale directory to 'clean it up' and it is being rebuilt slowly.

Bleachbit, I think, is included in the Garuda Welcome as a System Cleaner. It is not fit for purpose. Can I suggest you change Bleachbit for Stacer as your default System Cleaner.


I used this yesterday, worked well out-of-the-box. Note this is still not an official build at this moment.

@Colin This is rolling release, so when you download an ISO it doesn't matter significantly how old it is, as long as it installs and can update. Here are some examples to maybe help:

  • EX 1: Old ISO comes with older kernel, maybe you have new AMD GPU only supported on new kernel, now you have an actual need for new ISO with newer kernel.

  • EX 2: You have an old ISO it will come with Latte, which is removed and migrated from when you update, but maybe Latte existing in the first place causes crashes before you can update, then that's reason for a new ISO.

  • EX 3: Calamares installer has hypothetically patched a problem that disallowed you to custom format a disk during install, that's reason to build new ISO with a newer Calamares.

@Hamster1962 These applications have some feature overlap, but I don't view them as direct replacements. When I open Welcome and I click on system cleaner, it does try to launch Stacer, not BleachBit... :confused:


Could be he installed Garuda from an ISO that had Bleachbit (was the case in the past) and never made the switch when the ISO did.


Thanks for the response. I was always a bit nervous about BleachBit previously. This is the first time it killed some of my install. I really don't want to re-install which is why I use a rolling release.
I managed to fix most if not all things.
We have a saying in the wild North of UK, once bitten, twice shy.
Stacer for me from now onwards.