New Install Failed

Hi seems like there's a lot of potential issues.

For context:
On Windows 10 + set aside ~150gbs of unallocated partition
Downloaded garuda-dr460nized-linux-zen-210507.iso [checksum seemed okay]
Used etcher to "flash from file" to 16gb USB drive [also tried rufus and redid etcher]

In UEFI BIOS, Secure boot disabled, I am able to reach the Garuda selection screen (not the desktop environment).

Selecting the non/open source drivers both fail with the error below.

I am unsure how to get a terminal in here and unsure how to get a log or how to copy and paste from here but I'll type what I can:

Most things are

[    OK   ]
.
.
.
.
.
[    OK   ] Started Daemon that prevent eviction of executables/libraries from memory.
     Starting User Login Management...
     Starting Manage swap spaces on zram, files and partitions...
     Starting Ananicy - Another Auto NICe daemon...
[FAILED] Failed to start Avahi mDNS/DNS-SD Stack
[FAILED] Failed to start Network Manager
[FAILED] Failed to start LiveMedia MHWD Script
[FAILED] Failed to start LiveMedia Pacman mirror ranking script
[FAILED] Failed to start Authorization Manager

[    OK   ] Reached the target Network
[    OK   ] Started D-Bus System Message Bus.
    Starting Permit User Sessions...
[    OK   ] 
[    OK   ] 
[    OK   ] 
[    OK   ] 
[    OK   ]  
[FAILED] to start D-Bus System Message Bus.
[FAILED] swap spaces on zram, files and partitions...
[FAILED] Failed to start Network Manager

then its just a bunch of more faileds
I can attach a picture later if needed, but I figure its just one thing causing all the rest such as not connecting to the network? I tried plugging into an ethernet cable instead of wifi with no change in the errors.

Use forum search function first. :slight_smile:
No pictures from terminal output, please.
Read

please
and post

inxi -Fxxxza

as text!

Even if you personally think it is unnecessary.

and
:slight_smile:

2 Likes

Hi thanks for the reply I gave all the links a read, hopefully I didn't miss anything and can format correctly (am on mobile at the moment as well).

Include the output of “inxi -Fxxxza” in your post.

If I'm not mistaken the above is how you would get a log to submit?
Is there a way to get here from a USB install? I couldn't seem to enter it anywhere as I can't seem to reach the desktop environment/a terminal

Also the laptop configuration you linked appears to be customizing the install from a Linux machine? Is that correct? Is there a way to download the laptop configuration or to create the configuration from windows? Sorry for all the questions and mistakes am definitely new here

Sounds like you can't even boot into the live environment so I don't think inxi output is possible. Have you checked the guide on dual booting garuda? That might shed some light on your issue. Also I flashed garuda to usb with rufus just fine. Been running it for a few months now no problems.

Yeah doesn't seem like I'm reaching the live environment.

Just looked the dual boot guide up after you mentioned it and it appears a potential culprit is having just the partition space sitting there as unallocated could be an issue instead of formatted ready to overwrite (recently did a kubuntu install and from memory I reached the live environment first and was able to shrink/grow/set the type from here so I overlooked it here)

Will attempt and update in the morning :slight_smile:

Just one idea...
Could you please check that SATA mode in the BIOS is set to AHCI and not RAID or even IDE?

2 Likes

In my experience dual booting I didn't have such an issue. You can try @filo 's suggetion however be warned that windows might throw a fit when you change it. It hadn't happened to me but I have seen the warning when I was looking into dual booting.

This normally means the image is corrupt in some way. Download again, try a different method of writing to the USB medium (maybe try Ventory?), try a different USB port, and try another USB flash drive.

2 Likes

@filo just confirmed SATA mode in BIOS is already set to AHCI, no luck there
@Khsh01 yeah doesn't seem that's changed anything
@jonathon I'll give that a try right now and will update, I downloaded initially:
from Sourceforge garuda-dr460nized-linux-zen-210507.iso, will give direct Fosshost download a try and along with a new port and USB

2 Likes

Just did a fresh download from Fosshost and imaged to new USB with new port, still no luck seems to be same error.

Wish I could export a log, but appears to be the same errors as always;

forgot to note though there is also:

[DEPEND] Dependency failed for Modem Manager

and all the way at the bottom after a lot of the faileds it loops between

.
.
.
[FAILED] Failed to start Ananicy - ANother Auto NICe daemon.

[FAILED] Failed to start User Login Management.
[FAILED] Failed to start  D-Bus System Message Bus.
[FAILED] Failed to start User Login Management.
[FAILED] Failed to start  D-Bus System Message Bus.
[FAILED] Failed to start User Login Management.
[FAILED] Failed to start  D-Bus System Message Bus.
[FAILED] Failed to start User Login Management.
[FAILED] Failed to start  D-Bus System Message Bus.

Do you have anything plugged in on your USB ports? Joypad, bluetooth ot stuff like that? If yes, take them off before to boot.

That's really weird btw, did you check sha256sum of your iso?

@Stardust nothing plugged into the USB ports, have also previously run a sha256sum with no issue :confused:

Try a different image/ISO.
Try a Barebones edition.

Stupid idea : There is an android app called Etchdroid that can flash iso images to usb. Maybe try that?

@petsam have a download running now for the barebones, will give that an install in the morning

@Khsh01 did a quick look at it, unsure what issue that addresses? I also don't have an adapter for my phone to a USB, so don't think thats the route for me, but curious what was your thought process for that?
Flashing the iso seems okay to me, and I have tried it from a Mac and PC, so if its a variety of options just to figure out the point of failure I think I'm okay for that part.

Thats why I started with "Stupid Idea". Just trying a different method to flash the iso to usb. I have found that to help at certain times. :rofl:

Edit: Just a thought but what are you using to download the iso? I have in the past tried to download with kget and even though it downloaded the file was completely corrupt.

My two cents...
Why not give a chance also to the good old dd?

sudo dd if=/dev/zero of=/dev/sdX bs=1m
sudo dd if=file.iso of=/dev/sdX

@Khsh01 haha all good, and I am just using the download page here, Sourceforge, Direct(Fosshost)

@petsam Just gave the KDE barebones install a try seems to be the same failure messages EDIT: I'll be switching back to the main version, just because that's the end product I want to install either way and it is "supported"

@filo I'll give that. a try right now :+1: EDIT: imaged using dd, same errors no changes

Then it seems closer to a HW issue (considering ISO is not corrupt, USB drive is good, more than 1 kernel tried).
Out of curiosity, what are your HW specs?
Have you checked min requirements for Garuda?

Maybe try another distro installer (preferably Arch based), to exclude any Garuda ISO bug.

1 Like

@petsam do you think theres any issue with specs below?:

|Processor|Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz   1.99 GHz|
|Installed RAM|16.0 GB (15.9 GB usable)|
|System type|64-bit operating system, x64-based processor|

I have a kubuntu bootable usb ready to go, I'll give it an install, are there any options for upgrading from a Arch [or ubuntu] environment to Garuda?