Networkmanager and wpa_supplicant won't shutdown since kernel 6.6.5

Hello,

Since the last kernel update (6.6.5) system can’t shutdown or reboot because networkmanager and wpa_supplicant won’t shutdown, it’s not related to Garuda as i saw the same problem on arch forum but for those who have this problem just restore a snapshot with an older kernel version (i took one from 2 days ago with 6.6.4) and the system Shutdown and reboot normaly.

yup same issue for me . There’s iwd as an alternative .
but i couldn’t find a setup guide to switch to iwd .
Request for garuda maintainers to provide a setup guide to switch to iwd .

I don’t suppose either of you tried a different kernel? I read the Arch thread and switching kernels (to LTS) didn’t work for one user.

The problem seems to be specific network cards.

4 Likes

Yes with a snapshot from 2 days ago and Kernel 6.6.4 it works normaly, it’s just the 6.6.5 that cause that problem.

666 is out now.

4 Likes

You mean the devil, right? :grin:

1 Like
5 Likes

The End Times are near!!!
I guess we may now add one to the list.

1 Like

You can manually add iwd yourself, (if you want to test out iwd).


How to replace wpa_supplicant with iwd:


With a text editor, create the required iwd configuration file for Network Manager:

/etc/NetworkManager/conf.d/wifi_backend.conf

With the following contents:

[device]
wifi.backend=iwd

Then, save the configuration file.


Next, Install and enable iwd, and mask wpa_supplicant:

sudo pacman -Syu iwd 
systemctl stop NetworkManager
systemctl stop wpa_supplicant
systemctl mask wpa_supplicant
systemctl enable --now iwd.service
systemctl daemon-reload
systemctl start NetworkManager

A restart may be required afterwards.



How to revert your changes and restore wpa_supplicant:


To restore wpa_supplicant usage, comment out the lines you created in /etc/NetworkManager/conf.d/wifi_backend.conf , as so:

#[device]
#wifi.backend=iwd

Save the changes, then execute:

systemctl stop NetworkManager
systemctl disable --now iwd.service
systemctl mask iwd.service
systemctl unmask wpa_supplicant
systemctl enable --now wpa_supplicant
systemctl daemon-reload 
systemctl start NetworkManager

A restart may be required afterwards.

Worked the last time I did this, but it’s been awhile.

2 Likes

I have a problem with reconnections if the wifi restarts

Please open a separate topic. this one has been solved.

2 Likes