Network drops after a while

Hey there,
since recently (I am not certain since when) my network connection sometimes just cuts out, but it's pretty regular.

I looked at NetworkManager, I looked at dmesg and I looked at journalctl. All I could see was NetworkManager and NetworkManager-dispatcher restarting for no apparent reason. No further logs, no errors no nothing. Restarting them myself didn't help.

Any idea how to troubleshoot this?
Thanks!

System:
  Kernel: 6.3.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc
    v: 13.1.1
    parameters: root=PARTUUID=fec66b8f-995b-8043-94b0-fcc9535362ba
    rw add_efi_memmap rootflags=subvol=@
    initrd=@\boot\amd-ucode.img rd.udev.log_priority=3
    vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
    sysrq_always_enabled=1 iommu=soft
    initrd=\@\boot\initramfs-linux-zen.img
  Desktop: Hyprland info: waybar vt: 1 dm: greetd
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends
    v: F50a date: 11/27/2019
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP
    arch: Zen+ gen: 2 level: v3 note: check built: 2018-21
    process: GF 12nm family: 0x17 (23) model-id: 8 stepping: 2
    microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled
    cache: L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB
    desc: 6x512 KiB L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3879 high: 4192 min/max: 2200/3600
    boost: enabled scaling: driver: acpi-cpufreq
    governor: performance cores: 1: 4149 2: 2622 3: 3914
    4: 4132 5: 3969 6: 4120 7: 3971 8: 3600 9: 4192 10: 4167
    11: 3706 12: 4007 bogomips: 86227
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2
    sse4a ssse3 svm
  Vulnerabilities: <filter>
(Why did it hang here for so long?)
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / 560/560X]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 8 ports:
    active: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 08:00.0
    chip-ID: 1002:67ff class-ID: 0300 temp: 49.0 C
  Device-2: Logitech Webcam C270
    driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3.4:6
    chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: wayland server: Xwayland v: 23.1.2
    compositor: Hyprland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: 1
  Monitor-1: DVI-D-1 model: Apple Cinema HD Display
    serial: <filter> built: 2003 res: 1920x1200 dpi: 99
    gamma: 1.2 size: 495x310mm (19.49x12.2") diag: 584mm (23")
    ratio: 16:10 modes: max: 1920x1200 min: 640x480
  Monitor-2: HDMI-A-1 model: Samsung SyncMaster
    serial: <filter> built: 2007 res: 1680x1050 dpi: 90
    gamma: 1.2 size: 474x296mm (18.66x11.65") diag: 559mm (22")
    ratio: 16:10 modes: max: 1680x1050 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.1.1 renderer: AMD Radeon RX 560
    Series (polaris11 LLVM 15.0.7 DRM 3.52 6.3.6-zen1-1-zen)
    direct-render: Yes
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP /
    560/560X] vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 8 bus-ID: 08:00.1
    chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media USB Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1:2
    chip-ID: 0d8c:9700 class-ID: 0300 serial: <filter>
  Device-4: Comtrue Swissonic Audio ASIO
    driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-9:3 chip-ID: 2fc6:f04e
    class-ID: 0102 serial: <filter>
  Device-5: Logitech Webcam C270
    driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3.4:6
    chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.3.6-zen1-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off
    tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.71 status: active with:
    1: pipewire-pulse status: active 2: wireplumber
    status: active 3: pipewire-alsa type: plugin 4: pw-jack
    type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit
    Ethernet vendor: Gigabyte driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
    bus-ID: 3-4.2:7 chip-ID: 0a5c:21e8 class-ID: fe01
    serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up
    address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 2.18 TiB (73.8%)
  SMART Message: Unable to run smartctl. Root privileges
    required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
    model: SSD 860 EVO 1TB size: 931.51 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung
    model: SSD 860 EVO 250GB size: 232.89 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD
    rpm: 5400 serial: <filter> fw-rev: 0A82 scheme: GPT
Partition:
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 91.37 GiB (46.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 19.1 MiB (6.3%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%)
    used: 235.45 GiB (32.0%) fs: btrfs dev: /dev/sda3
    maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB
    size: 195.03 GiB (100.00%) used: 91.37 GiB (46.9%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB
    size: 195.03 GiB (100.00%) used: 91.37 GiB (46.9%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60)
    cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.29 GiB used: 0 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.6 C mobo: 27.0 C gpu: amdgpu
    temp: 50.0 C
  Fan Speeds (RPM): cpu: 0 fan-1: 0 fan-3: 0 gpu: amdgpu
    fan: 1524
  Power: 12v: N/A 5v: N/A 3.3v: 3.33 vbat: 2.81 gpu: amdgpu
    watts: 18.25
Info:
  Processes: 358 Uptime: 6m wakeups: 0 Memory:
  available: 31.29 GiB used: 7.57 GiB (24.2%) Init: systemd
  v: 253 default: graphical tool: systemctl Compilers:
  gcc: 13.1.1 clang: 15.0.7 Packages: pm: nix-default pkgs: 0
  pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0 pm: pacman pkgs: 1855
  libs: 501 tools: yay Shell: Zsh v: 5.9 running-in: alacritty
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-01-08
  Last full system update: 2023-06-07
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Tried other kernels yet? Have you googled your intermittent drops?

4 Likes

I tried googling them yes, but found nothing recent enough to fit my problem. I didn't try other kernels yet, thanks. I always forget.

2 Likes

Try some of the other Garuda live environments to see if the same occurs

4 Likes

I would update your BIOS. There has been major security updates since the version you have installed (I can only guess that is why it hanged for a good bit while gathering vulnerability data for the inxi?). Good chance that it could help with the stability issues you are having with the onboard network device too given how odd your situation with it is. (especially if it persists while troubleshooting with using different things like suggested above [different kernels, live environments, etc.])

4 Likes

I assume your problem is not with a USB WiFi adapter that does not appear in your inxi output. Ethernet issues are most commonly caused by faulty or substandard cabling. Have you tried replacing your cable with a high quality cat6e or better cable?

Another thing you might want to try is installing and testing the r8168-dkms driver from the chaotic AUR.

7 Likes

It takes several hours to reproduce (6+). I can never be certain what causes it and I will not waste 6 hours in a live environment when I have things to do :smiling_face_with_tear:

I’m incredibly scared of bricking my mobo so I won’t do that for the time being. I want to upgrade my pc next year anyways (The new mobo is supposed to have bios flashback to recover from issues)

Hm I haven’t moved my pc nor touched the cable in months. This issue only really coming apparent recently. I could reproduce that four times over the course of three days.

I might try that. The issue is that I don’t even know if I’m gonna be able to reproduce it anymore. It’s really annoying when it happens but not frequent enough to “just test something”

Yes we do have a pretty good idea. You test different peoples suggestions until an answer becomes apparent through the process of elimination. That’s what troubleshooting is all about.

So let me try to understand this, you want people to try to help you troubleshoot your issue without accually assisting in the process yourself. I think what you’re really looking for is called a clairvoyant, because a crystal ball would be required to deduce your issue without you participating the troubleshooting process.

Sorry but my crystal ball is on the fritz right now, and I’m too lazy to actually troubleshoot what it’s issue is.

:8ball:

4 Likes

You may try sudo nmcli general logging level trace (I guess there's debug too but may well be overkill) and hope something relevant ends up in the journal (source: No internet connection after resuing from sleep (suspend) (#1258) · Issues · NetworkManager / NetworkManager · GitLab which is a different issue).

More generally, try searching in the issue tracker, even if you don't find your issue you may find some more specific troubleshooting there. You'll probably spend more than 6 hours on that though LOL.

Also, you mentioned networkmanager-dispatcher, do you have any custom configuration scripts for it?
Or some of the AUR networkmanager-dispatcher-something packages?

4 Likes

I'll try the logging.

If it happens again, which I'm starting to doubt, then I hopefully have something

I didn't install any packages that diverge from the defaults

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.