Network Driver

Hi,
I've just converted windows to garuda linux dragonize version and installed it with single boot.
I tried to connect my usb adapter but it didn't shows/recognize any network (No available connections).
I installed its driver through my CD rom (windows installation).
then, i opened up Garuda Network Assistant and clicked Windows drivers tab but it tells me theres no Ndiswrapper.

Hi there, welcome.
We should know at least the exact make and model of your USB adapter. Possibly your inxi -Faz as well.
I don't think installing the windows drivers is a good way to go. Most likely there's a proper driver on the AUR repository.
Was it working on the live USB?

1 Like

no it's not working on live usb . I have my lan port problem and also my laptop network don't work so i use Digisol [DG-WN3150Nu] for network connection. i am totally new to this i don't know anything

i got this from inxi -Faz command

parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=401dd6ce-5444-44f8-bddc-c07cbeaf3de3
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Latitude 3460 v: N/A serial: <superuser required> Chassis:
type: 9 serial: <superuser required>
Mobo: Dell model: 01YD0G v: A00 serial: <superuser required> UEFI-[Legacy]: Dell v: A19
date: 10/29/2020
Battery:   ID-1: BAT0 charge: 20.0 Wh (98.5%) condition: 20.3/41.4 Wh (49.0%) volts: 16.9 min: 14.8
model: Panasonic DELL 78V9D7CQ type: Li-ion serial: <filter> status: Charging
CPU:       Info: Dual Core model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell family: 6
model-id: 3D (61) stepping: 4 microcode: 2F cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15961
Speed: 1202 MHz min/max: 500/1900 MHz Core speeds (MHz): 1: 1202 2: 1202 3: 1313 4: 1459
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:1616 class-ID: 0300
Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 2-5:4
chip-ID: 1bcf:2b8f class-ID: 0e02
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Dell driver: ath9k v: kernel
bus-ID: 06:00.0 chip-ID: 168c:0034 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169
v: kernel port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-3: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus-ID: 2-3:3
chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s20u3 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros Dell Wireless 1802 Bluetooth 4.0 LE type: USB driver: btusb v: 0.8
bus-ID: 2-6:7 chip-ID: 0cf3:e006 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 4 state: up address: <filter>
Drives:    Local Storage: total: 465.76 GiB used: 7.45 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM021-1KJ152 size: 465.76 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: SDM1 scheme: MBR
Partition: ID-1: / raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 7.45 GiB (15.3%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
ID-2: /home raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 7.45 GiB (15.3%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
ID-3: /var/log raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 7.45 GiB (15.3%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
ID-4: /var/tmp raw-size: 48.83 GiB size: 48.83 GiB (100.00%) used: 7.45 GiB (15.3%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.0 C mobo: 49.0 C
Fan Speeds (RPM): cpu: 2360
Info:      Processes: 186 Uptime: 5m wakeups: 1 Memory: 7.67 GiB used: 1.37 GiB (17.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1129 lib: 287
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09~~~

If the mt7601u USB wireless isn't working out of the box, probably best to try unplugging it and try using your integrated Qualcomm wireless chip. The Qualcomm Atheros AR9462 should work fine. Both offer up to wireless N, so the integrated chip should be able to connect to the same kind of networks as the USB did.

(Saying this because the support for the mt7601u USB in the AUR isn't good; the driver is flagged as out of date. I would avoid using that USB wifi if it isn't working out of the box)

2 Likes

Try also to give a look at

rfkill list

it should be the issue, but you never can say...
Also, try disabling wifi power saving and MAC Address randomization in the Garuda Network Assistant.

2 Likes

rfkill list result

Soft blocked: no
Hard blocked: yes
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: phy1: Wireless LAN
Soft blocked: no
Hard blocked: yes
4: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

You seem to have a block, don't you have a button on keyboard to enable/disable wifi?

1 Like

no there is no such button

I don't know if the image is correct, something like this
immagine
the symbol below PrtScr

5 Likes

took a look at the model's keyboard. It should be Fn+PrtScr

1 Like

yes you are correct

thanks man ...it worked thanks a lot ....<3

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.