Nemo trying to use xterm but default is alacritty

i am trying to use alacritty as default. as archwiki says i ran those commands to use alacritty as default for nemo.
so when i try "open in terminal" it uses alacritty which is fine. but when i try to open a file which usually opens in terminal like "micro" (a fork of nano i think), it doesn't launch the terminal.
what have i tried:

  1. i installed xterm and my file opened with xterm and micro
  2. i installed pcmanfm and my file open with alacritty and micro (which i want)
  3. tried running nemo --debug which throws this when i try to open my terminal: (nemo:1143079): GLib-GIO-DEBUG: 20:51:14.459: Couldn’t find a known terminal
  4. i added custom command to open file like : alacritty -e micro and that works. (i don't want this method, because the title becomes 'alacritty' so if i add multiples like this, all will show as alacritty but they run different programs such as micro, vscode etc.

garuda-inxi:

System:
  Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=5a1a7018-04d3-413c-8c48-65d37ccf7308 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=4d1231c9-2dd3-48e1-9758-f32fd70cbe97 loglevel=3
  Desktop: Qtile v: 0.22.2.dev9+g946908b9 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B450M S2H v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50
    date: 11/27/2019
CPU:
  Info: model: AMD Ryzen 3 3100 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3551 high: 3604 min/max: 2200/3906 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3590 2: 3588
    3: 3600 4: 3600 5: 3604 6: 3226 7: 3600 8: 3600 bogomips: 57492
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Sapphire driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-2 empty: DP-1, DP-2, DVI-D-1, HDMI-A-1
    bus-ID: 0a:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 55.0 C
  Display: x11 server: X.Org v: 21.1.4 compositors: 1: Qtile
    v: 0.22.2.dev9+g946908b9 2: Picom v: git-8a373 driver: X: loaded: amdgpu
    unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: LG (GoldStar) FULL HD
    serial: <filter> built: 2020 res: 1920x1080 dpi: 102 gamma: 1.2
    size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 570 Series (polaris10 LLVM 14.0.6 DRM
    3.48 6.0.1-zen2-1-zen) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Sapphire driver: snd_hda_intel bus-ID: 3-1:2 v: kernel
    chip-ID: 0c76:16cb pcie: gen: 3 class-ID: 0300 speed: 8 GT/s lanes: 16
    bus-ID: 0a:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: JMTek LLC. FANTECH CAPTAIN 7.1 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: vethf56907c state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 794.2 GiB (67.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: ADATA SX6000PNP
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9002s34
    temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC43
    scheme: GPT
Partition:
  ID-1: / raw-size: 221.05 GiB size: 221.05 GiB (100.00%) used: 103.56 GiB
    (46.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 25.9 MiB
    (8.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 221.05 GiB size: 221.05 GiB (100.00%) used: 103.56
    GiB (46.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 221.05 GiB size: 221.05 GiB (100.00%) used: 103.56
    GiB (46.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 221.05 GiB size: 221.05 GiB (100.00%) used: 103.56
    GiB (46.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.56 GiB used: 84.1 MiB (0.5%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.13 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 63.4 C mobo: N/A gpu: amdgpu temp: 55.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 789
Info:
  Processes: 319 Uptime: 5h 46m wakeups: 0 Memory: 15.57 GiB used: 4.06 GiB
  (26.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1781
  libs: 498 tools: paru,yay pm: rpm pkgs: 0 Shell: Zsh v: 5.9
  running-in: alacritty inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-08-04
  Last full system update: 2022-10-16 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service irqbalance.service swapfile.swap