Need help downloading snap

Terminal Output below

╭─[email protected] in ~ took 4ms
[:red_circle:] × sudo su
[sudo] password for skarjen:
[root]# pacman -Sy snapd
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur 1614.7 KiB 779 KiB/s 00:02 [------------------------------------] 100%
error: target not found: snapd
warning: 'snapd' is a file, did you mean -U/--upgrade instead of -S/--sync?

basically I wanted to download snap for apps but everytime I run the command it says it can't do it. I'm on dragonfire version if that helps

snapd is in the AUR:
paru snapd
https://wiki.archlinux.org/title/Snap
Please be aware that, according to this wiki entry (still not completely translated after rework :slight_smile: ):
https://wiki.garudalinux.org/ru/how-to-snap-flatpak

We recently decided to not support both Snaps & Flatpaks as we got a lot of apps in Chaotic-AUR already / AUR has it all usually. It will probably work fine but if it doesnt, dont create posts about it.

It helps more, in general, to have your garuda-inxi (as explicitely requested in the template).
Please consider this in your future posts.

5 Likes

Unless you have a compelling reason to use a snap version of a package, I would avoid them. My experience with snaps is limited, but thoroughly disappointing. I know there has been a lot of development work going into them recently so they are probably getting better, but in general if you just build something from AUR it is less likely to be broken.

3 Likes