My second monitor it's not in the right position

Hi,
I have my laptop connected to a second monitor via HDMI with an adapter to VGA, everything's looked good until I noticed that the second screen it's a bit shifted to the left, I tried different resolutions to see if maybe that solve my problem but it doesn't solved it.

xrandr output:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080     60.00*+
1680x1050     60.00
1280x1024     60.00
1440x900      60.00
1280x800      60.00
1280x720      60.00
1024x768      60.00
800x600       60.00
640x480       60.00
HDMI-1-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
1920x1080     59.94*+  59.93
1680x1050     59.95
1600x1200     60.00
1440x900      59.89
1360x768      59.80
1280x1024     60.02
1280x960      60.00
1280x800      59.81
1280x768      59.87
1280x720      60.00    59.94
1024x768      60.00
800x600       60.32
720x480       59.94    59.94
640x480       59.94

PD: English it's not my native language, so if I have some mistakes, please excuse me. Thank you in advance for your help

Welcome :slight_smile:

Just post the output of your

garuda-inxi
1 Like
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_ADDRESS = "en_US.UTF-8",
LC_NAME = "en_US.UTF-8",
LC_MONETARY = "en_US.UTF-8",
LC_PAPER = "en_US.UTF-8",
LC_IDENTIFICATION = "en_US.UTF-8",
LC_TELEPHONE = "en_US.UTF-8",
LC_MEASUREMENT = "en_US.UTF-8",
LC_TIME = "en_US.UTF-8",
LC_NUMERIC = "en_US.UTF-8",
LANG = "es_CO.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e31902ab-3e58-4aac-a44e-bfffb0f738cc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04
serial: <superuser required>
Mobo: RO model: Stonic_RNS v: V1.04 serial: <superuser required>
UEFI: Insyde v: 1.04 date: 02/04/2021
Battery:
ID-1: BAT1 charge: 45.1 Wh (100.0%) condition: 45.1/57.5 Wh (78.5%)
volts: 16.7 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
status: N/A
CPU:
Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600103
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1459 high: 1667 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1605 2: 1455
3: 1441 4: 1451 5: 1667 6: 1415 7: 1403 8: 1491 9: 1397 10: 1397 11: 1397
12: 1397 bogomips: 71867
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia
v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 2 speed: 5 GT/s
lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
off: HDMI-A-1 empty: none bus-ID: 01:00.0 chip-ID: 10de:1f99
class-ID: 0300
Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1
empty: none bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:3
chip-ID: 04f2:b64f class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 1.21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
gpu: amdgpu,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: right
model: MT23L built: 2010 res: 1920x1080 hz: 60 gamma: 2.55 size: N/A modes:
max: 1920x1080 min: 640x480
Monitor-2: eDP-1 mapped: eDP pos: primary,left model: BOE Display 0x0818
built: 2018 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.1-zen1-1-zen)
v: 4.6 Mesa 22.0.1 direct render: Yes
Audio:
Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: Acer Incorporated ALI driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0
chip-ID: 10ec:2600 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 247.61 GiB (21.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 SDBPNPZ-256G-1014 size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 21103900 temp: 32.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-00Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 48.64 GiB size: 48.64 GiB (100.00%)
used: 22.95 GiB (47.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 55.9 MiB (58.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 48.64 GiB size: 48.64 GiB (100.00%)
used: 22.95 GiB (47.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 48.64 GiB size: 48.64 GiB (100.00%)
used: 22.95 GiB (47.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 48.64 GiB size: 48.64 GiB (100.00%)
used: 22.95 GiB (47.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.2 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 340 Uptime: 1m wakeups: 1 Memory: 7.2 GiB used: 3.2 GiB (44.4%)
Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
Packages: pacman: 1393 lib: 349 Shell: fish v: 3.4.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-1):
System install date:     2022-03-26
Last full system update: 2022-04-09
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

What do you mean by this?

Check in the display settings that there's no overlap between the two outputs.

1 Like

mmmmmm, it's like a black line in the right of the screen.
it's like the screen moving a little to the left.

I tried to upload a image to explain better the problem but the page don't let me upload anything for been a new user

Could just be the HDMI-VGA adapter doesn't provide the correct signal to the monitor to display correctly. Nothing to be done from the Garuda side if that's the case.

Try lowering the resolution to see what happens.

1 Like

I already tried it, but only in two resolutions fill all the entire screen but it looks worst

something important to keep in mind is the fact that in windows never appear this type black lines in the monitor so I assume that there's something that i can do to solve that.

What kind of monitor is it? Can you identify the brand and model number?

it's not a monitor, it's a tv (Challenger model: LD 19D60HD)

I have been messing with some configuration while I have been in windows and I discovered that the refresh rate it's the cause of that black line, I think if I set a refresh rate a bit lower maybe that can solve my problem but I don't know how to do that in garuda.

With an xorg file.
Read Archwiki on xrandr for examples.

3 Likes

Can you be more specific about the values?

There are two listed,

so you should see two available values in the DE's display settings.

2 Likes

I put the refresh rate in 59.93 and it works, I'm still seeing the black line but this one is tinier than the older one, maybe I should let this configuration. Thanks for your help, if someone has a new solution I would be very thankful.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.