Music files not playing

位 garuda-inxi
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=7e8cf59a-f63c-41c1-bcfb-8403f744500d rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
  Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 80C1 v: 96.53 serial: <superuser required> UEFI: Insyde
    v: F.29 date: 05/24/2019
  ID-1: BAT1 charge: 18.8 Wh (55.0%) condition: 34.2/32.1 Wh (106.5%)
    volts: 14.4 min: 14.6 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: discharging
  Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1995 high: 1996 min/max: 500/2000 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1995 2: 1995 3: 1996
    4: 1994 bogomips: 15961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-8 process: Intel 14nm built: 2014-15 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616
    class-ID: 0300
  Device-2: Suyin HP Truevision HD type: USB driver: uvcvideo bus-ID: 2-5:6
    chip-ID: 064e:930b class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: Samsung 0x4e51 built: 2014 res: 1366x768 hz: 60
    dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa
    22.2.1 direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
    class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:9ca0 class-ID: 0403
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 07:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 0d:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp13s0 state: down mac: <filter>
  IF-ID-1: CloudflareWARP state: unknown speed: 10 Mbps duplex: full
    mac: N/A
  IF-ID-2: enp0s20u2 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Huawei LLD-AL20 type: USB driver: rndis_host v: kernel
    bus-ID: 2-2:7 chip-ID: 12d1:108a class-ID: 0a00 serial: <filter>
  Device-2: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 2-4:5 chip-ID: 0bda:b006 class-ID: e001 serial: <filter>
  Report: ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 447.13 GiB used: 171.61 GiB (38.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 480GB SSD
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0Z13 scheme: GPT
  ID-1: / raw-size: 146.48 GiB size: 146.48 GiB (100.00%) used: 13.46 GiB
    (9.2%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.6 MiB
    (26.6%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 146.48 GiB size: 146.48 GiB (100.00%) used: 13.46
    GiB (9.2%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-4: /var/log raw-size: 146.48 GiB size: 146.48 GiB (100.00%) used: 13.46
    GiB (9.2%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-5: /var/tmp raw-size: 146.48 GiB size: 146.48 GiB (100.00%) used: 13.46
    GiB (9.2%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.68 GiB used: 571 MiB (7.3%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 68.0 C pch: 63.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 241 Uptime: 1h 10m wakeups: 1 Memory: 7.68 GiB used: 4.99 GiB
  (64.9%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1345
  libs: 334 tools: octopi,paru Shell: Zsh v: 5.9 running-in: tilda
  inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2022-10-26
  Last full system update: 2022-10-26
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units

When I try to play any song, There is no audio coming from the player, it just stays at start. The icons change to it being playing the music, but it doesn't. I tried multiple music players, Audacious, Rythmbox, Amberol and Sayonara. None works. Rythmbox stops responding when trying to play any music and then have to force stop.

Hi, welcome ^^
Are you using JamesDSP, and do you have it set to automatically start with each login?
Pipewire was updated recently which should address this issue if you are using JamesDSP or EasyEffects. Your garuda-inxi says your last full system update was on the 26th of October, so if you are using JDSP you should give an update a try. Make sure to backup things first though.

Updating in Garuda is really easy - just pop open the terminal and type update :slight_smile:. Once the update is done, restart JDSP, and if it still doesn't work, try logging out and logging back in.

Since you haven't updated in a while though, maybe it'd be a good idea to refresh your mirrorlists first with the reflector-simple GUI tool, or do the bulletproof method mentioned in 'The first thing to try' section here.

Ok last edit lolol... I just noticed your inxi also states your system is partially upgraded. Since Arch is a rolling release distro and Garuda is based on Arch, it isn't recommended to do partial upgrades due to dependency issues. More on that here: System maintenance - ArchWiki


Try using Lollypop maybe it will work and exit JamesDSP. Make sure your Audio mode is on Analog Stereo Duplex.

1 Like

The partial update @lum1nuss mentioned is the first thing to tackle. It is most likely the cause of most issues if true.

My favorite tool is QJackCtl. With the graph view, you can visualize where each app is sending audio to. I have constant problems with Brave either not showing up or not sending audio through JamesDSP. It is usually fixed by an application restart, or by unfocusing and refocusing the window, stopping and restarting player, and sometimes rebooting.


Yes. I also ruled out James DSP to be the culprit, and it turned out to be true. For the time being, I shut it down and also stop it from auto start on boot. So far, so good.

1 Like

Yes, I haven't yet update to latest since I'm dealing with a project on my end and don't want to update the python version I'm using until I finish a certain feature. And It turned out to be James DSP is the issue, I stopped it for the time being.

The partial update was when I installed Rhythmbox to test if it's also having problem btw.

1 Like

Ahh icic :open_mouth:
There's another way to get JamesDSP to work without updating the system, and that's to implement this: scripts: policy-node: wait for unactivated links instead of removing (d4a22c8c) 路 Commits 路 P V / wireplumber 路 GitLab in /usr/share/wireplumber/scripts/policy-node.lua
but if you don't really use JamesDSP then it's not worth the effort :slight_smile: good thing the solution to your problem was a simple one.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.