Mouse-pointer disappearing and window key unusable upon sub-window creation

I’m having a major issue preventing me from using my system. Everything seems to be normal after booting. During the course of my work, I have to open many different applications and windows.

Sometimes when X opens a new window/sub-window, my mouse-pointer disappears, and my Window key doesn’t work anymore (Both problems happen simultaneously). When this happens, the mouse isn’t just hidden. It’s completely gone (Can’t click anything or hover). There is no specific application window that causes it but I think it might only be sub-windows (Usually settings in various applications). I have seen it happen when I opened the settings dialog in Blender and in Pycharm. Probably others as well that I’m not recalling.

Whenever this happens I have to either alt+tab to the terminal I have open or ctrl+alt+f3 so I can manually end my gnome session with gnome-session-quit --logout --force.I have tried clearing my gnome config via dconf reset -f / which did not resolve the issue.

journalctl -b | grep -i error (Today’s entries): https://hastebin.com/share/seboxifuma.yaml

inxi:

System:
  Kernel: 6.5.6-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=cc8f8aae-9afb-48fc-9eff-62f9df1eb56c rw rootflags=subvol=@
    cryptdevice=UUID=cfffcf8a-c3da-46b8-b9c9-b4bc281caba8:luks-cfffcf8a-c3da-46b8-b9c9-b4bc281caba8
    root=/dev/mapper/luks-cfffcf8a-c3da-46b8-b9c9-b4bc281caba8 no
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=/dev/mapper/luks-4a58206a-a094-481e-8f36-013e250bfae4 loglevel=3
    no nvidia-drm.modeset=1 ibt=off
  Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G15 GA503RM_GA503RM
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: GA503RM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: GA503RM.313 date: 01/17/2023
Battery:
  ID-1: BAT1 charge: 14.4 Wh (18.2%) condition: 79.0/90.2 Wh (87.6%)
    volts: 15.0 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: charging
CPU:
  Info: model: AMD Ryzen 9 6900HS with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404101
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1279 high: 4591 min/max: 400/4935 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 2482 5: 1605 6: 2933 7: 4591 8: 400 9: 2143 10: 1726 11: 400 12: 400
    13: 400 14: 400 15: 1393 16: 400 bogomips: 105399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-23 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    off: eDP-2 empty: DP-9,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2520
    class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1,
    DP-2, DP-3, DP-4, DP-5, DP-6, DP-7, DP-8, eDP-1 bus-ID: 07:00.0
    chip-ID: 1002:1681 class-ID: 0300 temp: 59.0 C
  Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 13d3:56eb
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau,radeon alternate: fbdev,nv,vesa
    dri: radeonsi gpu: nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: eDP-2 mapped: DP-2 note: disabled model: ChiMei InnoLux 0x1540
    built: 2020 res: 2560x1440 dpi: 191 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 394mm (15.5") ratio: 16:9 modes: 2560x1440
  API: EGL v: 1.5 hw: drv: nvidia platforms: gbm: drv: nvidia
  API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2
    memory: 5.86 GiB
  API: Vulkan v: 1.3.264 layers: 8 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3060 Laptop GPU driver: nvidia v: 535.113.01
    device-ID: 10de:2520 surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: AMD Radeon Graphics (RADV REMBRANDT) driver: mesa radv
    v: 23.2.1-arch1.2 device-ID: 1002:1681 surfaces: xcb,xlib device: 2
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 07:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.6-zen2-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:7922 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth:
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 13d3:3568
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
    status: discoverable: no pairing: no
Drives:
  Local Storage: total: 1.38 TiB used: 398.37 GiB (28.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Smart Modular Tech.
    model: SHPP41-1000GM size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 51060A20 temp: 55.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:7 vendor: Western Digital model: WD PC
    SN735 SDBPNHH-512G-1002 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 70626000 temp: 41.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 451.59 GiB size: 451.59 GiB (100.00%)
    used: 398.33 GiB (88.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-cfffcf8a-c3da-46b8-b9c9-b4bc281caba8
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 724 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:8
  ID-3: /home raw-size: 451.59 GiB size: 451.59 GiB (100.00%)
    used: 398.33 GiB (88.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-cfffcf8a-c3da-46b8-b9c9-b4bc281caba8
  ID-4: /var/log raw-size: 451.59 GiB size: 451.59 GiB (100.00%)
    used: 398.33 GiB (88.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-cfffcf8a-c3da-46b8-b9c9-b4bc281caba8
  ID-5: /var/tmp raw-size: 451.59 GiB size: 451.59 GiB (100.00%)
    used: 398.33 GiB (88.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-cfffcf8a-c3da-46b8-b9c9-b4bc281caba8
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 22.77 GiB used: 4.05 GiB (17.8%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 25.05 GiB used: 34.3 MiB (0.1%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-4a58206a-a094-481e-8f36-013e250bfae4
Sensors:
  System Temperatures: cpu: 65.2 C mobo: N/A
  Fan Speeds (rpm): cpu: 4000
  GPU: device: nvidia screen: :1.0 temp: 52 C device: amdgpu temp: 59.0 C
Info:
  Processes: 500 Uptime: 1d 8h 46m wakeups: 47 Memory: total: 24 GiB
  note: est. available: 22.77 GiB used: 6.72 GiB (29.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 6/7
  clang: 16.0.6 Packages: pm: pacman pkgs: 2380 libs: 586
  tools: gnome-software,pamac,paru pm: appimage pkgs: 0 Shell: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2022-10-15
  Last full system update: 2023-10-09 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            anbox-container-manager.service 

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.