Missing programs, selected during first start

Hello to every one! I am totally new to Linux. Garuda Assistant after OS installation offered to install some different programs. I chose some browsers (opera, chromium), some office programs (libre office) and other. But after assistant ended his work, there is almost none chosen programs appeared in start menu. My English is not good, so I could do some mistakes. I searched in forum, but didn`t find same case. Please help me.

Be sure you didn't use the "guest" user.
Change the user at the login screen

3 Likes

UPD: If in the search bar of start menu write Opera, there will be icon "Install Opera".


But if I click it, opens Install program manager and says nothing

I checked this, I am using created user, at the right-top corner displaying his name. Thank you for reply.

Try running the setup manager again.

1 Like

Good idea as the setup assistant has bugged like that for me before. I suggest that while you run it the second time you make a list of the software you check so that if it doesn't work, you can just run

sudo pacman -S list of software
2 Likes

You can also use that list to manually search up the software, using the Add/Remove Software app. It normally works fine that way too, I normally download my software like that since the setup assistant and me had some painful encounters :sweat_smile:

2 Likes

@Vigilante Solution for you now:

paru -S --needed - < ~/pkglist.txt

You don't need to select the packages manually once again, as Setup Assistant saves the list in ~/.pkglist.txt file.

There's a bug in the Setup Assistant. Long before I reported here but didn't get attention it seems :roll_eyes:. The problem is that when it asks for replacing some packages ([y/N]), it just removes packages and exits without upgrading. But for the second time, as the conflicting packages are removed already, the installs work. I think this should get fixed by Garuda team.

5 Likes

Thank you all for replies! I think, I fell in love with Garuda community :sweat_smile: . I reboot my PC and tried to start it again and it is worked!

7 Likes

We all like to help, glad your problem has been taken care of, Have fun!!! :grinning_face_with_smiling_eyes:

4 Likes

Thank you!

1 Like

You are absolutely right, this seems to have been overlooked - thanks for bringing this up I'll have a look later :eyes:

6 Likes

Yeah thats why I manually install what i need, since I have been through the installation procedure many times. I had to reinstall garuda linux twice due to my setup assistant screwing with me, I seem to have bad luck when it comes to updates, Even windows is painful :laughing:

(But once you get used to linux its quite easy to work your way around these things, If you are new to Linux Dont worry you will get used to it. :grinning_face_with_smiling_eyes: )

4 Likes

Quite right it should have been fixed, but you know how it goes devs, have real lives too (and this isn't exactly a deal breaking bug).

What did people ever do before there was such a thing as auto-installers? It's been ages since I've used Windows, but I seem to recall that with Windows you had to go to the software developers or some other download site to get the software first. Then IIRC you had to virus scan the program before ever even thinking of installing it. This had to be repeated for each and every piece of second party software back in my Windows days. Also many programs were trialware, crippleware, or outright spyware, plus of course many you had to pay for.

Funny thing is, that it seems the Windows refugees complain the loudest when this time saving Garuda feature doesn't work properly. Go figure. :man_shrugging:

Whatever did people do before these newfangled gizmos came along. :crazy_face:

3 Likes

In Windows 10 Pro I use:

  • p7zip
  • balenaEtcher
  • Firefox
  • kdeconnect
  • LibreOffice (fresh)
  • qBittorrent
  • VLC
  • and a couple of minor apps

But, yeah, I have to go to the URL of each application to download and install updates. A few, like qBittorrent, advise me when there is an update available.

And the only reason for me to run Windows after a 20+ year absence? To stream in 1080p, about 40% of my daily activity (the rest being comprised of masturbating and arguing with idiots on the 'net--acts indistinguishable from each other.) It's a pain, sure, but no daily updates (just unpatched security holes) to break my system (so far).

Then I boot up Garuda or any Arch-based distribution (even Arch), and go "Ahhhhh" with the relief simplicity brings.
:wink:

6 Likes

I can understand that. That's why this was rather a reminder not a complain :slightly_smiling_face:

This reminds me my Windows days :laughing:
It was the time when I knew only 2 OSs,Win and Mac and had a myth that Linux is something only coders use. Thanks to the community they took me out from this myth. And you know what, now the thing turned the other way: if someone asks me how to get something in Windows, I can't help them as I got used to Linux now, it is my daily driver and Windows is, seriously, harder for me to use and also annoyed by commercial ads (which aren't treated as but are actually).

2 Likes

I'm curious, can't Linux stream 1080p?

1 Like

Not Netflix, Prime, or HBOMax. YouTube, yes.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.