Minecraft sound stutters


inxi info

Since I reinstalled Garuda, Minecraft's sound is most often (but not always) stuttering. This seems likely due to pipewire, the only difference between the old install vs the new.

I am not terribly familiar with pipewire, and have found nothing on these forums or the broader 'net about this issue and pipewire/Minecraft (Thou there are 10,000,000 about pulseaudio stuttering from years ago when that was a common issue.)

Note, as this is not in the inxi info and might be relevant: I have two sound devices. and I run a combined sink so they both play at once (makes switching between the wall speakers and the headphones something I can do with a click of the mouse). I have tried not loading the combined sink and having Minecraft use one sound device directly, but the same issue happens that way as well.

Other things I have tried:

  • Minecraft recognizes there is a JACK interface. When I have Minecraft use it, there is no change in the issue.
  • Increased memory allotment for Minecraft to 4Gb. No impact on the issue.
  • Reduced rendering range in Minecraft. Impressive FPS, but still stuttering sound.

I know two things about pipewire:

  1. Didly
  2. Squat

So I'm a little stuck on what to do next. Pleez Help!

I had a lot of sound issues when I first started using Garuda, and they were caused by JamesDSP. Are you using this? Try exiting it if so to see if there's any improvement.

It's a long shot, as your issue seems very isolated, but worth trying. If that works, a good alternative is Easy Effects.

If that doesn't work, can you confirm minecraft is using your dedicated GPU in the F3 menu?
I saw this issue, but checking the config of zen with zcat /proc/config.gz | grep CONFIG_HZ shows it's using 1000. That got me thinking maybe you're taxing your internal GPU? Maybe you're already using DRI_PRIME=1, just spitballing ideas here. I'm assuming since you said impressive fps, this isn't the issue.. but figured I'd ask.

1 Like

Thanks! :grinning:

I wasn't using JamesDSP, but I did have EasyEffects installed. Never got it to work, so I removed it just in case it's the source of the problem here.

So far, no stuttering in Minecraft. But the problem is flaky, so one test isn't enough to be sure. :crossed_fingers:

1 Like
  • Changed kernel to LTS. Nope.
  • Found that, in Minecraft, switching to Jack and back often relieves the problem until next session.

Bummer, was hoping it was something easy. Follow up questions then.

Is the issue happening on headphones, speakers, or both?
Is the issue triggered when switching between headphones and speakers?
I see you're using Unitek Y-247A, is there any output from sudo dmesg | grep usb ?
Have you tried using pulseaudio to see if the problem persists there?

You could try running minecraft in terminal to see if there's any output related to the issue, but you have to bypass the launcher. There's probably an easier way, but something like pidof java | xargs ps -o args -p | tail -n +2 >> minecraft-launcher-bypass.sh should work to get the command while minecraft is open, given you have nothing else running java. Basic explaination incase you want it, gets the pid, passes to ps to get the command, removes the first line, then saves in a file. Then you can just make it executable and call from terminal ./minecraft-launcher-bypass.sh .

The fact this is a flaky issue makes it pretty hard to debug. Hopefully someone smarter than me in linux comes along to help out. I'm a newbie, so this may be out of my league here.

Quick side note, I've read F3+S reloads the sound manager in minecraft, maybe easier than doing the Jack work around.

Both. BTW,
Unitek Y-247A = Headphones
Unitek Y-247A = Speakers.

Does not seem to effect it at all. (neither starts nor relives the problem)

Only info messages. No errs or warnings.

I have not. It’s now on the list of things to try.

Have done and no warning or errors there . Haven’t caught a transition (from clear to stuttery) yet, though.

Boogers, I forgot all about that :joy:


This issue appears to have been fixed by an update to pipewire.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.