Middle Click Not Registered

This is the only issue on my Garuda machines (all of them) that I have yet to solve. It happens both in X11 and Wayland sessions. It's as if nothing is happening when clicking the middle mouse button, click is not registered. In Plasma Mouse settings on Wayland I even tried to bind an additional mouse button and clicking the middle button wasn't detected. Using "Press left and right buttons for middle click" enabled works, so middle click as a feature works. At least I have a workaround.

I've verified this with multiple mice and computers.


Kernel: 6.1.23-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=e0430201-0931-4d49-a5a8-f8a1445e4ab0 rw [email protected]
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=ae0cdb3c-2994-4db6-8822-7960e6e25fe8 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_wayland vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0
serial: <superuser required> Chassis: type: 9 v: Mac-937CB26E2E02BB01
serial: <superuser required>
Mobo: Apple model: Mac-937CB26E2E02BB01 v: MacBookAir7,2
serial: <superuser required> UEFI: Apple v: 428. date: 10/27/2021
ID-1: BAT0 charge: 51.4 Wh (100.0%) condition: 51.4/54.3 Wh (94.5%)
volts: 8.5 min: 7.6 model: DP bq20z451 type: Li-ion serial: N/A status: full
cycles: 87
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i5-5350U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2750 high: 2853 min/max: 500/2900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2700 2: 2750 3: 2700
4: 2853 bogomips: 14407
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: HDMI-A-1
off: eDP-1 empty: DP-1,DP-2,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1626
class-ID: 0300
Display: wayland server: X.org v: with: Xwayland v: 23.1.1
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 6000 (BDW
GT3) direct-render: Yes
Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: facetimehd v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570
class-ID: 0480
API: ALSA v: k6.1.23-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.68 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: cdc_ncm
bus-ID: 2-1:2 chip-ID: 0b95:1790 class-ID: 0a00 serial: <filter>
IF: enp0s20u1c2 state: up speed: 1000 Mbps duplex: half mac: <filter>
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8
bus-ID: 1-3.3:11 chip-ID: 05ac:828f class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 233.76 GiB used: 169.49 GiB (72.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G
size: 233.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3A0Q scheme: GPT
ID-1: / raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 169.49 GiB (75.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 169.49 GiB (75.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 169.49 GiB (75.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 169.49 GiB (75.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 1.29 GiB (16.8%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 103.0 C pch: 98.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 258 Uptime: 3m wakeups: 4 Memory: 7.67 GiB used: 3.5 GiB (45.6%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman pkgs: 2170 libs: 596
tools: octopi,pamac,paru,pikaur Shell: fish v: 3.6.1 running-in: konsole
inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2022-12-02
Last full system update: 2023-04-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut(custom) mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

Are you trying to assign a custom function to it, or are you just trying to copy/paste?

1 Like

I'm just trying to use it as a input device button. For example, the Applied Energistics mod for Minecraft requires middle click for certain actions.

Can you test if highlighting text and middle-clicking somewhere (text file, whatever) copies and pastes the text? If not, perhaps something wrong with the mouse button.

1 Like

Tried to use middle click to copy/paste text but nothing happened and there isn't a new entry in my clipboard history. The mouse is not the problem, I've tested with multiple (known working) mice.

OK, turns out it is my mouse, I have to press middle click really hard for it to register. I just took my other test mouse that is brand new and never gets used, and now it works just fine. Not sure what happened when I tested it before. Glad this is working on a software level!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.