Meta key and auto focus on searchbox

Hi Community,

I am fresh user of Garuda Linux!
When I press the meta key, I get the "start menu" / "launcher" to open as seen in this screenshot:

But unfortunaltey, it is not focused automatically on the search box. So I cannot start typing right away, I need to go to the mouse and click in the search field and then start typing.
Before it was working fine.
System is uptodate and restarted.
Also, until yesterday I could look up KDE settings directly from the launcher like "shortcuts" or "composer" etc. Not anymore.

Any idea?

Thanks a lot!

Nico

Welcome :slight_smile:

Please send a full bug report at https://bugs.kde.org.

This seems to be related to latte-dock.
There is an identical thread here, but in that case the OP could roll-back to a previous version which worked for him (but this is not possible in your case).
I hope this will be checked and fixed. It is still unclear and not reproducible. We'll see...

even if it's a fresh installed garuda, i doubt everything is on the newest package, could you run this:
ls /var/cache/pacman/pkg/latte-dock* if you're lucky you get multiple versions of latte-docks out of there, the version it works "again" for me is latte-dock-git-0.10.0.r42.g53674a65-1-x86_64, i think it shouldn't be that old but it doesn't hurt to take a look

Hi there, welcome to the community.
It is clearly mentioned in KDE UserBase on how to open KRunner on pressing meta key.

https://userbase.kde.org/Plasma/Tips#Windows.2FMeta_Key

I hope this answers your question.

3 Likes

Hi

Indeed i still have r42 listed. How can I make this one the one that I use?

Thanks a lot

you should be able to install it via
sudo pacman -U [package]
in my case that was
sudo pacman -U /var/cache/pacman/pkg/latte-dock-git-0.10.0.r42.g53674a65-1-x86_64.pkg.tar.zst

oh and you might want to restart your computer afterwards

I just did that but it did not solve my issue unfortunately.

╰─λ sudo pacman -Q latte-dock
[sudo] password for nicolas:
latte-dock-git 0.10.0.r42.g53674a65-1

I see that the correct version is installed but still when the menu opens via meta key, I cannot start typing right away :frowning:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.