McFly updating problem

Hi there, good morning... I did a clean Garuda KDE no gaming edition install and I've been having this problem since the moment I tried to do a sudo pacman -Syyu (or -Syu, same problem), or trying to start a ssh session same problem occurs, terminal just shows

"McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cmd_tpl to commands (duplicate column name: cmd_tpl)', src/history/
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace"

and I've been searching in google and until now I haven't found anything yet about how to solve it.

I've tried re installing mcfly, and editing the history.db but no luck...

Any ideas?... Thanks!

1 Like

Hi there, welcome!
Maybe this is what you need?


Hi, thanks! yes more or less... after posting this I kept looking and I noticed that the history.db was blank! ._. so I renamed the .mcfly folder and did a -Syu and it created the folder again and looks like everything is working now... Still Thanks dude! I may mark this as solution


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.