"Maximum file size exceeded" instaling "anki" from chaotic-aur

sudo pacman --debug -S anki
:: Retrieving packages...
anki-2.1.60-1-x86_64 downloading...
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: url is https://cdn-mirror.chaotic.cx/chaotic-aur/x86_64/anki-2.1.60-1-x86_64.pkg.tar.zst
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: maxsize 15263756
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: using time condition 1677881142
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: opened tempfile for download: /var/cache/pacman/pkg/anki-2.1.60-1-x86_64.pkg.tar.zst.part (wb)
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: curl returned result 0 from transfer
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: response code 304
debug: anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig: url is https://r2.garudalinux.org/repos/chaotic-aur/x86_64/anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig
debug: anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig: maxsize 16384
debug: anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig: opened tempfile for download: /var/cache/pacman/pkg/anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig.part (wb)
debug: anki-2.1.60-1-x86_64.pkg.tar.zst: file met time condition
debug: anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig: curl returned result 63 from transfer
error: failed retrieving file 'anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig' from r2.garudalinux.org : Maximum file size exceeded
debug: anki-2.1.60-1-x86_64.pkg.tar.zst?r2request.sig: no more servers to retry
debug: curl_download_internal return code is -1
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.
garuda-inxi
System:
Kernel: 6.1.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@boot/vmlinuz-linux-zen
root=UUID=e1adc2d5-7b7d-4266-8e23-555c7e26c364 rw
[email protected] quiet
cryptdevice=UUID=7b1ced1a-3ab8-4284-9652-bdd8a1f83892:luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892
root=/dev/mapper/luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892 quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Inspiron 5502 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0YWFX8 v: A00 serial: <superuser required> UEFI: Dell
v: 1.7.1 date: 08/06/2021
Battery:
ID-1: BAT0 charge: 46.0 Wh (100.0%) condition: 46.0/53.0 Wh (86.8%)
volts: 16.5 min: 15.0 model: BYD DELL TXD0316 type: Unknown serial: <filter>
status: full
CPU:
Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xA6
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1700 min/max: 400/4700 scaling: driver: intel_pstate
governor: performance cores: 1: 1700 2: 1700 3: 1700 4: 1700 5: 1700 6: 1700
7: 1700 8: 1700 bogomips: 27033
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 0000:00:02.0
chip-ID: 8086:9a49 class-ID: 0300
Device-2: NVIDIA GP107M [GeForce MX350] vendor: Dell driver: nouveau
v: kernel non-free: 525.xx+ status: current (as of 2023-02) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 bus-ID: 0000:2b:00.0
chip-ID: 10de:1c94 class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 3-6:4 chip-ID: 0c45:671b class-ID: 0e02
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: iris,nouveau gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x05f2 built: 2018 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Xe Graphics (TGL GT2)
direct-render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
Sound API: ALSA v: k6.1.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.66 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 3-10:5 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Drives:
Local Storage: total: 476.94 GiB used: 139.69 GiB (29.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data
model: IM2P33F3A NVMe 512GB size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 92103061 temp: 58.9 C scheme: GPT
Partition:
ID-1: / raw-size: 350.57 GiB size: 350.57 GiB (100.00%)
used: 139.69 GiB (39.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892
ID-2: /boot raw-size: 350.57 GiB size: 350.57 GiB (100.00%)
used: 139.69 GiB (39.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892
ID-3: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%)
used: 380 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /home raw-size: 350.57 GiB size: 350.57 GiB (100.00%)
used: 139.69 GiB (39.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892
ID-5: /var/log raw-size: 350.57 GiB size: 350.57 GiB (100.00%)
used: 139.69 GiB (39.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892
ID-6: /var/tmp raw-size: 350.57 GiB size: 350.57 GiB (100.00%)
used: 139.69 GiB (39.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-7b1ced1a-3ab8-4284-9652-bdd8a1f83892
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.36 GiB used: 41.5 MiB (0.3%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 67.0 C mobo: 61.0 C gpu: nouveau temp: 62.0 C
Fan Speeds (RPM): cpu: 3683
Info:
Processes: 298 Uptime: 53m wakeups: 2967 Memory: 15.36 GiB
used: 5.27 GiB (34.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1909 libs: 522 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2023-02-18
Last full system update: 2023-03-04 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:
sudo pacman -S anki
Abhängigkeiten werden aufgelöst …
:: Es stehen 2 Anbieter fĂĽr qt6-multimedia-backend zur VerfĂĽgung:
:: Repositorium extra
   1) qt6-multimedia-ffmpeg  2) qt6-multimedia-gstreamer

Geben Sie eine Zahl ein (Voreinstellung=1): 1
Nach in Konflikt stehenden Paketen wird gesucht …
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: qt6-multimedia-ffmpeg wird vor seiner Abhängigkeit qt6-multimedia installiert werden

Pakete (20) python-decorator-5.1.1-2  python-flask-2.2.2-1  python-flask-cors-3.0.10-4  python-itsdangerous-2.1.2-2  python-jsonschema-4.17.3-1  python-orjson-3.8.7-1  python-protobuf-21.12-1
            python-pyqt6-6.4.2-1  python-pyqt6-sip-13.4.1-1  python-pyqt6-webengine-6.4.0-1  python-pyrsistent-0.19.3-1  python-pysocks-1.7.1-7  python-waitress-2.1.2-1
            python-werkzeug-2.2.3-1  qt6-multimedia-6.4.2-1  qt6-multimedia-ffmpeg-6.4.2-1  qt6-positioning-6.4.2-1  qt6-webchannel-6.4.2-1  qt6-webengine-6.4.2-3  anki-2.1.60-1

Gesamtgröße des Downloads:              86,22 MiB
Gesamtgröße der installierten Pakete:  281,62 MiB

:: Installation fortsetzen? [J/n] 
:: Pakete werden empfangen …
 python-pysocks-1.7.1-7-any                                                              27,0 KiB  90,9 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-itsdangerous-2.1.2-2-any                                                         24,9 KiB  83,9 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-decorator-5.1.1-2-any                                                            16,2 KiB  53,1 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-flask-cors-3.0.10-4-any                                                          19,9 KiB  64,8 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-pyqt6-sip-13.4.1-1-x86_64                                                        68,5 KiB   210 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-pyrsistent-0.19.3-1-x86_64                                                       96,0 KiB   282 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-waitress-2.1.2-1-any                                                             82,3 KiB   242 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-flask-2.2.2-1-any                                                               141,3 KiB   402 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-pyqt6-webengine-6.4.0-1-x86_64                                                  115,7 KiB   322 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 qt6-multimedia-ffmpeg-6.4.2-1-x86_64                                                   115,3 KiB   321 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-jsonschema-4.17.3-1-any                                                         136,9 KiB   378 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 qt6-webchannel-6.4.2-1-x86_64                                                          118,6 KiB   328 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-werkzeug-2.2.3-1-any                                                            338,9 KiB   880 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-protobuf-21.12-1-x86_64                                                         298,4 KiB   775 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-orjson-3.8.7-1-x86_64                                                           243,2 KiB   619 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 qt6-positioning-6.4.2-1-x86_64                                                         353,1 KiB   837 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 qt6-multimedia-6.4.2-1-x86_64                                                          939,2 KiB  2020 KiB/s 00:00 [---------------------------------------------------------------------] 100%
 python-pyqt6-6.4.2-1-x86_64                                                              4,1 MiB  7,69 MiB/s 00:01 [---------------------------------------------------------------------] 100%
 qt6-webengine-6.4.2-3-x86_64                                                            64,5 MiB  31,9 MiB/s 00:02 [---------------------------------------------------------------------] 100%
 anki-2.1.60-1-x86_64                                                                    14,6 MiB  5,74 MiB/s 00:03 [---------------------------------------------------------------------] 100%
 Gesamt (20/20)                                                                          86,2 MiB  33,5 MiB/s 00:03 [---------------------------------------------------------------------] 100%
(20/20) SchlĂĽssel im SchlĂĽsselbund werden geprĂĽft                                                                   [---------------------------------------------------------------------] 100%
(20/20) Paket-Integrität wird überprüft                                                                             [---------------------------------------------------------------------] 100%
(20/20) Paket-Dateien werden geladen                                                                                [---------------------------------------------------------------------] 100%
(20/20) Auf Dateikonflikte wird geprĂĽft                                                                             [---------------------------------------------------------------------] 100%
(20/20) VerfĂĽgbarer Festplattenspeicher wird ermittelt                                                              [---------------------------------------------------------------------] 100%
:: Pre-transaction-Hooks werden gestartet …
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 2412
:: Paketänderungen werden verarbeitet …
( 1/20) Installiert wird python-waitress                                                                            [---------------------------------------------------------------------] 100%
( 2/20) Installiert wird python-decorator                                                                           [---------------------------------------------------------------------] 100%
( 3/20) Installiert wird python-orjson                                                                              [---------------------------------------------------------------------] 100%
( 4/20) Installiert wird python-protobuf                                                                            [---------------------------------------------------------------------] 100%
( 5/20) Installiert wird python-pysocks                                                                             [---------------------------------------------------------------------] 100%
( 6/20) Installiert wird python-werkzeug                                                                            [---------------------------------------------------------------------] 100%
( 7/20) Installiert wird python-itsdangerous                                                                        [---------------------------------------------------------------------] 100%
( 8/20) Installiert wird python-flask                                                                               [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für python-flask
    python-asgiref: async functions and views
    python-dotenv: loading env vars from files
( 9/20) Installiert wird python-flask-cors                                                                          [---------------------------------------------------------------------] 100%
(10/20) Installiert wird python-pyrsistent                                                                          [---------------------------------------------------------------------] 100%
(11/20) Installiert wird python-jsonschema                                                                          [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für python-jsonschema
    python-isoduration: for duration format
    python-fqdn: for hostname format
    python-idna: for idn-hostname format [Installiert]
    python-jsonpointer: for json-pointer & relative-json-pointer format
    python-rfc3339-validator: for date-time format
    python-rfc3987: for iri, iri-reference, uri & uri-reference format
    python-uri-template: for uri-template format
    python-webcolors: for color format
(12/20) Installiert wird qt6-multimedia-ffmpeg                                                                      [---------------------------------------------------------------------] 100%
(13/20) Installiert wird qt6-multimedia                                                                             [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für qt6-multimedia
    qt6-declarative: QML bindings [Installiert]
    qt6-quick3d: for QtQuick3DAudio
(14/20) Installiert wird qt6-webchannel                                                                             [---------------------------------------------------------------------] 100%
(15/20) Installiert wird qt6-positioning                                                                            [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für qt6-positioning
    qt6-declarative: QML bindings [Installiert]
    qt6-serialport: NMEA plugin
(16/20) Installiert wird qt6-webengine                                                                              [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für qt6-webengine
    pipewire: WebRTC desktop sharing under Wayland [Installiert]
(17/20) Installiert wird python-pyqt6-sip                                                                           [---------------------------------------------------------------------] 100%
(18/20) Installiert wird python-pyqt6                                                                               [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für python-pyqt6
    qt6-tools: QtHelp, QtDesigner bindings
    qt6-svg: QtSvg bindings [Installiert]
    qt6-declarative: QtQml bindings, qmlplugin [Installiert]
    qt6-quick3d: QtQuick3D bindings
    qt6-connectivity: QtBluetooth, QtNfc bindings
    qt6-multimedia: QtMultimedia bindings [Installiert]
    qt6-positioning: QtPositioning bindings [Installiert]
    qt6-remoteobjects: QtRemoteObjects bindings
    qt6-sensors: QtSensors bindings
    qt6-serialport: QtSerialPort bindings
    qt6-speech: QtTextToSpeech bindings
    qt6-webchannel: QtWebChannel bindings [Installiert]
    qt6-webengine: QtPdf bindings [Installiert]
    qt6-websockets: QtWebSockets bindings
    dbus-python: for python-dbus mainloop support [Installiert]
(19/20) Installiert wird python-pyqt6-webengine                                                                     [---------------------------------------------------------------------] 100%
(20/20) Installiert wird anki                                                                                       [---------------------------------------------------------------------] 100%
Optionale Abhängigkeiten für anki
    lame: record sound [Installiert]
    mpv: play sound. prefered over mplayer [Installiert]
    mplayer: play sound [Installiert]
    texlive-most: render LaTex in cards
:: Post-transaction-Hooks werden gestartet …
(1/7) Arming ConditionNeedsUpdate...
(2/7) Foreign/AUR package notification
iio-sensor-proxy-git 3.4.r1.5a1a5df-1
ookla-speedtest-bin 1.2.0-1
paleta 0.30-1
yoga-usage-mode-dkms-git r9.3d15f93-1
(3/7) Orphaned package notification...
libjffi 1.3.10-1
meson 1.0.1-1
(4/7) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/shells.pacnew
/etc/pacman.d/mirrorlist.pacnew
Please check and merge
(5/7) Updating the desktop file MIME type cache...
(6/7) Performing snapper post snapshots for the following configurations...
==> root: 2413
(7/7) Syncing all file systems...

No problem here. With 1 and 2

1) qt6-multimedia-ffmpeg  2) qt6-multimedia-gstreamer
5 Likes

Works fine here too, no problem installing these.

@gabriel-del you probably just need to refresh your mirrors. What is your method for updating? Try this:

garuda-update

After, try installing again.

6 Likes

In addition to the above, make sure you reboot after upgrades. Sometimes this helps, although I think a garuda-update will do the trick.

2 Likes

Maximum filesize mostly hints towards broken signatures - I rebuilt the package which means it śhould work fine now.

6 Likes

It worked now, thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.