Massive system Lag requires reset

Hey, there,
from time to time, I am having some very weird system lag, where almost everything freezes up (krunner, latte, plasma, youtube in firefox) and I get a few popups saying e.g. "Configuration file ~/.config/blablarc is not writable" - I then have to reset my computer, as I can almost do nothing apart from moving my cursor and barely interacting with the application I was using before that freeze.

Here is most of my Jorurnalctl output (Filtering everything except errors revealed nothing) 0bin - encrypted pastebin

CPU: 6-Core AMD Ryzen 5 2600X (-MT MCP-) speed/min/max: 3820/2200/3600 MHz Kernel: 5.12.7-zen1-1-zen x86_64 Up: 15m 
Mem: 8053.1/32117.9 MiB (25.1%) Storage: 2.96 TiB (7.7% used) Procs: 371 Shell: fish 3.2.2 inxi: 3.3.04 

I am using the btrfs file system.

I don't know, what is happening here - Can anyone explain this to me?
Thanks!

Search the forum.

There are many different solutions posted in the past. I sometimes see this after a large update or deleting my timeshift snapshots. Usually performing a full btrfs balance operation fixs thing up (and reboot).

1 Like

I just tried that (sudo btrfs balance start / -v --full-balance), I hope it will not occur again - Also, for your info, I am storing my timeshift backups on a seperate drive. Also my last update wasn't that big, I think.

Next time, paste in bin.garudalinux.org

Also, are you sure that the explicitly installed softwares are not the issue?

1 Like

These are the programs I have installed manually (pacman -Qqent): PrivateBin

Quite a lot of them. Off course it is impossible to suspect any of them.

Wait and see if it happens again.

1 Like

To the best of my knowledge timeshift does not support storing system snapshots (with btrfs) on any partition other than the system partition.

You can of course do this with timeshift using rsync, but then you would have to uninstall all the handy grub snapshot restore features that Garuda comes installed with by default.

If you have btrfs snapshots working with timeshift from the grub start menu please detail how you accomplished this. Unless timeshift has recently changed their btrfs setup options I think something is amiss here.

2 Likes

Oh, yeah, I used my own timeshift config, I didn't ever use the btrfs one

So, you may have created this issue yourself by using a non-standard Garuda installation method. That is why we generally do not offer support advice for non-standard installs.

We never know what alterations the user has made, and we can not possibly predict the results. The method to correct problems in those situations would be nothing more than speculation, so we refrain from advising in these cases.

If you want to stray from the path Garuda has chosen, you basically need to learn how to manage the results of the changes you have made.

2 Likes

Huh? Why would using a different Timeshift config cause my system to hang up?
I am just using rsync instead of btrfs, so I always have secure backups of my system, in case I manage to somehow format my main drive - Also used it when switching distros, as I didn't have a seperate home partition yet.

How could I possibly know if you uninstalled all the related btrfs timeshift integration properly?

This stuff is the basis of what Garuda is built around. We had to prevent the Calamares installer from allowing non-btrfs installations precisely because of the problems created by novice users dramatically changing the default Garuda setup.

I really don't feel like debating this with you as this debate has already been done many times before. As I stated the result was having to block making changes through Calamares for users that refused to follow the distro's recommendations for file systems and minimum specs.

I'm not going to debate this again. Do as you wish with your own system, but don't expect distro Devs to rush to your assistance if you've seen fit to dismantle their default Garuda configuration.

3 Likes

I didn't want to debate with you about this, either - I didn't know this.
It's just, that having "actual" backups is something nice to have, for example, when you accidentally delete a file, you needed - so you just search for it in your backup and you can get it back.
Why is Garuda built around that? Why are btrfs backups better than rsync ones - Can you access the backups the same way, as you would with rsync backups - don't they clog my drive?
Edit: I just found this 18.04 - What's the difference between Rsync & BTRFS Snapshots - Ask Ubuntu - I don't know, if I will be able to access my accidentally deleted data as well as I would with rsync though, pondering...

Is there any way to get garuda's default user config? I am gonna try to revert some configs, but I don't know, if it will work.

They are in etc/skel

2 Likes

I have now reverted all of the few non-graphical configs from /etc/skel (that also didn't contain a timeshift config, but well, I can still set that up manually), so I am basically back to the defaults. If this problem reoccurs, then I think I am back to actually getting support

1 Like

Oh, I just realized - Funnily enough, changing the timeshift settings might have actually fixed the whole problem. I remember noticing a popup from time to time, where plasma told me "Filesystem <My backup - HDD> is not responding", and now, that I disabled my timeshift rsync backups (and moved it to a cronjob) - since then, it didn't happen again (at least yet). :rofl:
So I guess it's fine.
(Why is timeshift's rsync so weird)

So, I marked it solved !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.