Making your own garuda hyprland

Ahh I have been watching hyprland on arch videos for a while now and have been dying to try it out. Sadly I don't have a wifi at my current location and would be here for the next few months. Would have really loved to test this. :cry:


Just tried out the Hyprland ISO
Was able to boot in proprietry nvidia drivers , OHH yeah !!!
but seems like forgot to put foot terminal config in my Merge request :sweat_smile:
It shouldn't be like this :

Actually I was making something like this :

other things blowing my minds :
nwg-drawer :
expectation :

what it became :

for log out screen :
expectation :

what I got :

Seems like I have to rebase my MR and put some missing thing and work on some problematic stuffs or should I just put them here ? :slightly_smiling_face:

Anyways hold tight we would be doing a big mission. :racing_car: :fire: :fire:


Added foot config and tried to repair logout screen (hope it works) :



A great thing to test the configs is creating new user and just putting the config files of /etc/skel of the settings package in it's home directory. This way testing is faster and more efficient :slight_smile:


Sorry , language problem :sweat_smile:
I didn't get it.

Well, to test changes to done configs to the following:

  1. Create a new user
  2. The settings repo contains an etc folder. Copy the files contained in etc/skel/* to the new users home directory
  3. Login as the new user - this will be similar to running the iso.

This is a great project, my main OS is Garuda but I've been playing with Hyprland on my laptop.
Cant wait to try this out tomorrow !

1 Like

Thanks :smile: ,

1 Like

Thank you very much !

Been loving Dragonized on my main gaming desktop for over 6 months now !

Btw, AnkurAlpha / Garuda Hyprland Settings · GitLab
Is the dotfiles I should use as they're more updated right ?
Rather than the garuda-linux repo ?

Having a problem installing as the "install garuda linux" button doesn't do anything once booted into the USB.. everything else works fine seemingly but not the actual "install Garuda"
I'm booting into open drivers as my system is AMD.

So I'm stuck in the live USB environment, strange.

Any ideas ?

Cheers !


sudo -E calamares -D8

in terminal.

1 Like

That did the trick !
Silly of me to not think of that, thank you very much.

For testing purpose , yes !!!
It is the place as feedbacks are required.

1 Like

Very good, the installation completed without issue but I cant boot into it.
I can boot into secure and I get the little archlinux logo below my Lenovo login screen but it just hangs and never proceeds unfortunately.

Reformatted with normal Arch and sway, that seems to work.
Guess my Hypr-Garuda dream will have to wait for now :confused:

Relax some things might take time :slightly_smiling_face: ,
I learnt it by my own self from learning git a few weeks ago to now slowly making the things to role with others :wink:


Yeah it's no rush. I'm very happy with my now riced out Arch Hyprland machine ^^

Tho I do prefer all the extra utilities and user friendlyness of Garuda, I can't believe this is not a more popular distro, like it hardly ever appears on the lists of "good" distros.

Of all the distros I tried, this is by far the one with most "just works" and loads of configs available from the start. I'd argue its better for newbies than the likes of Linux MInt even.

Huge shoutout to all the maintainers and devs working on this beautiful distro !