Mac Book Pro13" 2017 Could not install bootloader

I hope you can help me install Garuda on my MacBook, Garuda is the only distro that recognizes bluetooth.


This is the error I get every time I want to install Garuda.

Could not install bootloader; the installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
returned error code 1.

System info.

Operating System: Garuda Linux
KDE Plasma Version: 5.26.1
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 6.0.2-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-7360U CPU @ 2.30GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® Iris® Plus Graphics 640
Manufacturer: Apple Inc.
Product Name: MacBookPro14,1
System Version: 1.0

Hi there, welcome to the forum!
There are several users in the forum with a MacBookPro, but there are so different models that your issue might be peculiar.
Your error reminds me of this thread (although that was a Macbook Air):

The solution might seem a bit strange and complicated, but it's worth trying in my opinion.
Before doing that, if you want, I remember also an interesting suggestion from a topic which was going on in parallel in those days (for a MacBook Air again...):


I have the same issue with MacBookAir7,2. Using this version works for me.


Thanks , but this don´t work for me.

What did you do? Which part didn't work?


Nothing, I think the problem is in the Garuda installer when looking for a directory to install the grub-install, I've tried several desktop environments Garuda KDE Dr460nized, Garuda GNOME, Garuda Wayfire and they all end up with the same error mentioned in the post. My theory is that the installer looks for a directory name on the disk that it cannot find because it is named differently. I can install other distros like manjaro or ubuntu without problems, but all the audio and bluetooth drivers do not work otherwise everything works my right.

For sure there is a problem with efibootmgr (of Arch), which is not able to configure the UEFI NVRAM entry.
Have you tried also, after a failed installation, the suggestions given above (e.g. the --removable option in grub-install or the use of efibootmgr from a Debian live iso)?


I am going to will tested this efibootmgr from a Debian live iso.

A lot of things changed for the Macbook Pro's 2016/2017+ making them problematic for linux. I haven't really read a lot of success with these later macbook pros and linux. Here is a guide but has not been updated since 2021, but it at least points to the problematic areas;

Also, there is the Arch Mac Wiki;

And for later models;

Good luck!