Lxqt-kwin scaling issues on hidpi (retina) display

Hello,

As I log in on a fresh install every desktop element is very small. To solve the problem I go on "session settings" (LXQT preferences) where I enter a scale factor of 2. Finally I reboot the system.

There are 2 resulting problems:

  1. The scaling is not applied consistently. In other words not all the graphical desktop elements react to the setting. For example the LXQT menu and the LXQT lateral panel have the desired setting, however the log in screen does not. Same goes for the top "bar" of each window which remains small while the window's content is scaled properly (an exception here is the firedragon browser which applies the setting as expected)

  2. The bottom bar (Latte) disappears after the scaling. I tried to disable autohide but could not find a menu item for setting the Latte bar.

Hope somebody can provide me with some hints/solution

Thank you!

System:
  Kernel: 5.19.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=ee7db7b3-1fe0-4d7c-81e0-f5de706aa80b rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=1c399ee5-0dcd-4d5e-82a8-53abe8f1e808 loglevel=3
  Desktop: LXQt v: 1.1.0 tk: Qt v: 5.15.6 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Apple product: MacBookPro11,3 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-2BD1B31983FE1663
    serial: <superuser required>
  Mobo: Apple model: Mac-2BD1B31983FE1663 v: MacBookPro11,3
    serial: <superuser required> UEFI: Apple v: 432.60.3.0.0 date: 10/27/2021
Battery:
  ID-1: BAT0 charge: 57.0 Wh (73.7%) condition: 77.3/95.4 Wh (81.1%)
    volts: 12.6 min: 11.3 model: DP bq20z451 type: Li-ion serial: N/A
    status: charging cycles: 1011
CPU:
  Info: model: Intel Core i7-4850HQ bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x46 (70) stepping: 1 microcode: 0x1C
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1186 high: 2400 min/max: 800/3500 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 2295 3: 800
    4: 800 5: 2400 6: 800 7: 800 8: 800 bogomips: 36716
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GK107M [GeForce GT 750M Mac Edition] vendor: Apple
    driver: nouveau v: kernel non-free: series: 470.xx+
    status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-18 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:0fe9
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nouveau unloaded: modesetting
    alternate: fbdev,nv,vesa gpu: nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
    s-diag: 898mm (35.37")
  Monitor-1: eDP-1 model: Apple Color LCD built: 2013 res: 2880x1800 hz: 60
    dpi: 221 gamma: 1.2 size: 331x207mm (13.03x8.15") diag: 390mm (15.4")
    ratio: 16:10 modes: max: 2880x1800 min: 800x600
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14e4:1570 class-ID: 0480
  Sound Server-1: ALSA v: k5.19.12-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-8.3:6 chip-ID: 05ac:8289 class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 465.92 GiB used: 12.36 GiB (2.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0512F
    size: 465.92 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: JA1Q scheme: GPT
Partition:
  ID-1: / raw-size: 448.53 GiB size: 448.53 GiB (100.00%) used: 12.36 GiB
    (2.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 448.53 GiB size: 448.53 GiB (100.00%) used: 12.36
    GiB (2.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 448.53 GiB size: 448.53 GiB (100.00%) used: 12.36
    GiB (2.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 448.53 GiB size: 448.53 GiB (100.00%) used: 12.36
    GiB (2.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 71.0 C mobo: N/A gpu: nouveau temp: 65.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 234 Uptime: 1h 18m wakeups: 7 Memory: 15.54 GiB used: 2.86 GiB
  (18.4%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1155 libs: 307
  tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: qterminal inxi: 3.3.21
Garuda (2.6.8-1):
  System install date:     2022-10-03
  Last full system update: 2022-10-03 ↻
  Is partially upgraded:   No                                                                                                                                                
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:  

:slight_smile:

This is by-design :upside_down_face: , since this desktop is of Frankenstein type.
The original LxQt is originally using Openbox window manager.
Even if the devs include an easy method to use a different WM, like kWin (which produces an excellent result combo), it doesn't mean it is automatically syncing all settings to both parts (LxQt <=> kWin). You need to do it manually, or use modification methods that work consistently to both.

For the specific issue (small elements), I would rather suggest to change font size, instead of scaling the Display. Making scaling consistently applied is very difficult in such multi-part systems in my experience, but you may try. You should know that GTK apps need their own scaling as well (GDK_DPI_SCALE env var).

The lucky part is that you may easily change kWin and other KDE related settings, using the usual KDE System Settings application.

This is SDDM and is not a part of the Desktop Environment (DE). Although you might be able to easily modify it with KDE System Settings as well.

Latte dock development has paused for some time now, and such issues were not easily solved, especially after several new KDE development code. I would suggest you find another way to replace it. Or reset its config files to default and try more settings (it has hundreds of them).

3 Likes

It looks like Frankenstein only after scaling on hidpi though.. Not to worry I'm happy to fiddle with it for a while.

Just one more question.
Does Garuda provide documentation specifically on how the various modules were linked/tied up together during the development of this edition (or any other garuda edition for that matter) ?

Thank you

as an aside, I've been using lxqt for a good few months and the scaling is "selective" as previously mentioned, so in the end i found its either a case of chasing down font sizes in kwin and other such things (firefox did give an issue i seem to remember too), so in the end I just dropped the resolution a little bit (14 inch, FHD originally), and personally i don't notice any difference in clarity (but that might be my slowly ageing eyes!).

Everything that Garuda develops is Open Source.
Take a look at Garuda GitLab.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.