Low performance when not plugged in with charger (laptop)

when i installed garuda on my laptop, it was very smooth (while both plugged in and not plugged in) but after updating it for first time , it only works perfect when plugged in , otherwise it is very lagy and choppy.
please fix it so that i could recommend it to other people.

If you are hoping for a knowledgeable answer, you will need (at a minimum) information about the system you are running it on (terminal command inxi -Fxxxza, then paste the text output between sets of 3 backticks in the next message. It might also help to know what packages were updated. A section from /var/log/pacman.log - also posted between sets of backticks - will convey that information.

With that added to the next post, help may be possible.

1 Like

I have exactly the same symptoms. When the power is disconnected, the system runs as if it were on hardware from twenty years ago. Sorry for the English (deepl.com/translator).

System:
  Kernel: 5.10.8-112-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive 
  BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
  root=UUID=ec47e905-39f5-4440-9fbb-003f6a0dcca7 rw [email protected] 
  quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Garuda Linux 
Machine:
  Type: Laptop System: HP product: HP Laptop 15-da0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 84A7 v: 80.31 serial: <filter> UEFI: Insyde v: F.07 
  date: 11/21/2018 
Battery:
  ID-1: BAT1 charge: 28.8 Wh condition: 28.8/41.9 Wh (69%) 
  volts: 13.0/11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 
CPU:
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) 
  stepping: A (10) microcode: E0 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28824 
  Speed: 2511 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 2511 
  2: 2551 3: 3400 4: 3400 5: 3370 6: 3402 7: 3402 8: 3401 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard 
  driver: nvidia v: 460.32.03 alternate: nouveau,nvidia_drm 
  bus ID: 01:00.0 chip ID: 10de:174e 
  Device-3: Lite-On HP TrueVision HD Camera type: USB driver: uvcvideo 
  bus ID: 1-5:3 chip ID: 04ca:7092 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
  OpenGL: renderer: GeForce MX110/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.10.8-112-tkg-bmq 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8821ce v: N/A 
  modules: rtw88_8821ce,8821ce port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:c821 
  IF: wlo1 state: up mac: <filter> 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 6060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Drives:
  Local Storage: total: 223.57 GiB used: 24.88 GiB (11.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSCKHF240A4L 
  size: 223.57 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: LSTi 
Partition:
  ID-1: / raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 24.88 GiB (11.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 24.88 GiB (11.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-4: /var/log raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 24.88 GiB (11.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-5: /var/tmp raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 24.88 GiB (11.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram3 
  ID-5: swap-5 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram4 
  ID-6: swap-6 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram5 
  ID-7: swap-7 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram6 
  ID-8: swap-8 type: zram size: 731.7 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram7 
Sensors:
  System Temperatures: cpu: 55.5 C mobo: 29.8 C gpu: nvidia temp: 58 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 269 Uptime: N/A wakeups: 1 Memory: 5.72 GiB 
  used: 1.9 GiB (33.2%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 1668 lib: 455 Shell: Zsh v: 5.8 running in: konsole 
  inxi: 3.2.01

I don't know how to paste the system information correctly.
@3esky
Read Wiki Reporting Bugs
If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.
greetings SGS

Thanks and sorry. Next answer should be posted correctly.

1 Like

@3esky

I don't have a notebook but the nature of the matter is that I have an arrow-fast battery-based system, which will probably also run out of power very quickly.

Battery:
  ID-1: BAT1 charge: 28.8 Wh condition: 28.8/41.9 Wh (69%) 
  volts: 13.0/11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 

status full, condition is bad 69% ???
IDK nothing about :smiley:

So is the battery faulty?

IDK, read terminal output and check if the values are the same in conky or other tools.

Actually this happens due to auto-cpufreq

When on battery it sets powersave governor to increase battery life.

To disable this feature

You can disable the service

systemctl disable auto-cpufreq

Doing this and rebooting will set your governor to performance.
But it will reduce battery life.

5 Likes

Thank you very much. After executing the command in the terminal, the system runs just as fast without power as it does on power. Previously on a clean Arch system I did not observe such anomalies. Out of pure curiosity I will reinstall the system to Garuda Barebones KDE and check how the battery will behave without mains power (unless power saving in Garuda Linux is enabled by default). I don't know how it is with a pure Arch system (it will be tested as another - installed from a script: GitHub - MatMoul/archfi: Arch Linux Fast Installer : tutorial installer, GitHub - MatMoul/archdi: Arch Linux Desktop Installer : tutorial installer) - Arch Linux Desktop Install download | SourceForge.net,

Thank you so much. Really appreciated. Keep Helping.
:relaxed:

I think there is a bug regarding auto-cpufreq.service.
After the first update my desktop run at lowest possible speed, but there is no battery to save!
So my first action after a fresh install of garuda is:

sudo systemctl disable auto-cpufreq.service
reboot

There after everything runs as expected.

I had the same issue, I disabled the 'auto-cpufreq.service' but the issue stays. I can see with cpupower that the cores are being scaled down and the governor is being changed to Powersave.

sudo systemctl status auto-cpufreq.service

auto-cpufreq.service - auto-cpufreq - Automatic CPU speed & power optimizer for Linux
Loaded: loaded (/usr/lib/systemd/system/auto-cpufreq.service; enabled; vendor preset: disabled)
Active: inactive (dead)

Then it is a different issue.
No system is the same. Start another topic, if you can't solve it.
Welcome to Garuda!

1 Like