Low-memory warning

@all, hoops i must say i forgot something !
I have a low-memory warning poping from time to time !
Wonder where it comes from...
Swappiness=10.... free space on ssd >70 °/°
Does anyone has kind of a clue to solve this "no problem" (for the time beeing!) ?
Best & feel free to use [email protected], i'm not that keen on reading Forums...

Fred

1 Like

It comes from
nohang

It shows notification when Your ram memory is low
And tries to free up memory by killing some bad processes

4 Likes

Thanks a lot... Seems that there is not much i can do !
Except adding ram i guess...
I'll do with the warning as long as it remains a warning !
Best
Fred.

2 Likes

Btw you can also disable to warning, nohang ships 2 systemd configs one with warnings one without. Do the following to apply:

sudo systemctl disable --now nohang-desktop
sudo systemctl enable --now nohang
4 Likes

For amusement, I loaded the latest lxqt-lite live-USB onto my baytrail laptop (2GB RAM) and had a number of warnings from nohang. This is a good addition, as nohang kept the desktop stable. 2GB is still not enough RAM for Garuda (and many other distros!) The baytrail is heading for retirement - too many limitations and it is accumulating hardware failures too.

3 Likes

Good morning @dr460nf1r3 & @jbMacAZ & @librewish...
I kind of handled nohang !
By the way my ram is~4GB, should do for the time being !
In fact that was the reason of my wonderings about the stange "warning" !
Best and many thanks to all & have a nice day.
Fred.

5 Likes