Low FPS on essentially any game

Hi, so I am running into an issue when trying to play a game, more notably through steam. They work just fine on my Windows installation; I have a 1660 super w/ an r5 3600 and am using foss drivers <- could that be the issue perhaps? i ran into these issues w/ the KDE gaming flavor and decided to give gnome a try -- same issue. any suggestions? thanks. for reference, i use vsync w/ windows so my fps is stable at 60 during gameplay with any game i play, however on linux w the same game and same settings i can't get more than 20

Yes.  

3 Likes

using proprietary freezes for me—i suppose ill have to just scratch it and wait until it's usable for me

Not sure what that issue is referring to. You might search the forum for similar issues, or start a thread with details?

yeah i might go ahead and do so, just when i boot the live usb and select the nonfree drivers, it freezes for me on the garuda splash. so i'm thinking i might try to install w the foss drivers and install the nonfree drivers after the fact or something. wonder if that would make any difference. I found a topic that had some solutions so ill see what happens :woman_shrugging:t3:

1 Like

That should work - some systems just don't like booting with the non-free drivers. :confused:

no avail unfortunately. i tried installing the nonfree drivers after a fresh install and it's ■■■■■ on "loading kernel". oh well, guess i might need to just cut my losses. not quite sure what's happening not what to try lol

Did you update your system before installing the drivers? if not, it probably didn't complete correctly.

yeah, it updated everything (to my knowledge).

I read that gigabyte motherboards are not friendly with linux so that could be an issue? dunno

1 Like

i dunno what i did, but somehow i managed to get the drivers installed after reverting to a snapshot and trying again and—yeah i genuinely have no idea what i did, but it's working great now and games run smoothly using the nonfree drivers. thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.