Login screen keyboard layout

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

System:    Kernel: 5.15.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=35a6b30d-744e-4d13-b40c-bf7750d693d6
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 amd_iommu=on iommu=pt
pcie_acs_override=downstream,multifunction
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: Gigabyte product: B550 VISION D v: -CF serial: <superuser required>
Mobo: Gigabyte model: B550 VISION D serial: <superuser required> UEFI: American Megatrends LLC.
v: F14c date: 09/06/2021
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3 serial: <filter>
charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 16-Core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25)
model-id: 21 (33) stepping: 0 microcode: A201016 cache: L1: 1024 KiB L2: 8 MiB L3: 64 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 217184
Speed: 3394 MHz min/max: N/A Core speeds (MHz): 1: 3394 2: 3394 3: 3394 4: 3394 5: 3394 6: 3394
7: 3594 8: 3394 9: 3394 10: 3394 11: 3394 12: 3394 13: 3394 14: 3394 15: 3394 16: 3394 17: 3394
18: 3394 19: 3394 20: 3394 21: 3394 22: 3394 23: 3394 24: 3394 25: 3394 26: 3394 27: 3394
28: 3394 29: 3394 30: 3394 31: 3394 32: 3394
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Tul driver: amdgpu v: kernel
bus-ID: 56:00.0 chip-ID: 1002:73bf class-ID: 0300
Device-2: ARC Camera type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-1:2
chip-ID: 05a3:9331 class-ID: 0300 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 7680x2160 s-dpi: 140 s-size: 1393x391mm (54.8x15.4") s-diag: 1447mm (57")
Monitor-1: DisplayPort-0 res: 3840x2160 hz: 60 dpi: 163 size: 600x340mm (23.6x13.4")
diag: 690mm (27.2")
Monitor-2: DisplayPort-2 res: 3840x2160 hz: 60 dpi: 163 size: 600x340mm (23.6x13.4")
diag: 690mm (27.2")
OpenGL:
renderer: AMD Radeon RX 6900 XT (SIENNA_CICHLID DRM 3.42.0 5.15.4-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] driver: snd_hda_intel
v: kernel bus-ID: 56:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus-ID: 59:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: ARC Camera type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-1:2
chip-ID: 05a3:9331 class-ID: 0300 serial: <filter>
Device-4: Razer USA RZ19-0229 Gaming Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:3 chip-ID: 1532:0511 class-ID: 0300
serial: <filter>
Device-5: Generalplus USB Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 5-3.4:5 chip-ID: 1b3f:2008 class-ID: 0300
Sound Server-1: ALSA v: k5.15.4-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel port: e000
bus-ID: 51:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp81s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel port: d000
bus-ID: 52:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp82s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 53:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp83s0 state: down mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
IF-ID-2: virbr0 state: down mac: <filter>
IF-ID-3: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-4: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6.1:6
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 4.51 TiB used: 211.18 GiB (4.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: MSI model: M480 1TB size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EIFM21.1 temp: 29.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Corsair model: Force MP510 size: 894.25 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: ECFM12.3 temp: 38.9 C scheme: GPT
ID-3: /dev/nvme2n1 maj-min: 259:7 vendor: Crucial model: CT1000P5PSSD8 size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P7CR402 temp: 38.9 C scheme: GPT
ID-4: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 033 scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
ID-5: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 EVO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: BB6Q
scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
Partition: ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 211.18 GiB (22.7%) fs: btrfs
block-size: 4096 B dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 1.2 MiB (0.5%) fs: vfat
block-size: 512 B dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 211.18 GiB (22.7%) fs: btrfs
block-size: 4096 B dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 211.18 GiB (22.7%)
fs: btrfs block-size: 4096 B dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 211.18 GiB (22.7%)
fs: btrfs block-size: 4096 B dev: /dev/sdb2 maj-min: 8:18
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 125.74 GiB used: 4.8 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 595 Uptime: 46m wakeups: 2 Memory: 125.74 GiB used: 19.38 GiB (15.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1966 lib: 551
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.09

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

  1. Problem 1 Login screen keyboard layout

I changed the keyboard layout to be pt-pt in settings and it is the only keyboard layout i have.

In the login screen it keyboard layout is not pt-pt and it is en-us. this is causing me problem in typing the password. this is the same when the computer wakes up from sleep. sometimes when i type the correct password in en-us/pt-pt it is not logging in. i try to change the keyboard layout by pressing the shortcut to change the layout to pt-pt and typed the password and it is filing to login sometimes. it is not consistent. i need to heard reboot the system sometime because i was not able to login

  1. Problem 2 - monitor shows black screen when i wake up the computer from sleep.

Sometimes when i wake the computer from sleep the monitor stays black screen. It is not working consistently. Some times it works and some it does not work.

Report everything you have already attempted to solve your problem.

I tried this Keyboard layout for login screen - Kde Plasma - Manjaro Linux Forum and it fixed the login screen keyboard layout.

But did not fix the layout problem when i wake the computer from sleep.

Hi there, welcome to the commmunity.

It is recommended to have numeric password if you have to switch between layouts often. I know it is not a solution, but it is a clever workaround.
Also, you can have on screen keyboard to prevent mistakes.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.