Locale question

As someone who reads only one language, I don't often change my locale but I did when I was doing some testing. I seem to be having some challenges changing it back. Most everything is in English now except console applications.

Here is what my locale settings look like:

[garuda-snapper ~]>> localectl                                                                                                                                                    
System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us

[garuda-snapper ~]>> echo $LANG
en_US.UTF-8

[garuda-snapper ~]>> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Here is what happens when I run something in a terminal:

[garuda-snapper ~]>> sudo pacman -Sy
[sudo] Passwort fΓΌr dalto:
:: Paketdatenbanken werden synchronisiert …
core ist aktuell
extra ist aktuell

I am sure I have missed something, but I don't know what.

Post your inxi -Faz, please :slight_smile:

localectl
System Locale: LANG=en_US.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
VC Keymap: de
X11 Layout: de

╭─[email protected] in ~ took 46ms
╰─> echo  $LANG
en_US.UTF-8

╭─[email protected] in ~  
╰─> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

╭─[email protected] in ~
╰─> sudo pacman -Sy
[sudo] password for sgs:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date

╭─[email protected] in ~ took 4s
Summary

???

1 Like

Here are the formats settings:

sddm, plasma and all gui applications are in English.

1 Like

OK, I just found this:

[garuda-snapper ~]>> env | grep LANGUAGE
LANGUAGE=en_US:de

The only reference I can see to that is in ~/.config/plasma-localerc

[Formats]
LANG=en_US.UTF-8

[Translations]
LANGUAGE=en_US:de

That corresponds to this setting:

I deleted german, which resolves the issue, but it doesn't seem like that should be needed.

1 Like

Maybe settings from @dr460nf1r3 went to the ISO?

I can't remember the file name with the long list of all languages. Maybe there are en and de are unchecked, i mean without the # in front.

Hello.
I'm having a similiar issue. I've added Japanese as a secondary language.
Command line and some applications are using it over English.

localectl
System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us

locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

echo $LANG
en_US.UTF-8

Have You Rebooted and can you provide your

inxi -Faz

Unfortunately, I never solved it, I just removed the secondary language.

The issue is that it seems to set the env variable LANGUAGE.

You could try setting LANGUAGE explicitly and see if that takes preference.

Yes, I have rebooted. Here is the output

inxi -Faz
System:
Kernel: 5.15.8-227-tkg-pds x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-pds
root=UUID=0b597938-c2be-4d69-98aa-7454d3223d1f rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=7b0311f4-0e83-4091-aee7-5aa25086f458 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial:
Mobo: ASUSTeK model: TUF GAMING X570-PRO (WI-FI) v: Rev X.0x
serial: UEFI: American Megatrends v: 4021
date: 08/10/2021
CPU:
Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3628 high: 3766 min/max: 2200/4850 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3598 2: 3596
3: 3599 4: 3766 5: 3682 6: 3599 7: 3598 8: 3599 9: 3585 10: 3591 11: 3598
12: 3593 13: 3599 14: 3753 15: 3701 16: 3591 bogomips: 121725
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 09:00.0
chip-ID: 10de:1c03 class-ID: 0300
Display: x11 server: [X.Org](http://X.Org) 1.21.1.2 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 106 s-size: 613x362mm (24.1x14.3")
s-diag: 712mm (28")
Monitor-1: HDMI-0 res: 2560x1440 hz: 60 dpi: 107
size: 610x356mm (24.0x14.0") diag: 706mm (27.8")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f1
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-3: Logitech G430 Surround Sound Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:3 chip-ID: 046d:0a4d
class-ID: 0300
Sound Server-1: ALSA v: k5.15.8-227-tkg-pds running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac:
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
port: N/A bus-ID: 05:00.0 chip-ID: 8086:15f3 class-ID: 0200
IF: enp5s0 state: down mac:
IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Drives:
Local Storage: total: 8.65 TiB used: 6.85 TiB (79.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: rev: S5Z42109
temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000DM004-2CV104
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5425 serial: rev: 0001 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 4B6Q
ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000DM004-2CV104
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5425 serial: rev: 0001 scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Generic model: Flash Disk
size: 7.5 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: rev: 8.07 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 896.76 GiB size: 896.76 GiB (100.00%)
used: 282.28 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 896.76 GiB size: 896.76 GiB (100.00%)
used: 282.28 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 896.76 GiB size: 896.76 GiB (100.00%)
used: 282.28 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 896.76 GiB size: 896.76 GiB (100.00%)
used: 282.28 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: partition size: 34.46 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 31.32 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 39 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 426 Uptime: 12m wakeups: 0 Memory: 31.32 GiB
used: 8.62 GiB (27.5%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 Packages: 1907 pacman: 1901 lib: 473 flatpak: 6 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

@dalto
Setting LANGUAGE explicitly to en_US.UTF8 does work.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.