Live USB goes to black screen after selected Garuda on GRUB menu

I am having issues installing Garuda KDE Dragonized on my desktop. I have created the Live USB with the Garuda Downloader in Linux and used it to install Garuda on a laptop which worked without issues.

When I boot from the Live USB on my desktop and select the Garuda options (free or non-free options) the screen immediately goes black and doesn't respond to any inputs.

Removing the quiet option from GRUB command doesn't show anything.

Below is the output for inxi -Fas from running KDE Barebones on the machine I am trying to install Dragonized on.

Post your terminal/konsole in- and output as text (no pictures) from:

[*****@b560i ~]$ sudo inxi -Faz
[sudo] password for *****:             
System:    Kernel: 5.10.76-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=9d43fa8d-fa77-4c15-8db9-eac2cf54c40e rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=9e90f1e2-d429-4d60-a169-89d578cb503d loglevel=3
           Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: Gigabyte product: B560I AORUS PRO AX v: -CF serial: N/A
           Mobo: Gigabyte model: B560I AORUS PRO AX v: x.x serial: N/A UEFI: American Megatrends LLC. v: F6 date: 06/18/2021
CPU:       Info: 8-Core model: Intel Core i7-10700K socket: U3E1 bits: 64 type: MT MCP arch: Comet Lake family: 6
           model-id: A5 (165) stepping: 5 microcode: EC cache: L1: 512 KiB L2: 16 MiB L3: 16 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 121596
           Speed: 4172 MHz min/max: 800/5100 MHz base/boost: 2970/5100 volts: 0.9 V ext-clock: 100 MHz Core speeds (MHz):
           1: 4172 2: 4581 3: 4638 4: 4635 5: 4629 6: 4700 7: 4567 8: 4676 9: 4566 10: 4555 11: 4208 12: 4700 13: 4665
           14: 4700 15: 4617 16: 4076
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Gigabyte driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1e84 class-ID: 0300
           Device-2: Razer USA Razer Kiyo Pro type: USB driver: snd-usb-audio,uvcvideo bus-ID: 2-3:3 chip-ID: 1532:0e05
           class-ID: 0102
           Display: server: 1.20.13 compositor: kwin_x11 driver: loaded: nvidia unloaded: modesetting
           alternate: fbdev,nouveau,nv,vesa resolution: <missing: xdpyinfo>
           OpenGL: renderer: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: Intel vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:f0c8 class-ID: 0403
           Device-2: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f8
           class-ID: 0403
           Device-3: ZhuHai JieLi EDIFIER G2000 type: USB driver: hid-generic,snd-usb-audio,usb-storage,usbhid bus-ID: 1-10:5
           chip-ID: 2d99:a005 class-ID: 0300 serial: <filter>
           Device-4: C-Media Audio Adapter (Unitek Y-247A) type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-6:8
           chip-ID: 0d8c:0014 class-ID: 0300
           Device-5: Razer USA Razer Kiyo Pro type: USB driver: snd-usb-audio,uvcvideo bus-ID: 2-3:3 chip-ID: 1532:0e05
           class-ID: 0102
           Sound Server-1: ALSA v: k5.10.76-1-lts running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.39 running: no
Network:   Device-1: Intel Ethernet I225-V vendor: Gigabyte driver: igc v: kernel port: N/A bus-ID: 04:00.0 chip-ID: 8086:15f3
           class-ID: 0200
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
           IF: wlp5s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:7 chip-ID: 8087:0029 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: see --recommends
Drives:    Local Storage: total: 931.51 GiB used: 197.24 GiB (21.2%)
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G size: 931.51 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S5Z42105 temp: 37.9 C
           scheme: GPT
           SMART: yes health: PASSED on: 69d 19h cycles: 222 read-units: 38,137,695 [19.5 TB]
           written-units: 17,001,070 [8.70 TB]
Partition: ID-1: / raw-size: 914.17 GiB size: 914.17 GiB (100.00%) used: 197.24 GiB (21.6%) fs: btrfs block-size: 4096 B
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat block-size: 512 B
           dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 914.17 GiB size: 914.17 GiB (100.00%) used: 197.24 GiB (21.6%) fs: btrfs block-size: 4096 B
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw-size: 914.17 GiB size: 914.17 GiB (100.00%) used: 197.24 GiB (21.6%) fs: btrfs
           block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 914.17 GiB size: 914.17 GiB (100.00%) used: 197.24 GiB (21.6%) fs: btrfs
           block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 17.05 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
           ID-2: swap-2 type: zram size: 15.5 GiB used: 259.8 MiB (1.6%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 48.0 C mobo: 16.8 C gpu: nvidia temp: 56 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 410 Uptime: 2h 25m wakeups: 0 Memory: 15.5 GiB used: 10.85 GiB (70.0%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1135 lib: 291 Shell: Bash (sudo) v: 5.1.8
           running-in: konsole inxi: 3.3.08

Read the FAQ section for possible solutions.

Welcome to the forum.


I have gone through the FAQs and tried many different solutions.

The only thing I can seem to drill down to being the issue is the Linux Kernal, Zen vs non-Zen or 5.10 LTS vs 5.14. Could this be it? Mainly because the Garuda KDE Barebones ships with the non-Zen 5.10 LTS kernel.

If the KDE barebones boots without issues them a kernel issue is a distinct possibility.

Test the Xfce live boot, as it also uses the LTS kernel. If that also boots correctly then a kernel issue is looking likely.

You have not given enough details about which solutions you have tested.

Did you also test out the free driver option at install?

Did you test out the proposed solutions on this thread in the FAQ:


Did you use the same USB stick and flashing tool for the two?

1 Like

The XFCE live boot worked fine.

The issue with the solutions on the page you've linked is that the black screen doesn't respond to any key input, I tried the whole range from F1-F12.

I tried the following things to fix it -

  1. modified GRUB command that launches the Live USB to get some form of debugging
  2. tried different versions of BIOS for the motherboard

There is not much more I could think of to attempt to resolve it.

For the Dragonized and KDE Barebones - yes. I did use a different one to test the XFCE (w/ LTS Kernel) as requested above by @tbg.

Sounds like a kernel issue.

1 Like

Maybe you could start with this, kindly created recently :slight_smile: although out of "standard" builds.

1 Like

That link sounds like exactly what I need @filo .

The link is returning 404. I also looked in the other link on the page - - the directory in question is no longer present.


I knew we could count on you. Fast (& furious?)!


LTS Kernel did the job. Looks spectacular on the desktop.

@filo @dr460nf1r3 @tbg Thank you for the help.

Should this be raised further or do I mark the LTS ISO download as the solution?


Theoretically, for the sake of the community, an "upstream" bug report could be opened, but I think it would be very complex to provide a complete enough picture of the situation to work with...
It seems to me that some kernel regressions for specific architectures happen every now and then (to me in 8 months a couple of times), but then at a later version everything is back in place.
In my opinion in a while you could try to install linux-zen again. If that doesn't work, keep using linux-lts. If you leave them both there, linux-zen will be updated and you can try booting with it each time.
The only annoyance would be that linux-zen, when present, I believe is the first line, by default, in the grub, so you would have to do some configuration (just search the forum) to make linux-lts the default.
This is just my opinion, of course.


Sounds like a good idea. Thanks again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.