Limited connectivity, while dual-booting

Hello humans,
i have garuda and i dual-boot windows 10 with it , this problem only surfaced last week but i've been dual-booting for a long time, anyways when i open garuda everything looks normal for a minute then i get the limited connectivity notification and that's it, i tried disabling the firewall, restarting NetworkManager, i used timeshift to go back before the latest update and still not working. what could this be? windows's internet is working normally so this is just linux

this is my garuda-inxi output:

System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b3d84ad5-60fd-45aa-a0f9-6fd3f466cafc rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Hewlett-Packard product: HP Z220 CMT Workstation
v: N/A serial: <superuser required> Chassis: type: 6
serial: <superuser required>
Mobo: Hewlett-Packard model: 1790 serial: <superuser required>
UEFI: Hewlett-Packard v: K51 v01.86 date: 06/13/2018
CPU:
Info: model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 2755 high: 3894 min/max: 1600/3900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1748 2: 3889 3: 2398
4: 2831 5: 3631 6: 2002 7: 3894 8: 1650 bogomips: 54277
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel IvyBridge GT2 [HD Graphics 4000] vendor: Hewlett-Packard
driver: i915 v: kernel ports: active: HDMI-A-1
empty: DP-1, DP-2, HDMI-A-2, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0162
class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI1 model: Philips 271P4 serial: <filter>
built: 2015 res: 1920x1080 hz: 60 dpi: 81 gamma: 1.2
size: 600x340mm (23.62x13.39") diag: 685mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
v: 4.2 Mesa 22.0.1 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502
class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
RAID:
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
port: f060 bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: N/A class-ID: 0104
Drives:
Local Storage: total: 577.55 GiB used: 104.91 GiB (18.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hikvision model: HS-SSD-C100 120G
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 979 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: KC65
scheme: GPT
Partition:
ID-1: / raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 104.89 GiB (94.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 25.5 MiB (9.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 104.89 GiB (94.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 104.89 GiB (94.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 104.89 GiB (94.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.07 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 284 Uptime: 29m wakeups: 0 Memory: 15.07 GiB
used: 3.59 GiB (23.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1752 apt: 0 pacman: 1746 lib: 486
flatpak: 6 Shell: fish v: 3.4.1 running-in: yakuake inxi: 3.3.14
Garuda (2.5.8-1):
System install date:     2021-10-18
Last full system update: 2022-04-05
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Timeshift (maybe)
Failed units:

You may start from updating system packages. If what you report is a bug, it may have been fixed with some package upgrade.

Other thing to note is WinOS is changing hardware chips (network/bluetooth is known for that) that affect Linux, when on dual-boot.
That's why we suggest to not dual-boot with non-Linux OSes.

5 Likes

If the update doesn't solve, I'd also try changing your DNS server.

3 Likes

It is important to point out, as petsam has, the importance of regular updates since Garuda is a rolling distribution. Perhaps a more frequent scenario can help.

Generally-speaking, the very first thing that should be done before posting a help request, if possible, is a complete system update and reboot.

1 Like

Be sure you disable MAC Address randomization, and then reboot both your router and computer. Sometimes Windows using one Mac address and Linux using a different one can cause issues.

You did not state if this was purely an Ethernet issue, or if you were attempting to use Wifi. If you have a wifi card and it is now not being detected, then you will likely need to reset your bios to the factory default. Windows often interferes with networking on a hardware level, and a bios reset is required to initiate the network adapter to work in Linux again.

I also see your Ethernet speed is greatly reduced from what it should be. You will likely need to raise your speed manually in Network Manager, rather than using the autodetect setting.

It would also be a good idea to test out the LTS kernel to see if that improves your connectivity.

I'm also wondering if you are using the in kernel e1000e driver module, or are you using the e1000e driver from the AUR. If you are using the e1000e driver from the AUR, then you should rebuild it. If you are not using the AUR driver version, then it might be worth testing it out. Sometimes the AUR driver works for some people when the kernel module won't.

Setting a static IP address in your router may also help with your issue. Usually this is best done via MAC Address association in your router settings.

Good luck to you up there in the Great White North.

Good day, eh. :smile:

2 Likes