Libgedit-amtk and amtk conflict


I’m new to Garuda Linux (GNOME spin) and have just finished installing it, and was following the setup assistant, and when it opened a terminal to update the system, where it outputed:

:: Synchronizing package databases...


--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵


resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libgedit-amtk and amtk are in conflict
Press enter to exit

I tried to replace amtk with libgedit-amtk, but it did not work, the error being that:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing amtk breaks dependency 'amtk' required by gedit
:: removing amtk breaks dependency 'amtk' required by tepl
:: removing amtk breaks dependency '' required by tepl

Here’s my garuda-inxi:

  Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=61c1c33e-a699-4ed0-958d-57ad631bd571 rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=4a51abc8-9e46-4870-b0a5-44f3bd47b742 loglevel=3 ibt=off
  Desktop: GNOME v: 43.5 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.0
    Distro: Garuda Linux base: Arch Linux
  Type: Portable System: Dell product: Inspiron 3421 v: N/A
    serial: <superuser required> Chassis: type: 8 serial: <superuser required>
  Mobo: Dell model: 08RR4G v: A13 serial: <superuser required> UEFI: Dell
    v: A13 date: 12/14/2015
  ID-1: BAT0 charge: 9.2 Wh (100.0%) condition: 9.2/41.4 Wh (22.2%)
    volts: 16.7 min: 14.8 model: SMP-SDI2.8 DELL FW1MN31 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i3-3217U bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 798 high: 800 min/max: 800/1800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 800 3: 799 4: 798
    bogomips: 14367
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: Microdia Dell Laptop Integrated Webcam HD type: USB
    driver: uvcvideo bus-ID: 2-1.6:5 chip-ID: 0c45:64ad class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: LVDS-1 model: LG Display 0x03b7 built: 2012 res: 1366x768
    dpi: 112 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1366x768
  API: EGL/GBM Message: No known Wayland EGL/GBM data sources.
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Dell driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 06:00.0 chip-ID: 168c:0036 class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
    bus-ID: 09:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp9s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 2-1.4:6 chip-ID: 0cf3:0036 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 1.02 TiB used: 712.13 GiB (68.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS120G2G0A-00JH30 size: 111.8 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: HDD
    rpm: 5400 serial: <filter> scheme: GPT
  ID-1: / raw-size: 103.31 GiB size: 103.31 GiB (100.00%) used: 4 GiB (3.9%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 103.31 GiB size: 103.31 GiB (100.00%)
    used: 4 GiB (3.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 103.31 GiB size: 103.31 GiB (100.00%)
    used: 4 GiB (3.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 103.31 GiB size: 103.31 GiB (100.00%)
    used: 4 GiB (3.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.72 GiB used: 16.5 MiB (0.4%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.2 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 61.0 C mobo: 46.0 C
  Fan Speeds (RPM): cpu: 4028
  Processes: 266 Uptime: 21m wakeups: 1 Memory: 3.73 GiB
  used: 2.22 GiB (59.6%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1091
  libs: 340 tools: pamac,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-10-05
  Last full system update: 2023-10-05
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            

Hi there, welcome to the forum.
Could you please try again from terminal with


Gedit and tepl have both been updated for that replacement. It’s strange…

Thanks for the fast reply!
I just ran the command and got the exact same output, it there any additional information I can send to help with the problem?
Also, a lot of other packages were automatically flagged to be replaced during the garuda-update, but that one didn’t, is that normal?

The other replacements are expected.
I think that

sudo pacman -Rdd amtk

should not be a risk, and followed by


will put things back in order.


Yep, that solved it, thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.