Lib32-nvidia-utils not update for the nvidia 555 drivers

Just went to do updates and got informed the 555 nVidia drives would break lib32-nvidia-utils. Looks like it wasn’t updated with the rest of the driver components. This is just a heads up to let the devs know that we need the lib32-nvidiautils updated. I ran packseek to check it and other than a beta for 555 of lib32-nvidia-utils the stable ones are all 550.

I am just reverting beta back to prod, and run full upgrade

That package is updated >

multilib/lib32-nvidia-utils            550.90.07-1               555.58-1                   -6.73 MiB      37.64 MiB
lib32-nvidia-utils-555.58-1-x86_64                       37.6 MiB  9.72 MiB/s 00:04 [------------------------------------------------] 100%

After reboot >


Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3080] vendor: eVga.com. driver: nvidia
v: 555.58 alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current
(as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: DP-3 empty: DP-1,DP-2,HDMI-A-1
bus-ID: 0b:00.0 chip-ID: 10de:2206 class-ID: 0300
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: nvidia gpu: nvidia display-ID: 0
Monitor-1: DP-3 res: 3440x1440 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia
x11: drv: zink inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 555.58
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2
memory: 9.77 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3080 driver: nvidia v: 555.58 device-ID: 10de:2206
surfaces: xcb,xlib,wayland

Regards,
S.

I’m not on the beta, nor is the beta trying to install.

Thats not what I am saying…

I am not on beta now, I was before, reverted back to prod. And I am running now on prod the Drivers 555.58.

pacman -Qn | grep nvidia
garuda-nvidia-config 2:1.1.6-1
lib32-nvidia-utils 555.58-1
lib32-opencl-nvidia 555.58-1
mhwd-nvidia 550.90.07.3-1
mhwd-nvidia-390xx 390.143-1
mhwd-nvidia-470xx 470.94-1
nvidia-dkms 555.58-1
nvidia-settings 555.58-1
nvidia-utils 555.58-1
opencl-nvidia 555.58-1

All is working well.

Regards,
S.

1 Like

I found the culprit. After I install Garuda, I let the setup wizard do it’s thing after landing on the desktop, then i do the reboot after that and check for updates one once back on the desktop. Then I install yay, pikaur, pacseek, archlinkux-tweak-tools, and the CachyOS repos. Once the Cachy repos are installed there are a couple of minor updates then it wants to do a major update I tell it no to and go into pacman.conf and place the Cachy rpos at the bottom then do a update check which normally finds nothing.

Moving the CachyOS repos to the bottom of pacman.conf should have kept them from changing any major files, but looks like they changed out the nVidia driver and associated files.

I went through and have nothing I actually install from the Cachy repos so for now I have commented them out and reran sudo pacman -Sy and then garuda-update, and all looks good.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.