Lenovo W530 NVidia Setup

Yes, Bumblebee was installed, and I have removed it now. No change in the Nvidia behavior.

Then follow post #18

1 Like

I already enabled the kernel parameter back at #19... no change in behavior.

Even with Bumblebee uninstalled, we still get the detected config during mhwd detection:

mhwd -a pci nonfree 0300
> Skipping already installed config 'video-hybrid-intel-nvidia-390xx-dkms-bumblebee' for device: 0000:01:00.0 (0300:10de:0ffc) Display controller nVidia Corporation GK107GLM [Quadro K1000M]
> Skipping already installed config 'video-hybrid-intel-nvidia-390xx-dkms-bumblebee' for device: 0000:00:02.0 (0300:8086:0166) Display controller Intel Corporation 3rd Gen Core processor Graphics Controller

Shouldn't removing Bumblebee have removed this config? If not, could this be the problem?

Did you


It’s tough when you have to ask for every single step.

Yes... I used the Garuda Boot Tool (garuda-boot-options), which runs update-grub under the hood. I've confirmed this in the GRUB options during my last reboot that the new drm parameter was applied to GRUB.

According to garuda-inxi:

  Kernel: 6.1.39-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=3a804b62-baa4-4440-95ba-a34fb1514f90 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    ibt=off nvidia_drm.modeset=1

I thought removing Bumblebee would remove the config, but it seems not. :thinking:

Check in /usr/lib/modprobe.d/ for any config files that are blacklisting Nvidia, and comment out or remove those lines. If there is a bumblebee.conf, you can delete it altogether.

I am not sure where those Bumblebee config files would be stored, but maybe you can search for them. Something like:

sudo find / -name "bumblebee"
1 Like

This seems relevant:

# /etc/modprobe.d/mhwd-nvidia.conf
## Generated by mhwd - Manjaro Hardware Detection
blacklist nouveau
blacklist nvidia
blacklist nvidia-modeset
blacklist nvidia-uvm
blacklist ttm
blacklist drm_kms_helper
blacklist drm

# /usr/lib/modprobe.d/nvidia-470xx-utils.conf
blacklist nouveau

Could some of this be related?

Yes, I think we have identified the problem. :bulb:

Try commenting out or deleting all of those blacklists, except for nouveau. Or delete /etc/modprobe.d/mhwd-nvidia.conf altogether, because the /usr/lib/modprobe.d/nvidia-470xx-utils.conf config also has nouveau in it. Then reboot, and see if the Nvidia card comes up.

OK, so deleting that and rebooting, we now have this in lspci -vv:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1000M] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Lenovo GK107GLM [Quadro K1000M]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 33
	Region 0: Memory at f0000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at d0000000 (64-bit, prefetchable) [size=32M]
	Region 5: I/O ports at 6000 [size=128]
	Expansion ROM at f1080000 [virtual] [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia

So it looks like the kernel module did load up correctly. However, still no provider in xrandr:

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x45 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 3 associated providers: 0 name:Intel

So I think we're still not fully 100% there. If I could just get it accessible enough to work with VULKAN, we'd be good.

Nice, that's progress at least. Check for any lingering configuration files that are messing with xrandr.

Any more Bumblebee files?

ls -lR /etc/bumblebee

Check for other rogue xorg configs:

ls -lR /{usr/share,etc}/X11/xorg.conf*

Yep, a few:

ls -lR /etc/bumblebee
total 8
-rw-r--r-- 1 root root 2911 Jun 21 10:57 bumblebee.conf.pacsave
-rw-r--r-- 1 root root  393 Jun 21 10:57 xorg.conf.nvidia.pacsave
ls -lR /{usr/share,etc}/X11/xorg.conf*
total 16
-rw-r--r-- 1 root root 232 Jun 21 10:32 00-keyboard.conf
-rw-r--r-- 1 root root 362 Jun 21 14:31 10-nvidia-drm-outputclass.conf
-rw-r--r-- 1 root root 240 May  1 13:12 30-touchpad.conf
lrwxrwxrwx 1 root root  26 Jun 21 10:57 90-mhwd.conf -> /etc/X11/mhwd.d/intel.conf

total 20
-rw-r--r-- 1 root root 1099 Nov  7  2021 10-evdev.conf
-rw-r--r-- 1 root root  227 Jul 15 09:09 10-nvidia-drm-outputclass.conf
-rw-r--r-- 1 root root 1350 Jul 10 01:25 10-quirks.conf
-rw-r--r-- 1 root root 1429 Apr  4 11:32 40-libinput.conf
-rw-r--r-- 1 root root 3458 Apr  5 21:48 70-wacom.conf

These .pacsave files are harmless (they have no effect), but you really don’t need this directory anyway–it will be automatically recreated if you decide you want to try Bumblebee in the future for some reason. I would just get rid of it.

sudo rm -rf /etc/bumblebee

I would delete this one too for now, or set it to backup.

sudo mv /etc/X11/xorg.conf.d/90-mhwd.conf /etc/X11/xorg.conf.d/90-mhwd.conf.bak

The two 10-nvidia-drm-outputclass.conf files, my guess is you want those but I do not know; you should open them up and read them to confirm they are not interfering with the configuration you are trying to achieve.

micro /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.