Latte + NetworkManager + Baloo crashing my system

garuda-inxi

System:
Kernel: 5.16.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9352e1a4-8d9b-416d-9ca2-0c7036732513 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX516PM_FX516PM
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FX516PM v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: FX516PM.322 date: 08/27/2021
Battery:
ID-1: BAT0 charge: 32.5 Wh (44.0%) condition: 73.8/76.0 Wh (97.1%)
volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Charging cycles: 33
CPU:
Info: model: 11th Gen Intel Core i7-11370H bits: 64 type: MT MCP
arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0x88
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2617 high: 3426 min/max: 400/4800 scaling:
driver: intel_pstate governor: performance cores: 1: 2533 2: 3072 3: 3062
4: 2560 5: 1272 6: 3426 7: 3277 8: 1736 bogomips: 52838
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel,modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 144 dpi: 143
size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Sound Server-1: ALSA v: k5.16.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 2e:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno2 state: down mac: <filter>
IF-ID-1: enp0s20f0u4 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:3 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Device-2: Samsung GT-I9070 (network tethering USB debugging enabled)
type: USB driver: rndis_host v: kernel bus-ID: 3-4:2 chip-ID: 04e8:6864
class-ID: 0a00 serial: <filter>
Drives:
Local Storage: total: 715.41 GiB used: 57.08 GiB (8.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: M Series NVMe SSD 256G
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V2.18.0
temp: 45.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung
model: MZVLQ512HBLU-00B00 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: FXM7201Q temp: 38.9 C scheme: GPT
Partition:
ID-1: / raw-size: 91 GiB size: 91 GiB (100.00%) used: 57.08 GiB (62.7%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 563 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 91 GiB size: 91 GiB (100.00%)
used: 57.08 GiB (62.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 91 GiB size: 91 GiB (100.00%)
used: 57.08 GiB (62.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 91 GiB size: 91 GiB (100.00%)
used: 57.08 GiB (62.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.32 GiB used: 4.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 59.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2600
Info:
Processes: 350 Uptime: 9m wakeups: 1097 Memory: 15.32 GiB
used: 3.97 GiB (25.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: note: see --pkg pacman: 2156 lib: 397
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2021-10-15
Last full system update: 2022-02-08
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

When logging into Garuda, baloo_file produced a segmentation fault. My toolbar + tray (Latte) were not present despite htop reporting it was running, and my networks were messed up (no internet and stuck at Waiting for authorisation) despite NetworkManager in systemctl looking normal.

I tried restoring an earlier snapshot that was perfectly fine, nothing resolved. I tried a system update, no luck. I also tried resetting Latte and other configs, I tried reinstalling baloo and reinstalling all system packages. Nothing.

Complete fresh install is a last resort. There is a lot on this OS that would take many hours to get back.

:slight_smile:

Did you search in forum?
There are solutions for Baloo, NetworkManager and Latte.
One part of your problem could be the dual boot which break your NetworkManager, but it's not official supported by Garuda-Team.

BTW, I run KDE without problems with and without M$ :slight_smile:

1 Like

I tried looking all over the internet for anything that could be causing this. I found that people suggested removing some baloo related files and indexes like baloorc and baloofileinformationrc which I did - this seemed to fix baloo giving a segfault, however didn't fix anything else.

I also can't tell whether each problem is related or not, it is strange.

Edit: thank you for the welcome <3

Disable Baloo in the KDE system settings app temporarily.

Disable latte dock from autostarting and start it manually from the terminal. Post any errors when latte is started from the terminal.

Please open a separate request in the "Networking support" sub-forum for wifi assistance.

2 Likes

I disabled Baloo already to see if that made a difference, and I also did try manually starting latte-dock from the terminal manually - there are no errors that pop up at all. I'll try disabling it from autostarting and see if it makes a difference.

If you supply full background information then far less time is wasted covering the same ground twice on the forum. Just sayin, thoroughness in your Opening Post (OP) is appreciated by assistants on the forum.

I'm not really sure what other "full background information" was really relevant, this issue seems out of the blue and I am not really sure what is helpful and what isn't, this issue seems way out of my depth

I'm simply referring to listing all steps you have already tried in your OP as this saves on wasted time and effort duplicating steps you've already tested.

Let's move on.

Fixed the issue by doing a complete reinstall. I figured out the Latte crashing issue: switching your Java default version from java-8-openjdk/jre to java-17-openjdk via archlinux-java will stop Latte from loading upon logging in. Not sure about baloo and NetworkManager though.

1 Like

The advantage of a rolling distro is your install can last you many years. Reinstalling teaches you nothing about troubleshooting or maintaining your system properly.

This is really not what I would call a solution. This is akin to putting in a brand new engine in your car when all it needed was a new air & fuel filter and new spark plugs.

2 Likes

Whatever analogy you assign to it, I didn't really have the time spare to diagnose and fix the issue properly. If I had the time, and things weren't so urgent, then I would've actually gone through the entire process. Completely reinstall was a guaranteed and much faster way to fix things.

Faster, yes.
Guaranteed, not at all.

Any breakage could easily recur if it was a result of a newer buggy package version. I've seen it countless times on the forum where people complain "I reinstalled 5 times and my system is still broken". :sob:

It's your system do as you please. :man_shrugging:

Glad it's working now.

1 Like

Same issues on my laptop, i mean a lot of people's are complaining about this problem, glad that you're successfully figured out, i'll try on my own system.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.