Latte Dock Issue - RESOLVED

I have a strange issue that I'm not quite sure how to describe, but here goes:

With Latte Dock running (centered on the bottom of the screen), the bottom 1/3 of my screen is unusable. By that I mean that I can resize windows by dragging the bottom of the window, I can't click on anything in any app within the bottom 1/3 of the screen.

Any ideas on how to troubleshoot this issue?

Please provide your garuda-inxi as per new topic template.
At first glance I would think of a problem with the compositor.

2 Likes

garuda-inxi

System:
Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2022-02-22_11-33-35/@/boot/vmlinuz-linux-zen
root=UUID=ecab03e1-a558-41c4-9a5d-c968be69fb64 rw
rootflags=subvol=timeshift-btrfs/snapshots/2022-02-22_11-33-35/@ quiet
cryptdevice=UUID=aafdf48b-7261-469c-8910-7f87d7aec02d:luks-aafdf48b-7261-469c-8910-7f87d7aec02d
root=/dev/mapper/luks-aafdf48b-7261-469c-8910-7f87d7aec02d splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-79407f78-876d-4460-8848-f2923cf77026 loglevel=3
Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Micro product: G510 v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: PRIME B550M-A AC v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2006
date: 03/19/2021
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3709 high: 4637 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3643 2: 3595
3: 3590 4: 3589 5: 3693 6: 3578 7: 3592 8: 3615 9: 3804 10: 4637 11: 3587
12: 3589 bogomips: 88632
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] vendor: Tul
driver: amdgpu v: kernel bus-ID: 0d:00.0 chip-ID: 1002:73df class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
s-diag: 777mm (30.6")
Monitor-1: DisplayPort-2 res: 2560x1440 hz: 165 dpi: 93
size: 697x392mm (27.4x15.4") diag: 800mm (31.5")
OpenGL: renderer: AMD Radeon RX 6700 XT (NAVY_FLOUNDER DRM 3.44.0
5.16.10-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.6 direct render: Yes
Audio:
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel v: kernel bus-ID: 0d:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0f:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.20 running: no
Sound Server-4: PulseAudio v: 15.0 running: yes
Sound Server-5: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: ASUSTeK driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: e000
bus-ID: 09:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlp9s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: d000
bus-ID: 0a:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp10s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: ASUSTek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-5:5 chip-ID: 0b05:18ea class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 429.19 GiB (46.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 211210WD temp: 33.9 C scheme: GPT
Partition:
ID-1: / raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.18 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 706 KiB (0.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.18 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
ID-4: /var/log raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.18 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
ID-5: /var/tmp raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.18 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.32 GiB used: 2.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.39 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-79407f78-876d-4460-8848-f2923cf77026
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 52.0 C
mem: 40.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 381 Uptime: 36m wakeups: 0 Memory: 31.32 GiB
used: 6.06 GiB (19.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1989 pacman: 1979 lib: 565 flatpak: 10
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.5-1):
System install date:     2021-11-04
Last full system update: 2022-02-23
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift
Failed units:            anbox-container-manager.service systemd-networkd-wait-online.service

I edited your garuda-inxi for proper formatting. Give a look :wink:, also here:

2 Likes

Careful, you're booted off a snapshot, so you should open the btrfs assistant (or timeshift application, I'm currently with snapper), locate that snapshot and restore it, then reboot.

2 Likes

Good catch. I'll do that right now.

Let's try this again.

garuda-inxi

System:
Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ecab03e1-a558-41c4-9a5d-c968be69fb64 rw [email protected]
quiet
cryptdevice=UUID=aafdf48b-7261-469c-8910-7f87d7aec02d:luks-aafdf48b-7261-469c-8910-7f87d7aec02d
root=/dev/mapper/luks-aafdf48b-7261-469c-8910-7f87d7aec02d splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-79407f78-876d-4460-8848-f2923cf77026 loglevel=3
Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Micro product: G510 v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: PRIME B550M-A AC v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2006
date: 03/19/2021
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3888 high: 4543 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4026 2: 3683
3: 3844 4: 3666 5: 3645 6: 4543 7: 3711 8: 3708 9: 4098 10: 4063 11: 3711
12: 3965 bogomips: 88628
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] vendor: Tul
driver: amdgpu v: kernel bus-ID: 0d:00.0 chip-ID: 1002:73df class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
s-diag: 777mm (30.6")
Monitor-1: DisplayPort-2 res: 2560x1440 hz: 165 dpi: 93
size: 697x392mm (27.4x15.4") diag: 800mm (31.5")
OpenGL: renderer: AMD Radeon RX 6700 XT (NAVY_FLOUNDER DRM 3.44.0
5.16.10-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.6 direct render: Yes
Audio:
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel v: kernel bus-ID: 0d:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0f:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.20 running: no
Sound Server-4: PulseAudio v: 15.0 running: yes
Sound Server-5: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: ASUSTeK driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: e000
bus-ID: 09:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlp9s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: d000
bus-ID: 0a:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp10s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: ASUSTek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-5:5 chip-ID: 0b05:18ea class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 429.21 GiB (46.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 211210WD temp: 34.9 C scheme: GPT
Partition:
ID-1: / raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.21 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 706 KiB (0.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.21 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
ID-4: /var/log raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.21 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
ID-5: /var/tmp raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
used: 429.21 GiB (47.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-aafdf48b-7261-469c-8910-7f87d7aec02d
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.32 GiB used: 2.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.39 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-79407f78-876d-4460-8848-f2923cf77026
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 58.0 C
mem: 46.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 398 Uptime: 1m wakeups: 0 Memory: 31.32 GiB
used: 5.36 GiB (17.1%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 2008 pacman: 1998 lib: 567 flatpak: 10
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.5-1):
System install date:     2021-11-04
Last full system update: 2022-02-22
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift (maybe)
Failed units:            anbox-container-manager.service

Resolved.

Restoring the snapshot fixed the issue.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.