Latte-Dock drawing menu twice in different locations

If you look at the top of the screenshot you can see the menu for "Kate" drawn twice in the top panel. This issue can also be seen in this post. That solution didn't work for me.

What you see is the application menu drawn and "live" where it belongs. Then behind it, it is drawn again, starting from the left side of the screen. It is just pixels, and moving the mouse over them does not highlight them or open a menu.

This only happens after interaction with a widget on the top panel. In other words, if I launch applications from a terminal, and cycle through them, their menus are displayed perfectly. However, if I interact with one of the widgets on the right, the "overlay" problem starts.

I can kill Latte-Dock and restart it and it will be fine again until I interact with any of the widgets.

Now this is interesting and may be related to what the other person posted about this problem. He said that he had the problem when the edit pannel->appearance->background->size was set to 0. If I set it at 30% for example, then the issue happens whether or not I interact with the top panel. In other words, if I kill and restart Latte-Dock, the menus of open programs are immediately drawn twice as is in the picture. However, when size is set to 100%, menus are drawn properly UNTIL I interact with the dock. Then the menus are drawn improperly as shown in the picture. It's as if touching the area reduces the size to something less than 100 and the issue shows itself. Just a guess.

If there is something I can check or more information I can provide, please tell me how to get that information. I'm new to Arch, and new to KDE so I don't know much about this environment. It sure is pretty though!!! Any help is greatly apprecitated. Thanks.

Hi TechTalk,
Welcome to the forum!

Right Click on Panel
--> Layouts

Maybe you have both Garuda and Dr460nized Layout Checked :white_check_mark:
Uncheck :blue_square: one of them


Also Check:
Right Click on the title (next to the dragon icon)
Configure Window Title
Text Style: ... <-- This should be Application


Thank you. I checked the settings and they are correct, however as a result of your suggestions I toggled the layout between Default and Dr460nized, then killed Latte-Dock and noticed there was still a panel there. So I closed that second panel went back to Dr460nised and all is well. I guess I must have somehow turned on that second panel.

I had heard that you can get lost in KDE's settings and after 2 years in Gnome I'm a little disoriented. So your suggestions are really appreciated. Thanks again.


If you believe that you have two identical panels at top edge that look exactly the same, this can happen for example if you you duplicate the top panel and after its creation you move the newly created at the top edge.

You can move one of them at the left edge and remove it as long as you are still watching the top one panel in its correct place.


Thanks. I'm not sure what I did. I was modifying the date, accidentally deleted the dock at the bottom of the screen, went out to the source to get the config file for Latte-Dock to put it back etc.... Like I said, I'm new to KDE and have a lot to learn.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.