Latte Dock broken after upgraded to v0.10 [SOLVED]

After the Latest upgrade of Garuda KDE dr460nized the Dock has move under the top bar and ins settings it set as Bottom. The main problem is that it moves widgets also and created a blur area about the one third of the screen height that anything behind it can't be moved . When kill the latte-dock all works the same. This has occurs to me more than 6 months ago but i installed the community version and the problem hasn't appeared again , until the last upgrade that installed the latest 0.10.x version of Latte-dock

I have tried back-up my Settings and remove everything even copy the settings from my second pc but nothing. Any suggestion/solution for this?


d

I have try installing another dock app the ksmoothdock and it has the same problem instead of bottom moved to top and blurred the screen and became (the PC) inoperative able ... i loaded previously snapshot before the upgrade and worked as it should ... so the problem isn't just Latte Dock related but some drivers or Monitor issue? can't understand exactly... I would love some advice ... :slight_smile:

By a suggestion in another topic i use the "downgrade" command and switch to .9.12 and now it works as it should...

for anyone have similar issue the command is:

sudo downgrade latte-dock and select the version 0.9.12

also needed to downgrade gtk3

sudo downgrade gtk3 to version 3.24.28-4

You seem to be using the stable version of latte dock while Garuda ships 0.9.91.r147.gf7032f7f-1 - it's possible that the provided config is incompatible? Please install latte-dock-git and use the default configuration provided to see if that changes anything.
I'm really curious why downgrading GTK3 "solves" the issue - latte dock is not even having this in dependencies.
Now I'm also wondering why the git version is appearently on the latest commit of the master branch while it's name still says 0.9.91 :eyes:
@psifidotos are there any breaking changes in latte-dock 0.10?

1 Like

Latte About reports v. 10.75 though (not synced yet...) with the git version. 10 is an internal naming. Git pulls in version with calculation

 printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

I think also the git PKGBUILD should not have both param and function declared, but I don't know how these work exactly.

If not placebo, it's really a mystery... :exploding_head:

2 Likes

latte master branch is in version - 0.10.75 (CMakeLists.txt · master · Plasma / Latte Dock · GitLab)

latte stable branch is in version - 0.10.0 (CMakeLists.txt · v0.10 · Plasma / Latte Dock · GitLab)

both master and stable versions are currently identical, there is no difference between them. Only new features will be added in master branch but this is no scheduled any time soon.

3 Likes

one more detail. the package named 0.9.91 is not correct naming. What is happening is the following, that package checks the last tag found in master branch which is 0.9.91 and names the package accordingly. The thing is that master branch is in version 0.10.75 but I can not make a manual tag for it, only way is to create a new release for master branch which is something I dont want to make yet. So the real versioning of master branch is 0.10.75 and not 0.9.91. You can check this out by doing latte-dock -v

2 Likes

I suppose you are using wayland. but it should be ok if your latte version is up to date meaning at least v0.10 . Except that you can try to open a bug report with full details, way to reproduce etc.... Such issue was fixed two months ago if I remember correctly.

@dr460nf1r3 what is the latest commit from master branch provided for Garuda?

2 Likes

Because it uses master (using AUR latte-dock-git, auto-built) my latest version reads

0.9.91.r147.gf7032f7f-1

$ latte-dock -v
lattedock 0.10.75

Updated half hour ago...

2 Likes

Thanks for the explanation, it makes sense now!
Interestingly enough, the most recent build is now labeled version latte-dock-git-0.10.0.r25.gdf9117d0-1 :smiley:

2 Likes

that should make it stable branch I think. The letter on the end gdf9117d0 and gf7032f7f no idea where AUR is finding them. They both do not exist as commits in Latte.

2 Likes

I just remembered we had an interfere (in build tools of Chaotic-AUR) put in place to get actual version numbers which is as follows:

pkgver() {
  cd "latte-dock"
  git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}

I sadly can't replicate this bug btw, on latest versions with Garudas default Latte layout..

λ pacman -Qs latte-dock-git
local/latte-dock-git 0.10.0.r25.gdf9117d0-1
λ pacman -Qs gtk3
local/gtk3 1:3.24.30-2
GObject-based multi-platform GUI toolkit
1 Like

The bug is only wayland related but I can not reproduce it.

2 Likes

The original version was like that 6 months ago and couldn't fix it (the bottom dock has moved to the top) the only solution was to install the "Official" but with the v0.10 it is broken as well

Have you used the Latte Configuration options?
You can examine all problems there and use clean layouts.

I suggest

  • Exit/close Latte (right-click Latte-dock)
  • backup and delete (or rename) .config latte folder and latterc
  • Start Latte-dock (Alt+F2 and write latte)
  • Create a new layout from an existing template.

Do you have or ever had more than a monitor attached?
Did you switch video drivers at some time (nouveau to nvidia, or other)?

2 Likes

I have rename the folder in .config so it create new and the "Default" it was loaded was broken i don't understand the issue with it , when i'm installing the "community" version the problem is fixed.... I will try again with the .config still renamed cause i'm not sure if i did that with the chaotic-aur version and i will reply here again , thanks for your time...

Ok i tried the latte-dock-git chaotic-aur version and i installed it after i rename the latte folder on .config and the same think happened just loaded the "Default" layout but the dock was overlapping the top panel... but i check in your instruction you write about a folder latterc where is located?

Link please.

IIRC there is only MATE as community DE.

I'm assuming they're referring to community/latte-dock 0.10.0-1

2 Likes

yes this is the one that works but until version 0.9.12 , when upgraded to v 0.10 the problem is the same as with the chaotic-aur version as in the screenshot above i needed to downgrade to v0.9.12 to make it work.