Latte-dock breaking everything


Latte-dock is always crashing and never works since updating about last week.

I've tried downgrading/switching back and forth between latte-dock-git and latte-dock

Nothing seems to work except using timeshift to go back to a working state (which I don't like to do because it messes up my containerization with docker and minikube)

when I run latte-dock --replace -d I get one output that's concerning

[Critical : 23:06:35.161161] - "Couldn't find QML Decoration \"\""

Also lots of these issues

[Warning : 23:09:07.605605] - "QXcbConnection: XCB error: 9 (BadDrawable), sequence: 12546, resource id: 77594999, major code: 72 (PutImage), minor code: 0"

clicking the digital clock causes the system to freeze and I've tried everything....

My suspicion is that there's some compatibility issue with other software because nothing I've done fixes anything...

Please help. Thank you so much for taking the time to read this.

inxi -Faz

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=892538cb-605a-42b7-a33c-9c0a0b320d67
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Laptop System: Dell product: XPS 13 9310 v: N/A serial: <filter> Chassis: type: 10
serial: <filter>
Mobo: Dell model: 0DXP1F v: A00 serial: <filter> UEFI: Dell v: 1.1.4 date: 11/23/2020
Battery:   ID-1: BAT0 charge: 41.4 Wh (100.0%) condition: 41.4/51.0 Wh (81.2%) volts: 8.4 min: 7.6
model: BYD DELL FP86V0A type: Li-poly serial: <filter> status: Full
CPU:       Info: Quad Core model: 11th Gen Intel Core i7-1185G7 bits: 64 type: MT MCP arch: Tiger Lake
family: 6 model-id: 8C (140) stepping: 1 microcode: 88 cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 47923
Speed: 4800 MHz min/max: 400/4800 MHz Core speeds (MHz): 1: 4800 2: 4800 3: 4458 4: 4788
5: 4806 6: 4807 7: 4809 8: 4801
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 3-6:3
chip-ID: 0c45:672a class-ID: 0e02
Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2130 s-dpi: 96 s-size: 1014x562mm (39.9x22.1") s-diag: 1159mm (45.6")
Monitor-1: eDP1 res: 1680x1050 hz: 60 dpi: 147 size: 290x180mm (11.4x7.1") diag: 341mm (13.4")
Monitor-2: DP1-1 res: 1920x1080 hz: 60 dpi: 92 size: 530x300mm (20.9x11.8") diag: 609mm (24")
Monitor-3: DP1-2 res: 1920x1080 hz: 60 dpi: 92 size: 530x300mm (20.9x11.8") diag: 609mm (24")
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8
class-ID: 0401
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: yes
Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
IF-ID-1: br-4a6470fd6bd3 state: down mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 150.29 GiB (31.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730 NVMe WDC 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 11121012 temp: 47.9 C scheme: GPT
Partition: ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 150.29 GiB (31.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 572 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 150.29 GiB (31.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 150.29 GiB (31.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 150.29 GiB (31.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.36 GiB used: 22.5 MiB (0.1%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A
Fan Speeds (RPM): cpu: 4686 fan-2: 4403
Info:      Processes: 279 Uptime: 13m wakeups: 4 Memory: 15.36 GiB used: 2.77 GiB (18.0%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1782 lib: 356
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.08

I also lost the old garuda layout with the eagle icon as the window launcher. I miss it. I loved that one, but I deleted the layout trying to fix this issue.

Any idea how to get it back?

I tried also removing "Problematic applets" from another post (the time applet from above) and when I go to edit dock, it looks like this:

Processing: broken latte.png...

Have you already tried with delay autostart and the configuration hints like here. (but there are several topics mentioning this)?

To recover the initial latte layout you can use the Garuda assistant, flag latte and push button to reset to default settings

1 Like

Run latte with default layout, you probably have an applet that is out of date.

latte-dock -d --default-layout


I tried that. That did not fix my issue.

If you get crashes with Latte default layout then your issue is probably something else and not Latte. I can give you a hint only if I see the crash report.


Could it just be a kde issue in general? One of the applications that's on the default dock that's broken or causes issues is the analog clock.

I think you're right about it not being a latte issue. It's just that latte was where it was most apparent, but even when I have latte completely disabled, I'm running it to slow system issues.... not sure why or even where to check.

Where might I find this crash report you're talking about?

Hi. Since the lattest updates, I was experiencing similar problems in my quite new LG Gram laptop and it seems that I have found a solution (finally), by changing the linux kernel to the LTS version (Long Term Support).

If you want to try, go to Garuda Settings Manager > Kernel, scroll to linux-lts and click Install. Once installed, reboot and in the starting menu (grub menu) choose Garuda Advanced Options and there choose the LTS Kernel. I do not know how to make that change permanent, as I am just a lowly newbie, so if it works for you as it does for me, by the moment you will have to choose the LTS kernel each time you boot. Cheers.


I'm going to try, but I think my libinput stuff was messed up on mainline linux. I can probably configure it to make it work though. We'll see.

OMG this actually worked... LTS is working like a charm. I'm not sure what exactly turned me off from switching kernels before, but I'll definitely keep that round in mind for future occurrences. Thanks for all the support and suggestions from everybody.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.