Latte-dock and latte-dock-git are in conflic can't update

I only have latte-dock-git installed, however, when I try to update my packages, I am being told that:
latte-dock and latte-dock-git are in conflict. Remove latte-dock-git? [y/N]

When I say no, the update procedure is aborted, which makes sense, if I did have both installed. I have checked, and I don't have latte-dock installed.

Has Garuda switched over from git or what? The git version seems to be way ahead of the non-git version, would be nice if I could stay.

1 Like

I was adding a new functionality to Latte dock (thanks @psifidotos ! - the Latte top bar will now be colored in the same color as the window touching it which enhances immersion a lot) which requires a Kwin script - this package appearently demands for the non-git version of Latte:

λ sudo pacman -S kwin-scripts-window-colors
resolving dependencies...
looking for conflicting packages...
:: latte-dock and latte-dock-git are in conflict. Remove latte-dock-git? [y/N]

I have removed that dependency and will ship the script in the settings package instead which means you can update again.

10 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.