Laptop won't turn on if charger is unplugged

Hello! After I updated my operating system(Garuda Linux Dragonized) if I unplug my laptop charger and I power on my laptop, after the loading bar is half, the screen is turning black and is blinking. If I set in optimus manager Startup mode to Hybrid or Integrated it will start, but it will be very laggy. I don't have auto-cpufreq or other powersave tweaks.

System:    Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0ac31f06-34e0-40f3-84f5-926dfafc21fe
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505DU_FX505DU v: 1.0 serial: <filter>
Mobo: ASUSTeK model: FX505DU v: 1.0 serial: <filter> UEFI-[Legacy]: American Megatrends
v: FX505DU.316 date: 01/28/2021
Battery:   ID-1: BAT0 charge: 32.1 Wh (91.5%) condition: 35.1/48.1 Wh (73.1%) volts: 12.7 min: 11.7
model: FX50442 type: Li-ion serial: N/A status: Charging
CPU:       Info: Quad Core model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
arch: Zen family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102 cache: L2: 2 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 36727
Speed: 2555 MHz min/max: 1400/2300 MHz boost: enabled Core speeds (MHz): 1: 2555 2: 2609
3: 1805 4: 2637 5: 3179 6: 2943 7: 1177 8: 1245
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191 class-ID: 0300
Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 5-1:2
chip-ID: 13d3:56e5 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1-1 res: 1920x1080 hz: 120 dpi: 142 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44
direct render: Yes
Audio:     Device-1: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: d000 bus-ID: 04:00.0 chip-ID: 10ec:c822
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-4:2
chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.38 TiB used: 52.18 GiB (3.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 002C temp: 36.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: SDM1 scheme: GPT
Partition: ID-1: / raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 32.81 GiB (6.9%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 32.81 GiB (6.9%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 32.81 GiB (6.9%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 32.81 GiB (6.9%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 86.4 C mobo: N/A
Fan Speeds (RPM): cpu: 4500
GPU: device: nvidia screen: :0.0 temp: 56 C device: amdgpu temp: 86.0 C
Info:      Processes: 358 Uptime: 42m wakeups: 1 Memory: 15.06 GiB used: 5.45 GiB (36.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1428 lib: 349
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Did you install TLP?

It is sometimes known for causing these kind of problems.

2 Likes

I didn't installed TLP. If I restore my os to Spotted-Eagle it is working without problems.

Install the linux-lts kernel and boot into it. Then try another system update, if it breaks again you'll have to roll the system back again

It could be a long process of elimination to determine which update is causing your issues. Be sure to save and post a list of the packages that are updated.

1 Like

I've changed my kernel to linux-ltx and I updated the system and now it works.

This are the packages that were changed:

Packages (27) cht.sh-git-r872.2463185-1  clang-13.0.0-2  compiler-rt-13.0.0-1
intel-compute-runtime-21.44.21506-2  intel-graphics-compiler-1:1.0.8744-4
intel-opencl-clang-13.0.0-1  lib32-clang-13.0.0-1  lib32-libva-mesa-driver-21.2.5-1
lib32-llvm-libs-13.0.0-1  lib32-mesa-21.2.5-1  lib32-mesa-vdpau-21.2.5-1
lib32-opencl-mesa-21.2.5-1  lib32-vulkan-intel-21.2.5-1  lib32-vulkan-mesa-layers-21.2.5-1
lib32-vulkan-radeon-21.2.5-1  libclc-13.0.0-1  libva-mesa-driver-21.2.5-1  llvm-libs-13.0.0-3
mesa-21.2.5-1  mesa-vdpau-21.2.5-1  opencl-mesa-21.2.5-1  qt5-tools-5.15.2+kde+r17-4
spirv-llvm-translator-13.0.0-1  vulkan-intel-21.2.5-1  vulkan-mesa-layers-21.2.5-1
vulkan-radeon-21.2.5-1  vulkan-swrast-21.2.5-1
1 Like

Glad to hear that worked for you, and welcome to the Garuda forum BTW. :grinning_face_with_smiling_eyes:

1 Like