Laptop not using NVIDIA GPU, stuck on llvmpipe

I just got a new Laptop (Lenovo LOQ I5IRH8). Everything except for the dGPU seems to be working out of the box. I seem to be stuck using the Intel integrated graphics. I’ve been using Garuda with an AMD GPU for a while, but this is my first experience with NVIDIA on Linux.

I ran the Garuda Setup Assistant and it didn’t do anything to help. I’m up to date and have restarted multiple times.

I’ve already tried installing the nvidia drivers manually from the repos. Since doing that, it seems to kind of be using the GPU, as it’s getting hotter and turning on the fans, but I’m actually getting worse performance in games. (Minecraft went from ~45 FPS with iGPU, to ~15 FPS with the NVIDIA drivers installed. )

After installing the drivers, my brightness keys no longer work.

If I look under the about section in KDE settings, I see that the graphics processor is llvmpipe. I also set the UEFI settings to only use the dGPU.

Any ideas what I can do to solve this?

System:
Kernel: 6.6.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pmHello Garuda users. 

Please read the following template before requesting assistancHello Garuda users. 

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:e:

Please post the terminal/konsole input and output as text (no pictures) from the following command:
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=295cb0e5-646b-4f62-be41-46c327e38c7a rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 82XV v: LOQ 15IRH8
serial: <superuser required> Chassis: type: 10 v: LOQ 15IRH8
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0T76463 WIN
serial: <superuser required> UEFI: LENOVO v: LZCN31WW date: 07/19/2023
Battery:
ID-1: BAT1 charge: 20.6 Wh (33.2%) condition: 62.1/60.0 Wh (103.6%)
power: 52.7 W volts: 14.7 min: 15.4 model: COSMX L22X4PA0 type: Li-poly
serial: <filter> status: discharging cycles: 2
CPU:
Info: model: 13th Gen Intel Core i5-13420H bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
microcode: 0x411C
Topology: cpus: 1x cores: 8 mt: 4 tpc: 2 st: 4 threads: 12 smt: enabled
cache: L1: 704 KiB desc: d-4x32 KiB, 4x48 KiB; i-4x32 KiB, 4x64 KiB
L2: 7 MiB desc: 4x1.2 MiB, 1x2 MiB L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 400 min/max: 400/4600:3400 scaling: driver: intel_pstate
governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400
8: 400 9: 400 10: 400 11: 400 12: 400 bogomips: 62668
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA107 [GeForce RTX 2050] vendor: Lenovo driver: N/A
alternate: nouveau non-free: 545.xx+ status: current (as of 2023-10;
EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:25ed class-ID: 0300
Device-2: Luxvisions Innotech Integrated Camera driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:2 chip-ID: 30c9:00a7
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: Unknown-1 mapped: None-1 res: 1920x1080 hz: 60 size: N/A
modes: 1920x1080
API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: swrast x11: drv: swrast inactive: wayland
API: OpenGL v: 4.5 vendor: mesa v: 23.2.1-arch1.2 glx-v: 1.4
direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
device-ID: ffffffff:ffffffff memory: 15.05 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 10 device: 0 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:51ca class-ID: 0401
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:2291 class-ID: 0403
API: ALSA v: k6.6.4-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f1 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Drives:
Local Storage: total: 476.94 GiB used: 20 GiB (4.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: MTFDKCD512QFM-1BD1AABLA size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 1001V3LN temp: 45.9 C scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 19.99 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 8.6 MiB (2.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 19.99 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 19.99 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 19.99 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.41 GiB used: 768 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 344 Uptime: 7m wakeups: 0 Memory: total: 16 GiB
available: 15.41 GiB used: 2.83 GiB (18.3%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1881 libs: 557 tools: octopi,pamac,paru Shell: fish
v: 3.6.2 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-12-07
Last full system update: 2023-12-07 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Turns out, my troubleshooting has also broken suspend/resume. It worked fine before I went messing with the drivers.

Looks like the Nvidia driver is not loaded.
Go to Garuda Welcome-> Garuda Settings Manager → Hardware Configuration .
Then click on “Auto Install Propriety Driver”. After following any additional prompts, try restarting to see if the drivers are properly working . (one way to check is going back to the same Configuration window to make sure the video-nvidia-dkms drivers are installed in the second column checkbox)

1 Like

I only seem to have an option to auto install open source drivers.

Try running

sudo pacman -S nvidia-dkms

In terminal to install the drivers if the button is missing.
(this solution seemed to help others with Nvidia “Unknown devices” listed in the Hardware Configuration Button to install NVIDIA proprietary drivers missing - #5 by filo )

7 Likes

That fixed the issue. Thanks for the help!

After rebooting I have brightness controls back and I’m getting ~118 FPS in Minecraft.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.