Laptop generating excess noise

I'm having quite a strange issue: my hard drive is making much more noise when I'm using Garuda than with Manjaro (my previous distro) or Windows. I can hear it with the other OS's as well if I listen closely, but with Garuda it sounds a whole level louder.
I think it's my hard drive, because it sounds very similar to this video. It's quite irregular when I'm using the laptop, but it has also been repetitive a few times when I was not doing anything (for example at the login screen).

Since these noises only occur on Garuda and my hard drive health stats (added below) seem to be alright, I don't think it's close to failing. This also makes me wonder if replacing it would even help. I really hope I can fix the issue, because the noise is annoying me a lot.

What makes the issue stranger is that both my Linux installations are on an SSD. Windows is on the HDD together with a Linux swap partition (used by both Manjaro and Garuda) and a shared data partition. Please let me know if there's a command I can run to show my disk layout if it would help.

Things I've tried so far:

  • Running S.M.A.R.T. tests. No errors found.
  • Running tests from the built-in test suite (before booting any OS). I only hear the noise softly (like with Windows and Manjaro) during the hard drive tests.
  • Unmounting all HDD partitions. Sounds did not stop.
  • Changing acoustics with hdparm, but the drive doesn't support it.
  • Using the LTS kernel (same version as Manjaro). Sounds did not stop.
garuda-inxi
System:
Kernel: 5.18.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=220d401c-e739-49f7-b37b-c9837e340ce5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 pci=noaer ibt=off
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Pavilion Gaming Notebook
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 816B v: 91.1E serial: <superuser required> UEFI: Insyde
v: F.91 date: 08/20/2019
Battery:
ID-1: BAT0 charge: 13.7 Wh (49.8%) condition: 27.5/27.5 Wh (100.0%)
volts: 14.1 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: discharging
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S
gen: core 6 built: 2015 process: Intel 14nm family: 6 model-id: 0x5E (94)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 3259 high: 3324 min/max: 800/3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 3244 2: 3227 3: 3232
4: 3252 5: 3212 6: 3324 7: 3268 8: 3314 bogomips: 41599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:191b class-ID: 0300
Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Hewlett-Packard
driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Maxwell process: TSMC 28nm
built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:139a class-ID: 0302
Device-3: Intel RealSense 3D Camera (Front F200) type: USB
driver: uvcvideo bus-ID: 2-3:2 chip-ID: 8086:0a66 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Samsung 0x5844 built: 2015 res: 1920x1080
dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 22.1.2
direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
chip-ID: 8086:a170 class-ID: 0403
Sound Server-1: ALSA v: k5.18.6-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 08:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 09:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: eno1 state: down mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-7:3 chip-ID: 0bda:b006 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 5 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.03 TiB used: 859.05 GiB (81.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNLF128HCHP-000H1
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1H1Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 2C scheme: GPT
Partition:
ID-1: / raw-size: 55.99 GiB size: 55.99 GiB (100.00%)
used: 41.16 GiB (73.5%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 81.6 MiB (31.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 55.99 GiB size: 55.99 GiB (100.00%)
used: 41.16 GiB (73.5%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 55.99 GiB size: 55.99 GiB (100.00%)
used: 41.16 GiB (73.5%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 55.99 GiB size: 55.99 GiB (100.00%)
used: 41.16 GiB (73.5%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 276 KiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4.88 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb5 maj-min: 8:21
Sensors:
System Temperatures: cpu: 58.0 C pch: 46.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 284 Uptime: 5h 22m wakeups: 99 Memory: 15.47 GiB
used: 5.63 GiB (36.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1575 lib: 375
Shell: fish v: 3.4.1 running-in: konsole inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-04-24
Last full system update: 2022-06-24 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            anbox-container-manager.service systemd-networkd-wait-online.service 
smartctl -a /dev/sdb

smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.18.6-zen1-1-zen] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family: Toshiba 2.5" HDD MQ01ABD...
Device Model: TOSHIBA MQ01ABD100
Serial Number:
LU WWN Device Id:
Firmware Version: AX1R2C
User Capacity: 1.000.204.886.016 bytes [1,00 TB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: 5400 rpm
Form Factor: 2.5 inches
Device is: In smartctl database 7.3/5319
ATA Version is: ATA8-ACS (minor revision not indicated)
SATA Version is: SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is: Fri Jun 24 22:21:54 2022 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x02) Offline data collection activity
was completed without error.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: ( 120) seconds.
Offline data collection
capabilities: (0x51) SMART execute Offline immediate.
No Auto Offline data collection support.
Suspend Offline collection upon new
command.
No Offline surface scan supported.
Self-test supported.
No Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 200) minutes.
SCT capabilities: (0x003d) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 100 100 050 Pre-fail Always - 0
2 Throughput_Performance 0x0027 100 100 050 Pre-fail Always - 0
3 Spin_Up_Time 0x0023 100 100 002 Pre-fail Always - 1806
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 8525
5 Reallocated_Sector_Ct 0x0033 100 100 010 Pre-fail Always - 0
7 Seek_Error_Rate 0x002f 100 100 050 Pre-fail Always - 0
8 Seek_Time_Performance 0x0025 100 100 050 Pre-fail Offline - 0
9 Power_On_Hours 0x0032 068 068 000 Old_age Always - 12986
10 Spin_Retry_Count 0x0033 253 100 030 Pre-fail Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 7957
183 Runtime_Bad_Block 0x0032 100 100 001 Old_age Always - 12
184 End-to-End_Error 0x0033 100 100 097 Pre-fail Always - 0
185 Unknown_Attribute 0x0032 100 100 001 Old_age Always - 65535
187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 0
188 Command_Timeout 0x0032 100 099 000 Old_age Always - 1
189 High_Fly_Writes 0x003a 100 100 001 Old_age Always - 0
190 Airflow_Temperature_Cel 0x0022 064 043 040 Old_age Always - 36 (Min/Max 32/37)
191 G-Sense_Error_Rate 0x0032 100 100 000 Old_age Always - 8522
192 Power-Off_Retract_Count 0x0022 100 100 000 Old_age Always - 4325442
193 Load_Cycle_Count 0x0032 082 082 000 Old_age Always - 188039
194 Temperature_Celsius 0x0022 064 043 040 Old_age Always - 36 (Min/Max 32/37)
196 Reallocated_Event_Count 0x0032 100 100 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 100 100 000 Old_age Always - 0
199 UDMA_CRC_Error_Count 0x0032 200 253 000 Old_age Always - 0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error

1 Short offline Completed without error 00% 12974 -

2 Short offline Completed without error 00% 12972 -

SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

Any help would be greatly appreciated!

1 Like

Welcome to the Forum! :smiley:

I have read that some btrfs mount options (or maybe just one) may have as a side effect to make mechanical drives spin more. I just googled and couldn't find again which one.

On the other hand maybe Garuda detects the mechanical drive during installation and provides the proper mount options to begin with (I do not know the answer to that) so your issue would be elsewhere.

3 Likes

Check if something like baloo is in action.

8 Likes

Thanks for your suggestions!

I will Google around to see if I can find anything about btrfs mount options.

Disabling baloo does not seem to help. It was only indexing my user home folder (which is on the SSD) anyway.

1 Like

Did you set up the fstab entry that is mounting this device, or was it set up by a software?

Can you post:

lsblk -f

and also copy/paste your fstab:

micro /etc/fstab
2 Likes

Just a note for inexperienced users, if you accidentally change the fstab, with sudo micro, the next boot might fail.

At the moment, fstab is not to be changed. :slight_smile:
Just

micro /etc/fstab

or

cat /etc/fstab
4 Likes

That is a good note; I have posted the edit! :slightly_smiling_face:

3 Likes

Here's the info:

NAME   FSTYPE FSVER LABEL     UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda
├─sda1 vfat   FAT32 SYSTEM    4C69-DF61                             174,4M    32% /boot/efi
├─sda2
├─sda3 ntfs3                  1EFADA78FADA4C21
├─sda4 ext4   1.0             9070f3a5-1ea8-4ea8-9075-29604617a3a9
└─sda5 btrfs                  220d401c-e739-49f7-b37b-c9837e340ce5   10,8G    78% /var/tmp
/var/log
/var/cache
/srv
/root
/home
/
sdb
├─sdb1
├─sdb2 ntfs3                  F2F26ABAF26A82A9
├─sdb3 ntfs3        DATA      A4F26A3FF26A1638                       33,8G    96% /home/data
├─sdb4 ext4   1.0   EXT4 Data c7da47df-5f03-4215-881e-072a05d77a9c    9,3G    57% /home/ext4-data
├─sdb5 swap   1     Swap      51a6eef4-e7fa-4004-9def-290a915f1c06                [SWAP]
└─sdb6 ntfs3        RECOVERY  58A26C77A26C5C0E
zram0                                                                             [SWAP]

The lines at the end is custom stuff to mount some partitions on the HDD. The rest should all be on the SSD.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4C69-DF61                            /boot/efi      vfat    umask=0077 0 2
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /              btrfs   subvol=/@,defaults,noatime,autodefrag,compres
s=zstd,discard=async,ssd 0 0
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /home          btrfs   subvol=/@home,defaults,noatime,autodefrag,com
press=zstd,discard=async,ssd 0 0
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /root          btrfs   subvol=/@root,defaults,noatime,autodefrag,com
press=zstd,discard=async,ssd 0 0
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /srv           btrfs   subvol=/@srv,defaults,noatime,autodefrag,comp
ress=zstd,discard=async,ssd 0 0
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /var/cache     btrfs   subvol=/@cache,defaults,noatime,autodefrag,co
mpress=zstd,discard=async,ssd 0 0
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /var/log       btrfs   subvol=/@log,defaults,noatime,autodefrag,comp
ress=zstd,discard=async,ssd 0 0
UUID=220d401c-e739-49f7-b37b-c9837e340ce5 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,autodefrag,comp
ress=zstd,discard=async,ssd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
# Binderfs Anbox
none /dev/binderfs binder nofail 0 0

UUID=A4F26A3FF26A1638                       /home/data        ntfs    noatime,uid=1000,gid=1000,umask=000   0
0
UUID=c7da47df-5f03-4215-881e-072a05d77a9c   /home/ext4-data   ext4    noatime                               0
2
UUID=51a6eef4-e7fa-4004-9def-290a915f1c06   none              swap    defaults 0 0

I also managed to make some audio recordings today. Maybe that helps pinpoint the source.
Normal
Garuda

One more thing I figured out: the sound can be reliably stopped for a few seconds if I unplug the power cord. No idea what that could mean :upside_down_face:

Probably cuz the laptop is going in battery saver mode.

Is Manjaro using BTRFS?

I would add the output of findmnt -l to your post, as this will give the exact mount options instead of "defaults" from the fstab file.

Also, what is the use of that HDD?
It hosts Garuda but are you mostly reading/writing small to medium files or you are also into much larger ones, like VM machines, disk images and Databases? (big files that get often modified)

Sorry I am unable to download your sound clips, there's a javavoid I can't figure out (Firedragon). :frowning:

EDIT: After the above, my next steps would be to identify what process(es) are reading or writing to disk.
For that, iotop is great, but lsof, strace, fatrace (I know this one sounds funny) are also usable but try iotop first. I believe none are pre-installed with Garuda (at least not from my 20210101 ISO).

1 Like

Hmm, I agree that does not sound good. If it weren't for the fact that the disk is acting normal on the other OS, I'd be convinced you have a failing disk on your hands.

Other than the disconcerting noise, is the disk behaving normally? Are you able to read files off of the disk? Are you able to write files to the disk?

Are you able to write files to the NTFS disk from Linux?

This might be a long shot, but:

UUID=A4F26A3FF26A1638                       /home/data        ntfs    noatime,uid=1000,gid=1000,umask=000   0

Try changing ntfs to ntfs3.

I do not know if it will make any difference (I do not use NTFS, so a lot of its mechanisms are rather mysterious to me), but I believe that is the correct mount option these days.

Nope.

So the strange thing is, Garuda is on the SSD, not the HDD.
The NTFS partition mainly hosts video, music and some old projects I don't actively work on anymore. Maybe something to note here is that I have a symlink from my user profile directory (on the SSD) to the old projects directory (on the HDD). I might try removing that temporarily.
The ext4 partition hosts my Docker and Stack roots. None of the Docker containers start automatically.
And finally, there is a small swap partition of 4GB.

I think so. I'm having some other weird issues on Garuda, but I don't think any of these are coming from a misbehaving HDD. At least I can read and write as normal.

I rebooted without the HDD mounts from the fstab just now, but the noise was still there (possible a bit less, but that could also be my imagination). This is what findmnt -l looks like now.

Mounts
TARGET               SOURCE           FSTYPE     OPTIONS
/proc                proc             proc       rw,nosuid,nodev,noexec,relatime
/sys                 sys              sysfs      rw,nosuid,nodev,noexec,relatime
/dev                 dev              devtmpfs   rw,nosuid,relatime,size=8081784k,nr_inodes=2020446,mode=755,i
/run                 run              tmpfs      rw,nosuid,nodev,relatime,mode=755,inode64
/sys/firmware/efi/efivars
efivarfs         efivarfs   rw,nosuid,nodev,noexec,relatime
/dev/pts             devpts           devpts     rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
/                    /dev/sda5[/@]    btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/sys/kernel/security securityfs       securityfs rw,nosuid,nodev,noexec,relatime
/dev/shm             tmpfs            tmpfs      rw,nosuid,nodev,inode64
/sys/fs/cgroup       cgroup2          cgroup2    rw,nosuid,nodev,noexec,relatime,nsdelegate,memory_recursivepr
/sys/fs/pstore       pstore           pstore     rw,nosuid,nodev,noexec,relatime
/sys/fs/bpf          bpf              bpf        rw,nosuid,nodev,noexec,relatime,mode=700
/proc/sys/fs/binfmt_misc
systemd-1        autofs     rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,dire
/dev/binderfs        none             binder     rw,relatime,max=1048576
/dev/mqueue          mqueue           mqueue     rw,nosuid,nodev,noexec,relatime
/dev/hugepages       hugetlbfs        hugetlbfs  rw,relatime,pagesize=2M
/sys/kernel/config   configfs         configfs   rw,nosuid,nodev,noexec,relatime
/sys/kernel/tracing  tracefs          tracefs    rw,nosuid,nodev,noexec,relatime
/sys/kernel/debug    debugfs          debugfs    rw,nosuid,nodev,noexec,relatime
/tmp                 tmpfs            tmpfs      rw,noatime,inode64
/var/tmp             /dev/sda5[/@tmp] btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/var/log             /dev/sda5[/@log] btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/srv                 /dev/sda5[/@srv] btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/var/cache           /dev/sda5[/@cache]
btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/root                /dev/sda5[/@root]
btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/home                /dev/sda5[/@home]
btrfs      rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,a
/boot/efi            /dev/sda1        vfat       rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=asci
/run/user/1000       tmpfs            tmpfs      rw,nosuid,nodev,relatime,size=16056320k,nr_inodes=405462,mode
/run/user/1000/doc   portal           fuse.porta rw,nosuid,nodev,relatime,user_id=1000,group_id=1000

I didn't have time to look at iotop this morning, but I'll give an update when I do.

I'm also wondering if the sound couldn't be caused by anything else, because everything I've tried so far had so little effect. Maybe I'll try to open up my laptop this weekend.

Oh boy sorry I missed that.

In the findmnt -l I don't see your ntfs disk mounted, there is no ntfs nor /home/data mounted. Maybe it wasn't mounted when you typed the command?

Are you able to see the HDD led blinking for that specific disk? If yes, what's the blink frequency?

1 Like

It is likely Manjaro is using different kernels, and possibly a different I/O scheduler. I would try switching one /both to see if there is a difference.

This could also possibly be a sound that is occurring when your drive has spun down and then is restarted. Perhaps Manjaro is using different settings for power saving. This could mean the timings are different on when the drive is put to sleep. You could try changing that setting using hdparm. However, some drives don't seem to respond to changes using hdparm.

Is it possible you host your images on this drive? Perhaps the drives is being accessed when the wallpaper image is changed, (if you have customised your wallpaper location).

Good luck, because IMO drives that are making noises, (even if they passed testing) are heading for problems down the road.

1 Like

I can't 100% pinpoint that sound, but at least to me it sounds more of a coil wine or a failing fan. (Could be from a deference in fan curves or something?)

Yes, try removing the HDD temporary to try to isolate where the noise is coming from.

1 Like

Check if you have

performance-tweaks

Installed if so removed that and reboot

4 Likes

Yes, I ran the command after I commented out the custom HDD stuff from fstab.

Good idea! It blinks with more or less the same frequency as when using Manjaro. It's becoming less and less likely this is a HDD issue.

What would be the best approach to this? Finding their kernel build files and build it locally?

This is the case, but I wouldn't expect continuous noise from this.

I'm also doubting that it's the HDD more and more, but these 2 seem unlikely, because the power adapter and fan are located on the sides of the laptop and the sound is coming from the center.
I will try to open up the laptop in the weekend so I can locate the sound more precisely and take components out to debug further.

I don't have it installed, but I'm happy to learn of it's existence. Any reason it's not installed by default?

Thanks for thinking along everyone! I'm sure we'll figure it out at some point :slight_smile:

Not everyone needs it.
Not everyone wants it.

garuda-assistant - settings.

I super highly doubt this is a HDD issue caused by software, cuz if software would over-utilize the disk, it would make it read/write more, therefore the led would blink more. Personally I haven't seen this theory broken, but there's still a chance I may be wrong.
To test this, iotop would help.

Cuz you have a laptop and for those I believe most of the time it's the power-profiles-daemon that are installed rather than performance-tweaks.

I think you are at a point where you should open it up and pinpoint the location of that sound.
And if possible disconnect completely the HDD and see what happens.

2 Likes

I finally managed to open it up and have a look. I can confirm it's not the HDD, but I'm not sure yet which component is the problem.
I marked the area the sound is coming from in the image below.

My first guess would be the large component under the heat conductor, but I'm not sure if that would be the GPU or CPU. For all I know it could also be any of the smaller components in that area though.

I messed around with GPU drivers a bit to see if that would fix it (and that was actually a difference with my Manjaro), but to not avail. I tried several mhwd configs including plain video-linux, video-modesetting, video-nvidia-prime-render-offload and video-optimus-manager. With optimus-manager, I also tried all the options (hybrid, integrated and Nvidia).
On Manjaro, I was using video-hybrid-intel-nvidia-prime in combination with video-modesetting, but with older versions than mhwd lists on Garuda (2021-12-18 and 2020-01-13 respectively). I might try to make these versions match exactly when I'm sure the GPU is actually the source of the noise.

Sadly, it seems I can't easily detach any of these components, but I hope this info give you all some more ideas for things I could try!

PS: the laptop model is HP Pavillion 15-ak113na

Hmm, so it is more of a coil-wine kind of thing traveling down the heat pipe? With hardware sound issues like that, probably the best you can do (without replacing the cooling) is see if you can adjust some fan curves. That and maybe check the screws near that plate that is circled to see if it is secured correctly. If none of that works, you would most likely would have to see about getting in-person repairs at a shop, as it would be easier for them to diagnose/repair.

3 Likes