Laptop doesnt shutdown

Hello all, recently I dual booted my Windows machine with Garuda OS as I was looking forward for Arch based OS. And I faced issues while shutting them down.
I tried the available guide to reduce the shutdown tike to 5 and remoce the #, but unfortunately it didn't work for me.
I see the caps lock buttons colors getting turned on and of continuously and hence I used the main buttton to switch off.

can you provide your


as per the forum template


available guide


remove the #



Shoot in the blue,

sudo update-grub
1 Like

what do you mean by shoot in the blue?

Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c30620e0-87af-43f2-ab3f-82d276571f8d rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: FX505DT.316 date: 01/28/2021
ID-1: BAT0 charge: 18.2 Wh (51.7%) condition: 35.2/48.1 Wh (73.1%)
volts: 10.4 min: 11.7 model: FX50442 type: Li-ion serial: N/A
status: discharging
Info: model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64
type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108102
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1783 high: 2396 min/max: 1400/2100 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1465 2: 2395
3: 2396 4: 1242 5: 1227 6: 1400 7: 2044 8: 2100 bogomips: 33538
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-10)
arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s ports:
active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1f91
class-ID: 0300
Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: eDP-1 empty: none bus-ID: 05:00.0 chip-ID: 1002:15d8
class-ID: 0300 temp: 47.0 C
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 3-1:2 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting,nouveau
alternate: fbdev,nv,vesa dri: radeonsi,nouveau gpu: amdgpu display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: Najing CEC Panda 0x0036 built: 2018
res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.6 DRM 3.48
6.0.2-zen1-1-zen) v: 4.6 Mesa 22.2.1 direct render: Yes
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
IF-ID-1: enp5s0f3u2 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: Huawei YAL-AL00 type: USB driver: rndis_host v: kernel
bus-ID: 1-2:10 chip-ID: 12d1:108a class-ID: 0a00 serial: <filter>
Device-2: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
Report: ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 476.94 GiB used: 7.81 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLQ512HALU-00000 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: FXV7000Q temp: 29.9 C scheme: GPT
ID-1: / raw-size: 75 GiB size: 75 GiB (100.00%) used: 7.78 GiB (10.4%)
fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 29.5 MiB
(30.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 75 GiB size: 75 GiB (100.00%) used: 7.78 GiB
(10.4%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 75 GiB size: 75 GiB (100.00%) used: 7.78 GiB
(10.4%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 75 GiB size: 75 GiB (100.00%) used: 7.78 GiB
(10.4%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.58 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 47.5 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: amdgpu temp: 47.0 C device: nouveau temp: N/A
Processes: 258 Uptime: 16m wakeups: 1 Memory: 13.59 GiB used: 2.56 GiB
(18.8%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1137 libs: 301
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2023-02-05
Last full system update: 2023-02-05
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Is partially upgraded: Yes

This may be part of the problem, I suggest running garuda-update, reboot, then the above mentioned sudo update-grub followed by reboot again.
It won't necessarily fix the issue (perhaps, perhaps not) but it rules out a whole class of problems arising from the partial upgrade or GRUB installation.

While at it, I remind to always upgrade with the garuda-update command, not just pacman -Syu or some other tool.

what do you mean by shoot in the blue?

Idiomatic expression equivalent the more common "shot in the dark", an attempt at hitting something you can't see. Some times the problem is clearly identified, some other times one has to guess and try a few likely steps to reach a solution.


Thank you for your guide, but I've installed it yesterday itself, in dual boot I'm unaware of many things.
After the installation was completed, i was prompted with garuda assistance asking for upgrade/update something, which i tried numerous times but it gave me some sort of error while installing it had some email ids and signature related thing. I tried read other queries similar to mine but none worked. And now today i see i am unable to connect to wifi, so i used using usb tethering but i have limited Internet so I'll have to fins another way if your upcoming solution on this needa good amount of wifi or Internet

And somehow, i see shutdown problem is resolved, maybe because of Internet nlt connected or something but I'll post an uodate on shutdown again after everything's working fine.

It would help greatly if you can remember or reproduce those error messages.
Something with "keyring" perhaps? Possibly caused by the connectivity problem.

This may be an unrelated problem, and I understand that upgrading on phone tethering is far from ideal. I see you correctly opened another thread for this, I'll reply there.


Yes i believe something related to keyrings, its was only after i tried garuda-update from cli or from theGaruda System Maintenance option. And this was the reason i wasnt able to upgrade it

1 Like


garuda-update remote fix


That's pretty cool, you have gen3 NVME, should boot or shut down in less than 30s.

Please share output

systemd-analyze blame

in the same format you shared inxi, that is enclose by 3 tilde, like

Also, please share the guide that you are referring to


do you need the complete output??

670ms plymouth-read-write.service
582ms plymouth-start.service
467ms dev-nvme0n1p4.device
418ms plymouth-quit-wait.service
417ms plymouth-quit.service
392ms plymouth-deactivate.service
174ms [email protected]
162ms systemd-udev-trigger.service
159ms systemd-journal-flush.service
149ms boot-efi.mount
131ms dev-zram0.swap
128ms upower.service
114ms systemd-journald.service
106ms systemd-timesyncd.service
97ms systemd-oomd.service
92ms ModemManager.service
80ms systemd-logind.service
75ms systemd-tmpfiles-setup.service
67ms bluetooth.service
66ms systemd-udevd.service
61ms NetworkManager.service
57ms systemd-remount-fs.service
56ms systemd-tmpfiles-clean.service
54ms [email protected]\x2duuid-1830\x2dE53E.service
53ms lvm2-monitor.service
52ms avahi-daemon.service
52ms udisks2.service
47ms systemd-vconsole-setup.service
43ms power-profiles-daemon.service
42ms home.mount
42ms polkit.service
40ms root.mount
38ms srv.mount
38ms [email protected]
38ms [email protected]
35ms systemd-tmpfiles-setup-dev.service
34ms tmp.mount
33ms systemd-modules-load.service
32ms var-cache.mount
31ms garuda-pacman-snapshot-reject.service
30ms dbus.service
28ms [email protected]
25ms var-log.mount
23ms dev-hugepages.mount
23ms dev-mqueue.mount
23ms var-tmp.mount
22ms sys-kernel-debug.mount
21ms garuda-pacman-lock.service
21ms sys-kernel-tracing.mount
20ms kmod-static-nodes.service
19ms [email protected]
19ms [email protected]
18ms linux-modules-cleanup.service
17ms systemd-rfkill.service
17ms wpa_supplicant.service
16ms systemd-random-seed.service
15ms [email protected]
15ms [email protected]:asus::kbd_backlight.service
13ms [email protected]:amdgpu_bl1.service
12ms systemd-update-utmp.service
9ms systemd-sysctl.service
7ms systemd-user-sessions.service
7ms sys-kernel-config.mount
6ms rtkit-daemon.service
3ms sys-fs-fuse-connections.mount

the wifi option is enabled, thank to this command

garuda-update remote fix

and somehow it still takes alot of time to shutdown.

also ppl, when i initially open the terminal for the first time after a reboot or just turning on the laptop, it takes a bit more time than usual.
while from the second time onwards the process is at normal speed.

few minutes back i tried to restart and it was stuck on a terminal like full black screen with something similar to this written

[ some random float nos ] nouveau 0000:01:00.0: timer: stalled at ffffffffffffffff

random nos like:

so eventually had to use the power button to shutdown the computer, and i am using power button to shutdown most of the time to shutdown garuda os, none of the previous linux os dual boots gave me this error

Do you have a reason for using Nouveau?


so how long is a long time?
or hours?

1 Like