Laptop constantly sleeps when using linux-hardened kernel

Hello,

I'm trying to use the linux-hardened kernel with Garuda Linux on the Gnome DE. My laptop is a 2021 Razer Blade Pro 15 Advanced Edition with an nVidia RTX 3080 GPU. After logging into Gnome with the linux-hardened kernel, the laptop constantly sleeps after about 15 seconds. I can wake the laptop and sign in again, but I'll always be automatically put into sleep mode after 15 seconds, even if I'm actively moving the cursor. I'm not quite sure what I should be doing to troubleshoot this.

It should be hardened kernel specific issue. So, I will say, choose never sleep option in GNOME. Try

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Or search on your favorite search engine on how to disable GNOME sleep.

And welcome to the community.

2 Likes

Verify the standard kernels work, then find out whether an older linux-hardened works. Check the Arch bug tracker for related issues.

If you then want to verify this is an issue with the linux-hardened kernel, install Arch on the laptop, verify the issue persists, then open a new bug report if there isn't one.

If there is an older version that works then you can bisect the kernel to find out exactly which change(s) caused the problem.

4 Likes