Language part in french, part in english

Hey all,

I made a fresh install of Garuda KDE version. But this time i have a problem with the language... Part of the system is in french and part is in englsih...
It seems like all is set with fr_CH.utf8, but...

What am i doing wrong ?

Here's my inxi

System:
  Kernel: 6.0.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5a2ed686-9f3f-4d1c-a51e-41bbeea7c18c
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 20FRS08T00 v: ThinkPad X1 Carbon 4th
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: LENOVO model: 20FRS08T00 v: SDK0J40697 WIN serial: <superuser required> UEFI: LENOVO
    v: N1FET80W (1.54 ) date: 07/29/2022
Battery:
  ID-1: BAT0 charge: 45.3 Wh (95.4%) condition: 47.5/52.1 Wh (91.2%) volts: 16.2 min: 15.2
    model: SMP 00HW029 type: Li-poly serial: <filter> status: not charging
  Device-1: wacom_battery_0 model: Wacom Pen and multitouch sensor serial: N/A charge: 0%
    rechargeable: yes status: N/A
CPU:
  Info: model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake gen: core 6 level: v3
    note: check built: 2015 process: Intel 14nm family: 6 model-id: 0x4E (78) stepping: 3
    microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 3282 high: 3376 min/max: 400/3400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 3355 2: 3200 3: 3376 4: 3200 bogomips: 22399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel arch: Gen-9
    process: Intel 14n built: 2015-16 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:5 chip-ID: 04f2:b531
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x04aa built: 2015 res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2
    size: 309x174mm (12.17x6.85") diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 520 (SKL GT2)
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  Sound API: ALSA v: k6.0.10-zen2-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btu
sb v: 0.8 bus-ID: 1-7:4
    chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 462.07 GiB used: 84.92 GiB (18.4%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: 00000 size: 238.5 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSCKGF240A5L size: 223.57 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: LV8i scheme: GPT
Partition:
  ID-1: / raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 11.12 GiB (19.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 612 KiB (0.1%) fs: vfat
    dev: /dev/sda5 maj-min: 8:5
  ID-3: /home raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 11.12 GiB (19.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  ID-4: /var/log raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 11.12 GiB (19.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  ID-5: /var/tmp raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 11.12 GiB (19.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.62 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C pch: 37.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 220 Uptime: 46m wakeups: 3 Memory: 7.62 GiB used: 3.18 GiB (41.7%) Init: systemd
  v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1330
  libs: 364 tools: octopi,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.23
Garuda (2.6.10-1):
  System install date:     2022-12-02
  Last full system update: 2022-12-03
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

Here's my locale -a

C
C.UTF-8
en_US.utf8
fr_CH.utf8
POSIX

It must be so simple, that i cant find the solution by myself :wink:

Make sure they are uncommented in /etc/locale.gen and run a

sudo locale-gen

https://wiki.archlinux.org/title/Locale#Generating_locales
Check also chapter 4.2 for KDE there.

1 Like

Hi again,

Thanks for the response... I did it several times, but with no luck...

[[email protected] jacques]# locale-gen
Generating locales...
fr_CH.UTF-8... done
fr_CH.UTF-8... done
Generation complete.
[[email protected] jacques]#

I'm checking your link...

Everything seems to be ok also with locale

LANG=fr_CH.UTF-8
LC_CTYPE="fr_CH.UTF-8"
LC_NUMERIC=fr_CH.UTF-8
LC_TIME=fr_CH.UTF-8
LC_COLLATE="fr_CH.UTF-8"
LC_MONETARY=fr_CH.UTF-8
LC_MESSAGES="fr_CH.UTF-8"
LC_PAPER=fr_CH.UTF-8
LC_NAME=fr_CH.UTF-8
LC_ADDRESS=fr_CH.UTF-8
LC_TELEPHONE=fr_CH.UTF-8
LC_MEASUREMENT=fr_CH.UTF-8
LC_IDENTIFICATION=fr_CH.UTF-8
LC_ALL=

Hi again,

Without a solution, i tried to create a new user, and guess what... KDE is fully in french... So... :saluting_face:

But one problem still remains... Impossible for me to have latte-dock in french...
When i right click on the panel above, configure latte, help, configure your language, i only have en_US.

Impossible to set it in french... If you have an idea... :pray: :pray: :pray:

Are you sure there is a translation for latte-dock? If not, then it won't have french. :person_shrugging:

1 Like

Apparently there is French localization: latte-dock/po/fr at master · KDE/latte-dock · GitHub

3 Likes

Hi!

I had the same issue with latte-dock and the german translation. I just fixed it by installing the git-version.

sudo pacman -R latte-dock && sudo pacman -S latte-dock-git

Then log out and log in. This fixed it for me.

3 Likes

Hi,

That is the right thing to do, thanks a lot mate :heart_eyes:

1 Like

Just only me?

error: failed retrieving file 'latte-dock-git-0.10.6.r302.g4ec72572-1-x86_64.pkg.tar.zst' from us-va-4-mirror.chaotic.cx : The requested URL return
ed error: 404

Hi SGS,

No problem for me on two different pcs...

[[email protected] jacques]# pacman -S latte-dock-git
avertissement : latte-dock-git-0.10.6.r303.g8783d075-1 est à jour -- réinstallation
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) latte-dock-git-0.10.6.r303.g8783d075-1

Taille totale installée :      6.54 MiB
Taille de mise Ă  jour nette :  0.00 MiB

:: Procéder à l’installation ? [O/n]

:thinking: :thinking: :thinking:

1 Like

Not even mentioned here.
https://status.chaotic.cx/
:thinking:

1 Like

Hi,

I'm using the server for Switzerland...

The Chaotic-Router works, but ... :slight_smile: nothing reaches me.

Switzerland has a chaotic-mirror???

Hi,

That's just the one i selected in the mirrorlist... Don't know if the same is used for chaotic...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.