Laggy pc and one thread always at 100%

No hard feelings at all! I'd like to give you the whole code but as I said before for some reason I can't copy all the lines. But once I go back to my pc I'll be happy to give you the code you asked me in your second to last reply!
By the way I tried booting a new iso from my flash drive, but this problem (cores alternating at 100%) was still there...

Now that's interesting... :thinking:

1 Like

Yeah it turned out quite interesting lol
Next thing I'm gonna do (after I go back to the pc) is check Windows, hopefully it's not hardware related

So, I tried with Windows and it doesn't seem like any of the cores are under particularly more stress than others:


I also tried it on two different distros, and it still gave me these weird core escalations:

Here core 1 went completely nuts lol:

So, I'm not sure what to do, that seems rather weird...

Here's the whole grub:

# GRUB boot loader configuration

GRUB_DEFAULT="0"
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR="Garuda"
GRUB_CMDLINE_LINUX_DEFAULT="quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off # Modified by garuda-migrations: ibt=off"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT=3

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
GRUB_DISABLE_OS_PROBER=false
GRUB_THEME="/usr/share/grub/themes/Vimix/theme.txt"

Also, I copied the first 1500 lines of the journald, here is the link.

I fixed it! I added pci=nomsi as a parameter to

GRUB_CMDLINE_LINUX_DEFAULT="quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off # Modified by garuda-migrations: ibt=off"

Now the cores are back at normal values. Thanks a lot everybody! Particularly to you, @BluishHumility!

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.