KWin crashed on me?

I was having a meeting using the Microsoft Teams application and playing Mahjong on the side out of sheer boredom where all of a sudden, everything turned black and then came back to normal when I was greeted with a message saying that KWin crashed. I pressed restart application but nothing happened. Now the "Wobbly Window" effect and "Genie" effect on my system doesn't work anymore. Is there a way to fix and get the animations to work again? All the effects are on, despite them being on it doesn't work. I tried restarting my system and that didn't fix it either. Any way to fix this?

Ya sure, turn on your compositor again, (and avoid M$ products like the plague). :rofl:

Sometimes logging off/on is required to re-enable the compositor's effects again.


Okay, I'll look around for a way to turn on the Compositor again. Thanks for your help.

How do I restart the compositor though?

Start KDE system-settings, in search line write "compositor", press restart (or simular, I am on i3 just now :wink: ) in the brown crash error window.


There is no obvious "Restart" button that I could find

I fixed it, I changed the scale method from accurate to smooth and then changed it back to accurate. And now it works. Thanks for your help!

1 Like

Then the compositor doesn't crash.

Read what I stated above on how I fixed the problem, thank you so much for your help.

After the last plasma update a few days back, KWin crashed once in my system. It was strange because I was moving file from internal hard disk to USB using dolphin at the time. Dolphin still worked but KWin crashed. Once. And this was the only time in 3 months of plasma Garuda. Could be a bug in the latest plasma. Haven't been able to reproduce it though. Compositor was turned off after I re-logged in. I enabled it and it was worked fine since then.

Slight hiccup. :stuck_out_tongue_closed_eyes:

P.S. I had sweet-kde as plasma theme. Been using Breeze-dark since then.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.